Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-04-2010, 03:43 PM   #1
Lithel
Scooby Newbie
 
Member#: 221307
Join Date: Aug 2009
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2007 Impreza
OBP

Default Unstable idle?

Quick question. I have noticed that in this one situation my idle is very unstable. Here's what happens:

- I am driving, but about to stop.
- I push down on the clutch and brake.
- Car starts slowing down and almost comes to a complete stop.
- As the car stops (still with clutch and brake pushed down) my idle will jump from 1k to right over 2k.

Just seems kinda weird to me, anyone else had this happen? Or have some explanation for what/why?
* Registered users of the site do not see these ads.
Lithel is offline   Reply With Quote
Old 06-04-2010, 04:15 PM   #2
vrusso
Scooby Specialist
 
Member#: 207074
Join Date: Mar 2009
Chapter/Region: BAIC
Location: Sacramento California
Vehicle:
2015 STI
You know you're jealous

Default

Could be TPS having issues. But for a 2007 I am not sure if thats the issue.
vrusso is offline   Reply With Quote
Old 06-04-2010, 05:01 PM   #3
J-Chow
Scooby Specialist
 
Member#: 104722
Join Date: Jan 2006
Chapter/Region: VIC
Location: Richmond, aka Hongerland
Vehicle:
2006 2.5i - SOLD
Gray

Default

^ that happens to me only on reverse (and its not consistent)

When I slow down at a traffic stop and the clutch is pushed down and I put into neutral, the revs drop almost near stalling point and rise up again to about 680-800rpm.

idk what it could be, but there seems to be an issue with idling of the NA imprezas more so than the turboed ones?
J-Chow is offline   Reply With Quote
Old 06-05-2010, 01:17 AM   #4
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

have you made any changes at all to the intake system or any vacuum/breather lines?
GrundleJuice is offline   Reply With Quote
Old 06-05-2010, 04:12 AM   #5
suex
Scooby Newbie
 
Member#: 243393
Join Date: Apr 2010
Chapter/Region: NESIC
Location: Foresdale
Vehicle:
o6 impreza rs
silver

Default

That happens to me every time I start it up, and some times when I'm coming to a stop...the dealer told me it sometimes happens, they can reset the idle, but it doesn't hurt it either....
suex is offline   Reply With Quote
Old 06-07-2010, 04:59 PM   #6
Lithel
Scooby Newbie
 
Member#: 221307
Join Date: Aug 2009
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2007 Impreza
OBP

Default

Only two mods that could affect this are:
- Air intake (RAM)
- Exhaust system

It's not a major "issue," I'm just curious.
Lithel is offline   Reply With Quote
Old 06-07-2010, 05:19 PM   #7
mr_subaru_rs
Scooby Newbie
 
Member#: 142872
Join Date: Mar 2007
Chapter/Region: W. Canada
Location: Calgary
Vehicle:
1999 Impreza 2.5RS
Silverthorn

Default

what type of intake do u have MAP or MAF?
mr_subaru_rs is offline   Reply With Quote
Old 06-08-2010, 01:01 AM   #8
Sir-Knight
Scooby Specialist
 
Member#: 73636
Join Date: Nov 2004
Chapter/Region: E. Canada
Location: the 'wa, ontario, canada
Vehicle:
2007 Impreza 2.5i SE
newport blue pearl

Default

07 is a MAF car.
Sir-Knight is offline   Reply With Quote
Old 06-08-2010, 11:25 AM   #9
Lithel
Scooby Newbie
 
Member#: 221307
Join Date: Aug 2009
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2007 Impreza
OBP

Default

I'm afraid it is e-Bay brand. It was on the car when I bought it and I can't see any identifiers on it at all.

Pic:

Lithel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unstable Idling Subaruuu06 Warranty Issues & SOA Problems 2 09-29-2008 02:28 PM
Unstable idle idle help.. WRXBob Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 02-10-2008 09:55 AM
does the bov's location cause unstable idling? qax Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 11-07-2006 08:01 AM
Bad gas? Unstable idle and stutter at low throttle. RigdenZW Normally Aspirated Powertrain 54 12-11-2003 07:03 PM
Unstable Idle? khai yang Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 01-11-2002 02:48 PM


All times are GMT -4. The time now is 04:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.