Welcome to the North American Subaru Impreza Owners Club Wednesday April 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-05-2010, 01:34 PM   #1
sixthgearjunkie
Scooby Newbie
 
Member#: 219497
Join Date: Aug 2009
Location: HAmilton,VA
Vehicle:
1997 Impreza L
Black

Default Strange noises causing potential problems!! help please!

so recently i have this new issue with my 97 impreza 2.2 l
whenever i start up the car i hear a squeaking noise like something rotating around and squeaking though this is usually only when i start up and every once in a while while it idles. I figure it is a belt as it sounds like it. And an even more pressing issue where every once in a while while im driving, the engine will "hiccup" and i will hear one of those squeaks only for a moment. i believe it is a belt, but does anyone else have any other ideas? if it is a belt can i replace it myself having little mechanical experience? i just took the thing out of the shop i can't afford for it to go back in.
* Registered users of the site do not see these ads.
sixthgearjunkie is offline   Reply With Quote
Old 06-05-2010, 07:02 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

start her up and pop the hood. listen for squeals. You can apply belt dressing if you like, but that's more like a band-aid. The proper thing to do is tighten the belt(s). Search on it in the maintenance forums, it's really easy to tighten. Just be sure to loosen the locking nut first.

Oh, and the fact that the engine hiccups during a squeak points me to the alternator/PS belt as the culprit.....unless you have the AC on at the time.
yarrgh is offline   Reply With Quote
Old 06-05-2010, 10:46 PM   #3
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by yarrgh View Post
Oh, and the fact that the engine hiccups during a squeak points me to the alternator/PS belt as the culprit....
Not sure how either the alternator or PS would cause the engine to hiccup, as both of them are operating continuously. If this problem only happens periodically it's almost certainly the A/C kicking on, and the A/C compressor most definitely puts enough load on the engine to be able to feel it kick on.

Pat Olsen
Patrick Olsen is offline   Reply With Quote
Old 06-05-2010, 10:48 PM   #4
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by sixthgearjunkie View Post
if it is a belt can i replace it myself having little mechanical experience? i just took the thing out of the shop i can't afford for it to go back in.
Yes, belt replacement is very simple. You'll just need 10mm and 12mm wrenches/sockets and you'll be good to go.
Patrick Olsen is offline   Reply With Quote
Old 07-04-2010, 05:36 PM   #5
sixthgearjunkie
Scooby Newbie
 
Member#: 219497
Join Date: Aug 2009
Location: HAmilton,VA
Vehicle:
1997 Impreza L
Black

Default

It was the A/C compressor belt! thanks!
sixthgearjunkie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So i clear my headlights... now strange problem! Help please! pics included! litowrx Electrical & Lighting 22 05-25-2009 07:10 PM
Cam potential, little help please Jpizzzle Built Motor Discussion 1 03-20-2008 11:58 AM
Idling problems and wierd Cel problem.. Help please SPOOLME Factory 2.0L Turbo Powertrain 4 01-26-2008 02:07 PM
Strange noise at 1500-3200 rpm.. please help!? theperfectK20 Service & Maintenance 0 12-11-2007 10:13 PM
Strange noise comming from engine bay...Please help UndertoW101 Warranty Issues & SOA Problems 13 11-21-2005 11:53 AM


All times are GMT -4. The time now is 10:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.