Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-26-2010, 11:14 AM   #1
Odin2347
Scooby Newbie
 
Member#: 244027
Join Date: Apr 2010
Location: Staten Island NY
Vehicle:
2010 WRX
DGM

Default 2010 WRX crazy noise after clutch install

Hey I had my clutch replaced under warranty by the dealer on my 2010 4 dr(7k miles) they said it was a faulty clutch. I got the car back from the dealer and today I notice when I start building boost at around 3-4k rpms I hear the turbo alot louder and then a loud whining/screeching/whooshing noise that sounds like air leaking rapidly and the car seems to pull rather sluggishly. I have no clue what could have happened. any ideas? I think it could be an exhaust leak. Do they touch the exhaust during a clutch install?
* Registered users of the site do not see these ads.
Odin2347 is offline   Reply With Quote
Old 06-26-2010, 02:23 PM   #2
424wrx
Scooby Specialist
 
Member#: 171948
Join Date: Feb 2008
Chapter/Region: Tri-State
Location: new york
Vehicle:
2008 vf52wrx12.6@108
11 forester,14 legacy

Default

get back to the dealer asap. the car is new and they just worked on it.
424wrx is offline   Reply With Quote
Old 06-26-2010, 05:59 PM   #3
Odin2347
Scooby Newbie
 
Member#: 244027
Join Date: Apr 2010
Location: Staten Island NY
Vehicle:
2010 WRX
DGM

Default

I plan on taking it on monday. Do you think it's OK to drive in the meantime?
Odin2347 is offline   Reply With Quote
Old 06-26-2010, 06:03 PM   #4
stikid2005
Scooby Specialist
 
Member#: 76228
Join Date: Dec 2004
Chapter/Region: Tri-State
Location: Tri-State NJ
Vehicle:
2005 STI (sold)
OBP Seibon carbon

Default

your uppipe is prob leaking. they most likly took it off during the the clutch job and didnt tighten it back up.

if you dont have to drive it dont. if you do stay out of boost till you can get it to the dealer
stikid2005 is offline   Reply With Quote
Old 06-26-2010, 06:09 PM   #5
Odin2347
Scooby Newbie
 
Member#: 244027
Join Date: Apr 2010
Location: Staten Island NY
Vehicle:
2010 WRX
DGM

Default

Would it be possible for me to tighten it myself if that is the issue? that would save alot of gas and toll $$$ as the dealer is over the bridge from me in brooklyn
Odin2347 is offline   Reply With Quote
Old 06-26-2010, 06:43 PM   #6
stikid2005
Scooby Specialist
 
Member#: 76228
Join Date: Dec 2004
Chapter/Region: Tri-State
Location: Tri-State NJ
Vehicle:
2005 STI (sold)
OBP Seibon carbon

Default

well... i would check it, however... i would still take it to the dealer. spec if it happend because of somthing the dealer did. Also to cover yourself in case somthing goes wrong with it. you have a warrenty, use it! haha i wish i had one!
stikid2005 is offline   Reply With Quote
Old 06-27-2010, 01:42 AM   #7
kickniteasy
Scooby Specialist
 
Member#: 201661
Join Date: Jan 2009
Chapter/Region: RMIC
Location: C-Springs, CO
Vehicle:
2013 STI
2002 Forester

Default

Quote:
Originally Posted by Odin2347 View Post
Would it be possible for me to tighten it myself if that is the issue? that would save alot of gas and toll $$$ as the dealer is over the bridge from me in brooklyn

definitely take it to the dealer....you try something yourself and mess it up you could end up voiding your warranty. It's a free fix and while it may be a PITA to get there it'll be worth it just to say it's their fault.
kickniteasy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crude Transmission Deceleration and Acceleration Noise after Clutch/Flywheel Install caterpill Transmission (AT/MT) & Driveline 268 05-08-2014 12:33 AM
2010 WRX Sedan System After Market Install (Alpine) Help! qronos Car Audio, Video & Security 3 04-25-2010 10:53 AM
CRAZY noise after coilover install g00dhum0r Brakes, Steering & Suspension 14 07-28-2008 12:56 AM
Seeking Input: Bad noise after clutch install mx_9 Transmission (AT/MT) & Driveline 3 06-04-2007 02:13 PM
Crazy noise after Uppipe install??? swilson Factory 2.0L Turbo Powertrain 17 06-11-2004 04:27 AM


All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.