Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-01-2010, 10:15 PM   #1
kirbykirb
Scooby Newbie
 
Member#: 183596
Join Date: Jul 2008
Chapter/Region: South East
Location: USA
Vehicle:
2005 WRX/9-2x
Obsedian Black Pearl

Default Killed a EJ25 :( Sad youtube vids showing the aftermath.

* Registered users of the site do not see these ads.
kirbykirb is offline   Reply With Quote
Old 07-01-2010, 10:59 PM   #2
cmiovino
Scooby Guru
 
Member#: 134005
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2004 WRX Premium
PSM

Default

Ouchies.

Sooooo, what did you do wrong when you changed the oil to cause this? Too much, too little?
cmiovino is offline   Reply With Quote
Old 07-01-2010, 11:08 PM   #3
kirbykirb
Scooby Newbie
 
Member#: 183596
Join Date: Jul 2008
Chapter/Region: South East
Location: USA
Vehicle:
2005 WRX/9-2x
Obsedian Black Pearl

Default

Quote:
Originally Posted by cmiovino View Post
Ouchies.

Sooooo, what did you do wrong when you changed the oil to cause this? Too much, too little?

That's the thing, I did nothing wrong! NOTHING.

Capacity is 4.7L so I used 5 quarts. Turned it over and THIS.
kirbykirb is offline   Reply With Quote
Old 07-01-2010, 11:40 PM   #4
Wrencher86
Scooby Newbie
 
Member#: 250463
Join Date: Jun 2010
Location: Evanston, Il
Vehicle:
2010 Impreza 2.5i
Silver

Default

Just tell everyone you did a diesel swap.

That sucks.
Wrencher86 is offline   Reply With Quote
Old 07-02-2010, 12:35 AM   #5
Jaren1
Scooby Specialist
 
Member#: 195061
Join Date: Nov 2008
Chapter/Region: NWIC
Location: Cool story, Brogue
Vehicle:
1997 \_(ツ)
Green

Default

thats odd. Obviously there is some underlying cause that made the bearing spin. Just doing an oil change and changing it properly shouldnt risk spinning a bearing or else a lot of us wouldnt risk doin them ourselves
Jaren1 is online now   Reply With Quote
Old 07-02-2010, 09:37 AM   #6
dstan
Scooby Specialist
 
Member#: 120386
Join Date: Jul 2006
Chapter/Region: South East
Location: Asheville NC
Vehicle:
2000 BRP 2.5RS Coupe
Wow the 89 Civic is fast

Default

ahh I have heard this sound recently
dstan is offline   Reply With Quote
Old 07-02-2010, 12:02 PM   #7
Gr3en
Scooby Specialist
 
Member#: 160991
Join Date: Oct 2007
Chapter/Region: MWSOC
Location: Gorillaoffroadcompany.com
Vehicle:
05 Corn Burner
Dirt Silver?

Default

I have metal shavings in my oil. I think it may be due to an oil change? Just happened 3 weeks ago.
Gr3en is offline   Reply With Quote
Old 07-02-2010, 12:03 PM   #8
imprezkid
Scooby Specialist
 
Member#: 71462
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: Des Moines, IA
Vehicle:
2001 2.5rs
STM

Default

Me too, mine happened as i had the cruise set on the highway, at least i believe this was the problem, still yet to pull it apart. I drove toward home till it seized up and then a little further, poor tranny.
imprezkid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Say a prayer for Milo the Roomba killing great dane :( kaisersouse Off-Topic 37 03-07-2013 10:40 AM
youtube vid Azn-Jap STI Vancouver Impreza Club Forum -- VIC 2 11-19-2007 12:40 AM
Some youtube vid of S-GT handling vs MS3 ptrout News & Rumors 121 08-24-2007 07:14 PM
Oh gawd! stop him he's posting a Youtube vid!!1!eleventy! (tom hanks James Bond vid) Gerkins31 Off-Topic 8 07-23-2007 06:23 PM
The Crocodile Man, Killed by Stingray :( KanosWRX Mid Atlantic Impreza Club -- MAIC 30 09-05-2006 11:35 AM


All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.