Welcome to the North American Subaru Impreza Owners Club Saturday July 30, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-03-2010, 03:16 AM   #1
Impact.blue
Scooby Newbie
 
Member#: 226569
Join Date: Oct 2009
Chapter/Region: VIC
Location: Richmond
Vehicle:
2013 WRX STi
World Rally Blue

Default check engine light on and fuel gauge reads E

hello everyone.

heres the the simple story, came home after a relax cruise and the as i was about to turn my car off my check engine light came on and my fuel gauge drop (it had 3/4 tank which is still in my car, therefore it didnt just leak away)

im guessing its a sensor? everything else works fine.

any opinion, suggestion and solution would be very helpful.

thanks for reading/helping.
* Registered users of the site do not see these ads.
Impact.blue is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-03-2010, 04:03 AM   #2
iht
Scooby Specialist
 
Member#: 196742
Join Date: Dec 2008
Chapter/Region: VIC
Location: Vancouver
Vehicle:
2000 Impreza 2.5rs
Silver

Default

time to go get a code reader and read whatever code was made. as long as you haven't reset the ECU yet you can see what code was made.
iht is offline   Reply With Quote
Old 07-03-2010, 08:18 AM   #3
bender
Scooby Specialist
 
Member#: 1839
Join Date: Jul 2000
Chapter/Region: VIC
Location: at home
Default

Quote:
Originally Posted by Impact.blue View Post
hello everyone.

heres the the simple story, came home after a relax cruise and the as i was about to turn my car off my check engine light came on and my fuel gauge drop (it had 3/4 tank which is still in my car, therefore it didnt just leak away)

im guessing its a sensor? everything else works fine.

any opinion, suggestion and solution would be very helpful.

thanks for reading/helping.
fuel sending unit. the code you are getting will probably be p0461
same thing happen to my car, and I've had a couple more that came into my shop with the same problem. I assume it's a common problem with the old school subies
bender is offline   Reply With Quote
Old 07-03-2010, 11:18 AM   #4
Loomin
Scooby Guru
 
Member#: 118113
Join Date: Jun 2006
Chapter/Region: VIC
Vehicle:
98' Stagea 260RS
Autech Ver.

Default

Quote:
Originally Posted by bender View Post
fuel sending unit. the code you are getting will probably be p0461
same thing happen to my car, and I've had a couple more that came into my shop with the same problem. I assume it's a common problem with the old school subies
bingo.
Loomin is offline   Reply With Quote
Old 07-03-2010, 01:56 PM   #5
Impact.blue
Scooby Newbie
 
Member#: 226569
Join Date: Oct 2009
Chapter/Region: VIC
Location: Richmond
Vehicle:
2013 WRX STi
World Rally Blue

Default

Quote:
Originally Posted by bender View Post
fuel sending unit. the code you are getting will probably be p0461
same thing happen to my car, and I've had a couple more that came into my shop with the same problem. I assume it's a common problem with the old school subies
so what did you have to fix/replace to solve this problem? its not a headache is it?

also thanks everyone for your input. My mind is more at ease than last night
Impact.blue is offline   Reply With Quote
Old 07-03-2010, 03:30 PM   #6
semaj
I'm sorry for apologizing
Moderatour
 
Member#: 113533
Join Date: Apr 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2006 Pathfinder
Off Road

Default

Quote:
Originally Posted by bender View Post
fuel sending unit.
Quote:
Originally Posted by Impact.blue View Post
so what did you have to fix/replace to solve this problem?
You have to replace the fuel sending unit, as bender mentioned.

It's $65.84 USD on Subaru Genuine Parts
semaj is offline   Reply With Quote
Old 07-03-2010, 03:34 PM   #7
Impact.blue
Scooby Newbie
 
Member#: 226569
Join Date: Oct 2009
Chapter/Region: VIC
Location: Richmond
Vehicle:
2013 WRX STi
World Rally Blue

Default

ah ok then.

thank you for your help
Impact.blue is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light on and cruise blinking? STIdrivr Electrical & Lighting 1 02-24-2007 08:38 PM
Check Engine light on and Weird Noise! AphexDouble Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 01-10-2007 03:14 PM
check engine light on and cruise flashing catass Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 23 07-08-2005 10:20 PM
Check engine light on and cruise control light flashing mpadovano Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 01-23-2005 02:04 PM
('93-'01) check engine light on and....... watcher in the sky Impreza Forum 27 01-13-2002 04:21 PM

All times are GMT -4. The time now is 11:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.