Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-07-2010, 08:26 PM   #1
mygreatgc8
Scooby Newbie
 
Member#: 230513
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Warrenton, Va
Vehicle:
2001 rs/wrx/sti swap
black

Impreza GC8 boost problems on my frankenstin

i have an 01 rs with a 06 wrx swap,ver 1 trans, header, up pipe, down pipe, and catback,. shorty ram intake, 3 core radiator, and a manual boost controller. now i put the boost controller on and it ran @ .90 bar, then i put an turboxs hybrid 50/50 bov, then my boost dropped to .65-.70, i put washers in i to make the spring tension higher to see if the boost change it didnt, so i put the stock one back on and still doing the same thing. any ideas? i get it tuned with an accessport on aug 2nd
* Registered users of the site do not see these ads.
mygreatgc8 is offline   Reply With Quote
Old 07-08-2010, 10:53 AM   #2
suberdave
NASIOC Supporter
 
Member#: 101865
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
88 GL-10 STi
silver

Default

i had a turboxs bov. it would not hold more than 12PSI without leaking. put an APS one on and have not had a problem since...

-=Suberdave=-
suberdave is offline   Reply With Quote
Old 07-08-2010, 01:36 PM   #3
FuJi K
Scooby Guru
 
Member#: 3687
Join Date: Jan 2001
Chapter/Region: MWSOC
Location: St. Paul, MN
Vehicle:
MY99 GF4 JDM 6spd
NF Performance

Default

Use an OEM BPV. If you would like.. run a better TMIC with silicone hoses oppose to the '06 WRX. Run OEM BPV. Also make sure ALL hoses and clamps are tight from turbo to the throttle body. Make sure all vacuum hoses are tight and not ripped. If anything run an OEM airbox. You get cooler air than the short ram and you're not maxing out the OEM MAF housing yet.

If you're still on the FACTORY turbo and factory ECU mapping, it doesn't boost high. The '06 WRX doesn't boost high like the EJ205.
FuJi K is offline   Reply With Quote
Old 07-08-2010, 07:20 PM   #4
mygreatgc8
Scooby Newbie
 
Member#: 230513
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Warrenton, Va
Vehicle:
2001 rs/wrx/sti swap
black

Default

now im right at .7-.73 ish, i got a cx racing intercooler, and installing my invidia divorced downpipe tomorrow, now im getting rid of my turboxs bov --100 shipped
mygreatgc8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost problem on 2.0GT WGTimpreza Factory 2.0L Turbo Powertrain 2 12-24-2009 01:11 PM
Boost problem on 04 WRX cbbwrx Factory 2.0L Turbo Powertrain 12 09-03-2009 10:34 PM
Boost problems on SZ49 KRZNQWK Mid Atlantic Impreza Club -- MAIC 18 11-20-2007 09:15 AM
Severe Boosting problems on SZ49 Sjerzey05sti Factory 2.5L Turbo Powertrain 22 03-19-2006 03:40 AM
Boost Problems on stock motor - help! Kickz107 Factory 2.0L Turbo Powertrain 4 10-21-2003 09:47 PM


All times are GMT -4. The time now is 04:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.