Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-29-2010, 11:29 PM   #1
subarumafia700
Scooby Newbie
 
Member#: 150288
Join Date: May 2007
Chapter/Region: NESIC
Location: North Ferrisberg, Vermont
Vehicle:
1998 Impreza Sedan
Dark Green

Default Clutch issue...random burning clutch smell

So i installed an F1 stage 2 clutch about 3500 miles ago with an F1 11lbs flywheel. Everything was brand new. The clutch is ment for a wrx, but its the same still as my 91 turbo tranny. I also have the 91 master and slave cylinder. I have been noticing a random clutch smell laitly, sometimes after a pull, sometimes just after cruising around and pulling into my parking spot. The clutch pedal seems to sometimes come off the floor a little slower then most times. Where should i start? master is a bit dirty fluids a little dark should i start with cleaning?
* Registered users of the site do not see these ads.
subarumafia700 is offline   Reply With Quote
Old 07-30-2010, 02:04 AM   #2
hybrid gti 2
Scooby Guru
 
Member#: 67004
Join Date: Jul 2004
Chapter/Region: SCIC
Location: (818) 200k+ ej205 ppg 5mt
Vehicle:
02 vf30 pnp wagon
silver and cf

Default

Yea I would start with clean fluid. Dot 3/dot 4 what ever it calls for. Auto parts store cheap stuff works fine. It sounds like your having a hydraulic issue. If the pressure still has issues. I would say master and slave time. It uses a pull style clutch. So the hydraulics is pretty much the only thing to cause this delay in the pedal.

The f1 stage 2 clutch
http://gripforce.com/store/index.php...roducts_id=396

I would say it should be broken in by now 3.5k. Kevlar clutches don't really smell much from my experience. Generally it slips or it works. As well it's pretty cheap of a clutch. Known to have some issues.

I say it a hydraulic issue. The lag time for the clutch to engage is causing extra wear. So fix it soon. Make sure you bleed it correctly.
hybrid gti 2 is offline   Reply With Quote
Old 08-02-2010, 05:50 PM   #3
subarumafia700
Scooby Newbie
 
Member#: 150288
Join Date: May 2007
Chapter/Region: NESIC
Location: North Ferrisberg, Vermont
Vehicle:
1998 Impreza Sedan
Dark Green

Default

ok thanks ill try, idk if i can break the bleeders free without breaking them, both slave and master are from a 91 turbo leg, and being that its vermont, rust goes havock
subarumafia700 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slipping clutch issue.. with new clutch kit, evsoul Transmission (AT/MT) & Driveline 7 09-05-2006 01:39 PM
Question for STi owners - burning clutch smell from reverse? avatarr Transmission (AT/MT) & Driveline 13 03-23-2004 09:19 AM
Burning clutch smell dragonglen Baja Forum 3 10-28-2003 11:20 PM
the smell of my burning clutch (or lack thereof) RChampion Transmission (AT/MT) & Driveline 4 09-10-2002 01:45 AM
ack! burning clutch = bad smell. Valien South East Region Forum 5 04-26-2002 11:14 PM


All times are GMT -4. The time now is 04:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.