Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-01-2010, 11:31 PM   #1
kempobmx1
Scooby Newbie
 
Member#: 238165
Join Date: Feb 2010
Chapter/Region: NESIC
Location: Framingham, MA
Vehicle:
2012 Nissan Xterra
Slate

Default 12v DC jack not connected. Missing part?

Hey guys. I have an 05 STi and there's nothing hooked up to the rear of my 12v DC jack. All that's in there is a white connector plug but nothing but, what look like, brass leads on the back of the plug. What part am I missing? Toomes and I have concluded there is obviously something missing there, and taking it to a dealer has proven useless (they charge an arm and three legs to take a look at it).
Ideas? Definitely need to get my radar detector running asap =P.
* Registered users of the site do not see these ads.
kempobmx1 is offline   Reply With Quote
Old 08-02-2010, 08:59 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

I believe they use a standard power connector back there just like the one up front. You should be able to purchase one at a parts store.
Cougar4 is offline   Reply With Quote
Old 08-02-2010, 11:00 PM   #3
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

Pictures would help...
Bluefoton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What is this part that is not connected!? Help please Dont Try To Run Factory 2.5L Turbo Powertrain 14 04-13-2009 09:56 PM
12v DC direct to DCCD? xCatch22x Transmission (AT/MT) & Driveline 5 05-18-2008 04:44 PM
Missing part of my jack in my sti? oilybirdy General Community 13 11-07-2007 06:36 PM
Carputer 1Ghz ITX 12v DC with 7" touch screen monitor pir800 Private 'For Sale' Classifieds 0 07-01-2005 10:49 PM
People that are 12v DC pros, please help. G3Red04WRX Electrical & Lighting 20 05-04-2005 11:48 PM


All times are GMT -4. The time now is 12:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.