Welcome to the North American Subaru Impreza Owners Club Saturday November 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-02-2010, 01:25 PM   #1
Mr. Adovnik
Scooby Newbie
 
Member#: 168464
Join Date: Jan 2008
Default 93 Legacy Wagon Clutch Problem

I have a 93 Legacy Wagon that has a clutch issue. A few months ago my brother drove it for a few days and when he returned it he said it kept popping out of my gear. My main mechanic friend and i both confirmed this and for several months the car sat since i was in no hurry to replace the clutch. The other day I went out to go drive it and it seemed fine in the driveway so I drove it from my in-laws house to mine. However, halfway home I could not shift and finally got kicked out of gear and into neutral and had to coast to the side of the road. Does this sound it just needs a new clutch/flywheel/pressure plate? Or is a bigger issue at hand? I know you guys are experts on these particular cars and I thought I'd run it by you so that I dont buy the wrong parts so the job can get done.

Thanks,
Ryan A
* Registered users of the site do not see these ads.
Mr. Adovnik is offline   Reply With Quote
Old 08-03-2010, 12:17 AM   #2
scobydo
Scooby Newbie
 
Member#: 253799
Join Date: Aug 2010
Chapter/Region: MWSOC
Vehicle:
93 Legacy

Default

that kind of problem is usually inside the transmission and not a clutch problem. atleast on other cars i have seen with that problem.
scobydo is offline   Reply With Quote
Old 08-06-2010, 03:50 PM   #3
95leggy
Scooby Newbie
 
Member#: 186737
Join Date: Aug 2008
Chapter/Region: MWSOC
Location: Tha Boonies
Vehicle:
1995 Legacy
Red

Default

sounds like the issue i had with my honda trans, shifter fork broke making it extremly hard to get it into gear and change gears......check the fluid could have been low and overheated warping something inside
95leggy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
seat belt problem..93 Legacy wagon coolbreeze Legacy Forum 0 04-30-2009 02:21 AM
Is there a direct turbo swap for my sisters car? its a 93 Legacy Wagon LS AWD Generalee01 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 08-23-2005 03:27 PM
93 Legacy turbo ignition problems?help! rickG888 Legacy Forum 5 04-13-2004 12:11 PM
90-93 legacy wagon Skibum4444 North West Impreza Club Forum -- NWIC 3 01-24-2004 05:43 PM
93 legacy wagon auto "turbo"!!!!! felix Legacy Forum 11 06-02-2000 01:15 AM


All times are GMT -4. The time now is 11:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.