Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-05-2010, 09:55 PM   #1
drummerRS2505
Scooby Newbie
 
Member#: 111331
Join Date: Mar 2006
Chapter/Region: MWSOC
Location: Omaha NE
Vehicle:
2005 Impreza 2.5 RS
OBP

Default prosport oil pressure gauge problem

Have three prosport gauges oil temp, oil press, fuel press. all been working fine for awhile. had a oil pressure sending unit go bad once, they sent me a new one and its been working fine for over a year.

Couple days ago i noticed my oil press gauge needle started flickering from normal readings to the max 120psi. then eventually it would always stay maxed out at 120 while running. checked all the wiring looks fine, connections were tight, the ground for the sender was okay and the entire wire from the gauge to the sender was fine, no shorts. what do you think another bad sender, bad gauge? gonna try and call prosport tommorow and look at the car again tomm or sat.

last time my sender was bad it would just read 0 at idle but come up to normal numbers with more rpm's. now it just reads max 120 after the sweep/dance.
* Registered users of the site do not see these ads.
drummerRS2505 is offline   Reply With Quote
Old 08-08-2010, 10:06 PM   #2
drummerRS2505
Scooby Newbie
 
Member#: 111331
Join Date: Mar 2006
Chapter/Region: MWSOC
Location: Omaha NE
Vehicle:
2005 Impreza 2.5 RS
OBP

Default

Called prosport, talked with a guy who didn't seem to care about helping me to much. he kept telling me to check my wiring and ground, and i said i did. and when he knew my gauge was not under the one year warranty then he really didn't care to help me out. i rechecked my wire from the gauge to the sender, it was fine. checked the ground wire from sender to chassis grnd, it was okay. checked resistance of the sending unit it self which spec on the website says 3-160 ohms mine was 4.365 Mega ohms almost a complete open circuit. so the sending unit is bad again, ordered a new one for $18.50

just updating my first post for search purposes for anyone who may have same problem.
I'll post back if it fixes it which i am sure it will
drummerRS2505 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Prosport Oil Pressure Sender Problems alpentalic Car Part Reviews 95 12-07-2013 06:16 PM
Problems with Prosport Oil pressure gauges 05Scooby Interior & Exterior Modification 22 03-06-2009 03:43 PM
Oil Sandwich Adaptor for Prosport Oil Pressure Gauge? SubyTR07 Interior & Exterior Modification 10 02-01-2008 05:58 PM
FS: Prosport oil pressure gauge (matches STi perfectly), and custom AL dead pedal! sticrazy Interior/Dressup/Audio & Security 12 10-18-2006 11:38 PM
Prosport oil pressure gauge, Clarion MP3 deck, and custom dead pedal all on Ebay!!!!! sticrazy Interior/Dressup/Audio & Security 11 10-04-2006 10:01 PM


All times are GMT -4. The time now is 12:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.