Welcome to the North American Subaru Impreza Owners Club Thursday March 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-07-2010, 02:02 PM   #1
ruckus82
Scooby Newbie
 
Member#: 246623
Join Date: May 2010
Chapter/Region: MWSOC
Location: STL
Vehicle:
2006 WRX TR
WRB

Default prosport oil gauge fail?

I washed my car and changed my oil, now the gauge is messed up! it starts out reading max press of like 160 pinned out and will sometimes drop to 0 and the alarm will go off saying i have no pressure. Is there a simple way I can locate the sender, I didnt wash the motor but im guessing the sender got wet durring the wash and now is faulty I dont know how to disable the alarm on it either so that I can still drive the car for the time being: im still new to the wrx and didnt install the gauges so im at a loss. I disconnected the battery and let everything reset but that didnt help either. Any help is appreciated!! thanks



btw the prosport boost gauge works great still lol
* Registered users of the site do not see these ads.
ruckus82 is offline   Reply With Quote
Old 08-07-2010, 03:39 PM   #2
ruckus82
Scooby Newbie
 
Member#: 246623
Join Date: May 2010
Chapter/Region: MWSOC
Location: STL
Vehicle:
2006 WRX TR
WRB

Default

Started the car up and the gauge worked just fine for a few minutes and the I drove down the street and the gauge dropped back to zero pressure and started beeping at me. I drove it hard to see if I could heat up te sender enough to burn off any water that was on it. Now it's sitting with the hood up in the sun
ruckus82 is offline   Reply With Quote
Old 08-07-2010, 08:17 PM   #3
ruckus82
Scooby Newbie
 
Member#: 246623
Join Date: May 2010
Chapter/Region: MWSOC
Location: STL
Vehicle:
2006 WRX TR
WRB

Default

Started it up after it sat in the sun for a few hours, it seems to be fine for now so we will see how long it lasts
ruckus82 is offline   Reply With Quote
Old 08-09-2010, 10:24 AM   #4
ruckus82
Scooby Newbie
 
Member#: 246623
Join Date: May 2010
Chapter/Region: MWSOC
Location: STL
Vehicle:
2006 WRX TR
WRB

Default

it messed up right after I type this message lol so i parked it again. Drove it to work this morning and no alarms and it worked fine. prolly order a new sender just for fun today.
ruckus82 is offline   Reply With Quote
Old 08-10-2010, 03:22 PM   #5
skingfreak
Scooby Specialist
 
Member#: 152591
Join Date: Jun 2007
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
2010 Jetta TDI Cup
Jet Black

Default

Prosport = garbage

*Yes I've owned them, yes I know from first hand expierence that they're pure and utter ****. I currently own Defi BF's 1000303000x better and more accurate. 'you get what you pay for'
skingfreak is offline   Reply With Quote
Old 08-11-2010, 06:25 PM   #6
ruckus82
Scooby Newbie
 
Member#: 246623
Join Date: May 2010
Chapter/Region: MWSOC
Location: STL
Vehicle:
2006 WRX TR
WRB

Default

I have a DEFI oil gauge and innovate wideband in my mr2. The prosport came with the wrx so im prolly leaving it in for now. They have been logged and proven dead accurate though. but ya never heard of prosport until i bougth this wrx 3 months ago
ruckus82 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Prosport Oil gauges Notnice Electrical & Lighting 3 02-14-2008 01:30 AM
Oil Sandwich Adaptor for Prosport Oil Pressure Gauge? SubyTR07 Interior & Exterior Modification 10 02-01-2008 06:58 PM
FS: Prosport oil gauge w/ filter adaptor and dash gauge assembly bazdrum Interior/Dressup/Audio & Security 5 10-05-2007 09:21 PM
Perrin Big Maf $100, Prosport Oil Pressure & Oil Temp Amber Gauges, MISC TopEndPull TXIC Private Classifieds 28 05-18-2007 03:36 PM
Prosport oil gauge install... bazdrum Interior & Exterior Modification 2 10-01-2006 02:47 AM


All times are GMT -4. The time now is 03:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.