Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-10-2010, 01:07 PM   #1
Cowabunga
Scooby Newbie
 
Member#: 64086
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Mass
Default Springs sitting okay?

Since I did this by myself, I'm nervous I may not have them seated correctly, could you guys give me a confirmation? For the record, no clunking. While the bottom moved away from the notch maybe 3/4", it's the top that concerns me. The spring is not 100% flush with the top hat, and I'm not sure if that's how it's supposed to be. It didn't seem like it was going to recess all the way into the spring though so that the top part of the spring is flush all the way around. Does it look ok to you guys?

Anyway, I took pictures. Does it look okay to you guys?





* Registered users of the site do not see these ads.

Last edited by Cowabunga; 08-11-2010 at 02:04 PM.
Cowabunga is offline   Reply With Quote
Old 08-11-2010, 07:27 AM   #2
Cowabunga
Scooby Newbie
 
Member#: 64086
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Mass
Default

Also, theres no rubber isolator needed at the bottom right?
Cowabunga is offline   Reply With Quote
Old 08-11-2010, 02:02 PM   #3
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Any chance the spring is upside-down? It's been a while since I've messed with stock springs/dampers, but I seem to recall that one end was smaller than the other.

I imagine once the weight of the car is on the assembly that the spring will seat itself fully.

On a somewhat unrelated note, if you put a RETURN between each of the images they won't run together.

Pat Olsen
Patrick Olsen is online now   Reply With Quote
Old 08-11-2010, 02:06 PM   #4
Cowabunga
Scooby Newbie
 
Member#: 64086
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Mass
Default

Pat,

These are the fronts, which you are correct they are a different size top to bottom. The bottoms are the bigger, so as far as that goes they are in the right position.

I added the RETURN, so it's easier to distinguish pictures...
Cowabunga is offline   Reply With Quote
Old 08-12-2010, 01:39 AM   #5
that one legacy
Scooby Specialist
 
Member#: 103665
Join Date: Dec 2005
Default

what year is your car? cause that looks nothing like the springs or the mounts on either of my cars.
that one legacy is offline   Reply With Quote
Old 08-12-2010, 07:04 AM   #6
Cowabunga
Scooby Newbie
 
Member#: 64086
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Mass
Default

Quote:
Originally Posted by that one legacy View Post
what year is your car? cause that looks nothing like the springs or the mounts on either of my cars.
2008 LGT.
Cowabunga is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : (IL) front sti strut mounts, eibach sportline springs ilikebmx999 Suspension/Brakes/Handling 14 10-17-2010 06:39 PM
V6 sti springs - sitting too low Hitokiri Brakes, Steering & Suspension 4 04-11-2004 01:22 AM
Whiteline Springs sitting funny Turbo GC4 Brakes, Steering & Suspension 1 03-14-2003 08:41 AM
Trip to the dealer... springs upsidedown??? wich way do they sit?? BlackWagon Brakes, Steering & Suspension 0 07-29-2002 10:17 PM
update: sit springs are not quite so harsh now that jmott Texas Impreza Club Forum -- TXIC 4 07-26-2002 03:57 PM


All times are GMT -4. The time now is 05:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.