Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-16-2010, 03:19 PM   #1
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default Hella FF700 lights not very bright.

I would have expected these to have been at least as bright as the OEM headlights, but they arent. Not nearly. If I put my high beams on you cant even tell these are on. You can barely tell with the low beams on.

Any thoughts? I am thinking a weak ground maybe?

All connections are soldered, they are wired through the relay then to the battery.

Or am I just expecting too much from the 55W bulbs?

I picked up a set of 100W bulbs a few min ago, I'm gonna see if they are what I need.
* Registered users of the site do not see these ads.
Davenow is offline   Reply With Quote
Old 08-16-2010, 03:34 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

d0000000000000d....yer just gettin old and cant see like ya used too
Uncle Scotty is offline   Reply With Quote
Old 08-16-2010, 03:37 PM   #3
cantseejack
Scooby Newbie
 
Member#: 225097
Join Date: Sep 2009
Default

I had a set of FF700s; they aren't the brightest by a long shot. Probably going to go with FF4000 Halogens next.
cantseejack is offline   Reply With Quote
Old 08-17-2010, 10:51 AM   #4
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

What car do you have to start with? If you have retrofitted quad-HIDs, no wonder you don't see them... Did you aim them properly? My pencil 500s make a heck of a difference at a distance...perfect to complement high beams on empty freeway driving.
Bluefoton is offline   Reply With Quote
Old 08-17-2010, 12:22 PM   #5
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Its an 07 FXT, just standard reflector headlights. I may have Silverstar bulbs in them, but that's it, and I don't even remember if I did that.
Here it is


They are aimed, and I have tried re-aiming them a touch higher, they just dissapear when I get out anywhere near the range of my high beams, and even then you can only see them if the high beams are off.

I put 100W bulbs in them last night, that should help. I havent had it out on the road since I put them in though. Ill find out tonight.
Davenow is offline   Reply With Quote
Old 08-19-2010, 04:20 AM   #6
fastwrx25
Scooby Guru
 
Member#: 126441
Join Date: Sep 2006
Chapter/Region: SCIC
Location: TPE
Vehicle:
03 bugeye

Default

^^sexy foz.

I would like to see pics of lightoutput.

curious to see how bad they are.
fastwrx25 is offline   Reply With Quote
Old 08-20-2010, 06:27 PM   #7
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Quote:
Originally Posted by fastwrx25 View Post
^^sexy foz.

I would like to see pics of lightoutput.

curious to see how bad they are.
I put a set of 100W bulbs in them and they are much better. WAY better. This is what I expected from them.

Ill try to get a pic tonight, but it will be with the 100w bulbs.
Davenow is offline   Reply With Quote
Old 08-21-2010, 03:15 PM   #8
jutes85
Scooby Specialist
 
Member#: 127232
Join Date: Sep 2006
Chapter/Region: W. Canada
Location: Suck Lake, Alberta
Vehicle:
E92 M3
98' Foz

Default

I dono, I have the 55W bulbs in my FF700's and they seem okay.

Low



Low+High beams



Low+High+FF700+FF1000 fogs.




If the 100W bulbs are as good as you say I might get a set. Did you go with anything particular?
jutes85 is offline   Reply With Quote
Old 08-21-2010, 06:37 PM   #9
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Nice car and nice lights!

As a suggestion, at 200 watts you should be using 14-gauge wire. Also, the wire that Hella uses off of the lamps themselves is aluminum wiring. Get rid of it. Use copper wiring throughout.
Big-E is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS Gram Lights 57 Optimise Bright Silver --Light Weight Rims H.K. Phooey Wheels/Tires 8 01-25-2010 02:09 PM
WTT: Hella 500 amber fog lights for Hella driving lights Dforce SCIC Private Classifieds 29 08-30-2008 02:38 PM
WTT: Hella 500 amber fog lights for Hella driving lights Dforce Exterior/Styling 36 08-30-2008 02:36 PM
Cheap Low Beam H7 bulbs: Silverstar VERY BRIGHT ScubaruImpreza05 Tri-State Area Private Classifieds 0 07-27-2008 05:03 PM
Dim / Fog lights not working; Brights work. ??? DoodieHead Electrical & Lighting 1 11-26-2004 01:10 PM


All times are GMT -4. The time now is 01:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.