Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-21-2002, 09:52 AM   #1
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Unhappy Need help with HKS wastegate problem

Hey guys,

Well Last night we wrapped up my Turbo install on my RS. The kit is a Minnam Stage 2. I bought it from a local i-clubber and he installed it for me. The problem is that the wastegate will not hold boost at 5psi, like it should. The wastegate worked fine on his car, until he blew the motor. All the parts were then taken off by rallispec and put into a box. The wastegate has not been used in a few months, so could it have frozen? There is also a small leak between the wastegate and down pipe flange, but that should'nt matter as the WRC car vents to atmosphere out of the wastegate. What should I do? Take it off and see if its frozen? Try getting a new spring and seeing if that works? Until I fix this, I can't really go into boost safely, as I don't know how to control my boost rate yet, But I'm learning... We tuned the car so the EGT's are low, and its safe to drive, just not trying to hit ANY boost above 5psi... Thanks for all your help!

--Brian
* Registered users of the site do not see these ads.
rhdude is offline   Reply With Quote
Old 06-21-2002, 10:14 AM   #2
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
04 FXT
Red

Default

You mean that it won't hold boost at any level, it just keeps climbing? I would say that either it sounds like it's stuck, or it sounds like the vacuum line you ran to it had a one-way valve in there (no pressure to the WG = always closed & building boost).
8Complex is offline   Reply With Quote
Old 06-21-2002, 05:07 PM   #3
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

we had the both the side and top nipples connected to vacuum lines. I just got off the phone with HKS and they told me that the top nipple must remain un-capped, and open to atmosphere... I am going to go pull off that hose now... back in a few..


---Brian
rhdude is offline   Reply With Quote
Old 06-21-2002, 05:08 PM   #4
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

oh, forgot to metion...

The boost will keep on rising, no end in sight... so you basicly had to modulate the boost level with the throttle...
rhdude is offline   Reply With Quote
Old 06-21-2002, 05:31 PM   #5
Jewbaru
Scooby Specialist
 
Member#: 1994
Join Date: Jul 2000
Location: "Teh Hebro Town"
Vehicle:
2013 Impreza WRX
WRB

Default

Quote:
Originally posted by rhdude
we had the both the side and top nipples connected to vacuum lines. I just got off the phone with HKS and they told me that the top nipple must remain un-capped, and open to atmosphere... I am going to go pull off that hose now... back in a few..


---Brian
Bingo, that's the problem. The top nipple must either be open, or connected to a source BEFORE the turbo.

The wastegate uses the vacuum/pressure from the bottom nipple to push UP on the spring, lifting the valve to control boost. The top source is to help "pull" the spring up (considering there's always vacuum before the turbo), and hold boost tightly. With a vacuum source after the turbo on both ends, the rise in boost is making the spring see equal pressure on both sides, basically making it think it's running 0psi, so it's not opening.
Jewbaru is offline   Reply With Quote
Old 06-22-2002, 12:34 PM   #6
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

bingo, problem solved... i just un-hooked the top nipple hose...
Thanks guys!

--Brian
rhdude is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with hks turbo timer turbo turtle21 Electrical & Lighting 2 04-24-2010 01:36 PM
need help with hks evc RedSun Factory 2.0L Turbo Powertrain 6 06-07-2004 02:59 AM
need help with HKS FCD slammedWRX Factory 2.0L Turbo Powertrain 1 08-12-2002 06:12 PM
need help with a question/problem wrxracer Factory 2.0L Turbo Powertrain 3 02-01-2002 04:52 PM
Need help with dying ignition problem... Digital_Boy Normally Aspirated Powertrain 1 10-26-2000 10:02 AM


All times are GMT -4. The time now is 10:16 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.