Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-25-2010, 05:37 AM   #1
thejaredhuang
Scooby Specialist
 
Member#: 86206
Join Date: May 2005
Chapter/Region: SCIC
Location: Irvine
Vehicle:
2006 WRX Wagon
Blue

Default Need help identifying relay

I broke this part, gold looking one with 5614 on it: (imaged taken from Nickcrsx)


It is located between the intake manifold and power steering pump. It looks just like the stock boost control solenoid. I specifically broke one of the hose barbs off but I'm JB Welding it back.

My question is how vital is this part to the engine? Also what is it exactly? Right now I'm getting a P0607 CEL but it may not be that part specifically.

FYI I broke it taking the power steering pump off.
* Registered users of the site do not see these ads.
thejaredhuang is offline   Reply With Quote
Old 08-25-2010, 06:29 AM   #2
Abearslife
Scooby Newbie
 
Member#: 163480
Join Date: Nov 2007
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2002 WRX
Black

Default

I think that's part of the fuel evap system. it throw a code if it has a vac leak. fix it then reset ecu and it should go away.
Abearslife is offline   Reply With Quote
Old 08-26-2010, 02:09 AM   #3
thejaredhuang
Scooby Specialist
 
Member#: 86206
Join Date: May 2005
Chapter/Region: SCIC
Location: Irvine
Vehicle:
2006 WRX Wagon
Blue

Default

Thanks, fixed it and put the hoses in the correct orientation this time and my CEL is gone. Car is working great.
thejaredhuang is offline   Reply With Quote
Old 08-26-2010, 11:08 AM   #4
Haelan
Scooby Specialist
 
Member#: 151045
Join Date: Jun 2007
Location: NW Indiana
Vehicle:
2013 Subaru STI
CBP

Default

More specifically that is the Purge Control Solenoid Valve. It is part of the fuel evap system.
Haelan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help locating relays d0gsoup Service & Maintenance 1 06-09-2005 06:53 AM
Need help identifying speedline look-alike rims! poopysnaps Brakes, Steering & Suspension 2 08-30-2001 11:51 PM
Need help identifying wheel Jon [in CT] Brakes, Steering & Suspension 1 12-19-2000 01:33 AM
Need help identifying wheel Jon [in CT] General Forum Archive 6 12-18-2000 06:21 PM


All times are GMT -4. The time now is 03:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.