Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Care & Detailing

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-26-2010, 02:45 PM   #1
Mark_02WRX
Scooby Newbie
 
Member#: 244808
Join Date: Apr 2010
Chapter/Region: SWIC
Location: Casa Grande, AZ
Vehicle:
2002 Subaru Impreza
WRX WRB

Default Throttle cable clips

There are 3 clips that are supposed to clip onto the alternator cover of my bugeye but there's nothing on the bottom part of the cover that they attach to.

Am I retard and just can't figure out how they clip on or are there pieces missing needed to clip them on??

Here is a pic of the clips I'm talking about circled in red (not my engine bay).

Then a pic of the clips themselves (my engine bay).



Uploaded with ImageShack.us


Uploaded with ImageShack.us

TIA,
Mark
* Registered users of the site do not see these ads.
Mark_02WRX is offline   Reply With Quote
Old 08-26-2010, 06:29 PM   #2
cowboy_Rob
Scooby Specialist
 
Member#: 194062
Join Date: Nov 2008
Chapter/Region: MAIC
Location: Camp Hill PA
Vehicle:
2003 Impreza WRX
PSM

Default

yours are broken. they are supposed to have little prongs. they just stick into the hole on the cover and catch it with the prongs
cowboy_Rob is offline   Reply With Quote
Old 08-27-2010, 03:02 AM   #3
Mark_02WRX
Scooby Newbie
 
Member#: 244808
Join Date: Apr 2010
Chapter/Region: SWIC
Location: Casa Grande, AZ
Vehicle:
2002 Subaru Impreza
WRX WRB

Default

Where can I get replacements?
Mark_02WRX is offline   Reply With Quote
Old 08-28-2010, 02:58 PM   #4
jxkim
Scooby Specialist
 
Member#: 239150
Join Date: Feb 2010
Chapter/Region: Tri-State
Location: Bergen, NJ
Vehicle:
2003 WRX Sedan

Default

dealer. will be cheap
jxkim is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need clips for throttle cables arrowscooby Private 'Wanted' Classifieds 1 07-05-2009 08:38 PM
Detaching throttle body from throttle cable..how? jcbluescooby Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 11-03-2008 01:28 AM
How do you take up the slack in throttle cable? 96Lconversion Normally Aspirated Powertrain 2 02-22-2001 08:48 PM
How to tighten the throttle cable chyisan Technical Forum Archive 2 08-17-2000 05:38 PM
weak throttle cable--> can we change it? pwrup25RS Technical Forum Archive 5 06-16-2000 04:15 PM


All times are GMT -4. The time now is 06:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.