Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-26-2010, 10:58 PM   #1
ZenBoy
Scooby Newbie
 
Member#: 12524
Join Date: Nov 2001
Chapter/Region: MWSOC
Location: Minneapolis, Minnesnowta
Vehicle:
2004 STi
WRB/Gold

Default '00 2.5RS - Odd sunroof behavior after electrical fix

This past spring, my sunroof "died". I did the standard diagnoses...pulled the sunroof motor, which worked fine, and checked all of the voltages into and out of the relay. Everything seemed fine, but it still didn't work.

The dealer found that problem - the relay was heating up with use, resistance went up, and voltages went down. Brilliant. Problem solved, right?

Not completely. Now its behavior isn't quite right.

Normal behavior:
- Press OPEN button - Sunroof tips up and stops.
- Press OPEN button again - Sunroof opens all the way.
- Press CLOSE button - Sunroof closes halfway.
- Press CLOSE button again - Sunroof closes completely.

My sunroof's behavior:
- Press OPEN button - Sunroof opens all the way.
- Press CLOSE button - Sunroof closes halfway.
- Press CLOSE button again - Sunroof closes completely.

Occasionally, the first press of the OPEN button does nothing, but then the second press opens it all the way.

Suggestions, anyone? The ONLY thing I can think of is that the motor is what stops the sunroof after tipping up on the first OPEN button press, and that the motor and sunroof linkage have somehow gotten out of sync....
* Registered users of the site do not see these ads.
ZenBoy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Complete swap from '00 2.5rs and '00 white coupe trunk with wing Cyclops NWIC Private Classifieds 65 02-11-2010 10:34 AM
Yakima rack on 01 2.5RS and sunroof issues yeos Interior & Exterior Modification 0 09-11-2008 07:02 PM
Engine swap, '06 2.5i into '00 2.5RS--Direct swap? singincanary Subaru Conversions 13 10-01-2007 09:47 PM
'02 2.5RS TRANNY into '00 2.5RS?????? 4WDRFT 74 Transmission (AT/MT) & Driveline 1 09-26-2004 11:25 PM
'00 2.5RS 4-dr vs. '00 Integra GS-R 4-dr--What to buy??? jmcn General Forum Archive 23 05-31-2000 12:37 AM


All times are GMT -4. The time now is 08:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.