Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-16-2010, 06:24 PM   #1
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default URGENT: how should this ground wire be repaired?

Removed the Prolumen H1 hid kit after it didn't fire up on the first try, started to smoke last night and melted a splice connector when I went to investigate the problem (performed flawlessly for 4+ years and never again will I bother with aftermarket hid kits). The kit was spliced into the ground wire for the low beams via a vampire tap splice, I managed to free the ground wire from it, but now it's slightly exposed.

What should be my plan of attack in repair of the wire? Cut, stripped, soldered and rejoined together?

* Registered users of the site do not see these ads.
eurospek is offline   Reply With Quote
Old 09-16-2010, 06:37 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

If the wire itself appears ok and just the insulation is trashed, you can wrap it up well with electrical tape and it should be ok. It may be best though, to just cut out the bad section and splice in a new section of wire. Those taps usually cut through a few strands of the wire.
Clip-on taps should never be used for headlights and it was totally insane to use them with HIDs. You're lucky it only smoked and didn't go on fire.
Mulder is offline   Reply With Quote
Old 09-16-2010, 06:44 PM   #3
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Quote:
Originally Posted by Mulder View Post
You're lucky it only smoked and didn't go on fire.
Total noob mistake on my part. Bought into the hype of hids in 2006 and they definitely did look cool (had 5000K), along with my PIAA Ion yellow fogs. But lately they were never firing up right away, the passenger side always color shifted a little before getting up to the correct color and the cutoff of them was bothering me lately everytime I saw it on the car in front of me on the highway.

But never again.
eurospek is offline   Reply With Quote
Old 09-16-2010, 10:34 PM   #4
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Also Mulder, instead of soldering, could something like this be used or stay away from splices?

http://order.waytekwire.com/productd...MPED%20SEALED/
eurospek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where does this ground wire go?! helievacpilot Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 01-13-2006 01:18 AM
How should I run wires to my trunk? mora2818 Car Audio, Video & Security 4 02-12-2005 06:09 PM
Should this classic thread be unlocked? Kha0S Off-Topic 21 08-13-2004 06:02 PM
can this damage bumper be repaired? etam Off-Topic 3 02-09-2004 09:17 AM
Should this site URL be changed to www.impreza-wrx.com? IsraelGT General Forum Archive 6 11-22-2000 09:20 AM


All times are GMT -4. The time now is 01:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.