Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-04-2010, 04:26 PM   #1
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Default Help my turbo timer isn't counting down

I got the hks harness and wired it up. I'm not using any other features but after idle feature. So I'm not running wired to my ecu.
I haven't yet hooked up the optional ebrake wire but that shouldn't effect my tt countdown??
I'm stumped cause the harness is connected and the relay is grounded but when I turn my car off everything just turns off.......
* Registered users of the site do not see these ads.
Flyin_Hayn is offline   Reply With Quote
Old 09-04-2010, 04:59 PM   #2
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Default

if the parking brake line isnt connected will it not work..? i thought i t was optional. maybe i should ground that out too
Flyin_Hayn is offline   Reply With Quote
Old 09-04-2010, 07:00 PM   #3
jutes85
Scooby Specialist
 
Member#: 127232
Join Date: Sep 2006
Chapter/Region: W. Canada
Location: Suck Lake, Alberta
Vehicle:
E92 M3
98' Foz

Default

Take that POS off, you don't need it.
jutes85 is offline   Reply With Quote
Old 09-04-2010, 07:13 PM   #4
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Default

it looks sexi though.... i want my hta to cool down
Flyin_Hayn is offline   Reply With Quote
Old 09-10-2010, 07:59 PM   #5
GusGus91
Scooby Specialist
 
Member#: 201312
Join Date: Jan 2009
Chapter/Region: SWIC
Location: Reno, NV
Default

Quote:
Originally Posted by jutes85 View Post
Take that POS off, you don't need it.
^ This. There's no use for it.. Unless you just want the factor of people saying "gee whiz, you left your car running". Or if you're driving the car and getting the turbo red hot.. Which even then, you could just drive it calmly for a few miles, or just sit in the car for a min before you get out.
GusGus91 is offline   Reply With Quote
Old 09-11-2010, 02:07 AM   #6
requience139
Scooby Newbie
 
Member#: 240240
Join Date: Mar 2010
Chapter/Region: NWIC
Location: Oak Harbor, WA
Vehicle:
2007 WRX
WRB

Default

Let me help and not put my comments about TT's because that's what you posted a thread about, help, not other peoples opinions. What TT do you have? And I'm pretty sure that it has to make a ground with the e brake. The reason I ask what tt you have is cuz you might have to put what amount of time you want the tt to count down from. Cuz it might be set to 00.00 seconds lol. And do you have power to it?
requience139 is offline   Reply With Quote
Old 09-15-2010, 11:19 PM   #7
Anthony1990
Scooby Newbie
 
Member#: 222682
Join Date: Sep 2009
Default

im in the same boat....my TT turns on but when turning the car off it shuts down and doesnt count down.

HKS type 0 TT
Anthony1990 is offline   Reply With Quote
Old 09-29-2010, 03:09 PM   #8
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Default

i got this fixed a while back sorry for not posting. I have the Apexi TT. The Ebrake wire needs to be connected or grounded out aswell.
i really dont care what other people think. even though the coolant and oil both cool the turbo it is still cooling much more efficiently while the car is on because the coolant is actually running through the system. not to mention your engine continunes to get fresh coolant.. 30secs is not gonna hurt.. it looks cool too.
thanks for your 0.02 but i have enough money
Flyin_Hayn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hks type 1 turbo timer not counting down after install? Help??!?!?! SubieLuvin Electrical & Lighting 1 08-14-2010 10:00 AM
i need help with my turbo timer dahlinc Rocky Mountains Impreza Club Forum -- RMIC 8 06-22-2007 11:25 PM
turbo timers and cool down Donzo Impreza Forum 14 12-11-2005 01:40 PM
please guys,i need some help with my turbo timer Vidiotgamer Electrical & Lighting 0 03-13-2003 02:16 AM
Slight problem with my Turbo timer - help! djerickd Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 09-26-2001 01:06 PM


All times are GMT -4. The time now is 12:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.