Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-05-2010, 04:10 PM   #1
Wrx949
Scooby Newbie
 
Member#: 210271
Join Date: May 2009
Default Brake lights issue :(

I noticed yesterday that my brake lights were not coming on when braking, I found that the fuse (no 16) under the dash fuse box was out, I replaced it and it was all good. Driving back home I noticed they were out again, and replaced the fuse again. It seems like the brake lights work for a bit, but eventually the fuse burns again. I tried this a few times and the same. I checked the tail lights for shorts and stuff and they seem fine. Is there something I should look for in the brake switch above the brake pedal? Is there something like a relay that also controls the brake lights (under the hood fuse box) that I should check? Thanks for any info on this!
* Registered users of the site do not see these ads.
Wrx949 is offline   Reply With Quote
Old 09-15-2010, 04:09 AM   #2
magnus8681
Scooby Newbie
 
Member#: 257777
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: missouri
Vehicle:
1993 impreza L
white

Angry have a 1993 impreza L

I am having some what of the same problem all my lights work in back driving lights ect. just no brake lights i can turn on my head lights and the tail lights work but if i hit the brakes nothing the tail lights stay on but the brake lights dont come on same if i just hit the brakes without the tail lights on on brake lights if i hit the breaks i just got the car used and dont have the manual or i would read it but where are all the fuse boxes is it just the one under the hood and the one one drives side floor board area or is there another one cause i cant find the brake light fuse
3b4ae3ca-6477-4de0-944b-8aa07259140d
1.03.01
magnus8681 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Brake Light issue whig-it Electrical & Lighting 3 09-10-2008 09:01 PM
brake light issues? 97 gt illegal2.2 Legacy Forum 3 11-05-2007 04:36 PM
Brake light issues. japakazol Electrical & Lighting 2 09-16-2006 11:14 PM
1993 Legacy Brake Light issues pyropoptrt Electrical & Lighting 5 01-24-2005 01:56 AM
Emergency Brake Light Issues tiltedhugh Brakes, Steering & Suspension 8 04-07-2004 06:04 PM


All times are GMT -4. The time now is 10:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.