Welcome to the North American Subaru Impreza Owners Club Friday November 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-07-2010, 03:18 AM   #1
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Question Im gettin a metallic grinding noise...

Only when there is load on the engine, all gears from about 1,750rpm-1,900rpm.. accel and decel..
the engine has 7,500~ on it. so its nothin in the block.. i hear it while driving with my window down and can barely hear it with my windows up.

one thing i might want to add is that my clutch might be slipping.. it smells super clutchy after i hit full boost in fourth ~5krpms

Any ideas?
* Registered users of the site do not see these ads.
Flyin_Hayn is offline   Reply With Quote
Old 09-07-2010, 04:51 AM   #2
stibowen
Scooby Specialist
 
Member#: 234174
Join Date: Jan 2010
Chapter/Region: South East
Location: NC
Vehicle:
2006 STi
WRB

Default

Check your throw out bearing.

Or your brakes.

Last edited by stibowen; 09-07-2010 at 04:59 AM.
stibowen is offline   Reply With Quote
Old 09-07-2010, 07:08 AM   #3
sube-trex
Scooby Specialist
 
Member#: 97577
Join Date: Oct 2005
Chapter/Region: BAIC
Location: OR->WA->TX->OR->CA
Vehicle:
Bug In Your
Eye

Default

Quote:
Originally Posted by Flyin_Hayn View Post

Any ideas?

I have a gear set for sale.
sube-trex is offline   Reply With Quote
Old 09-07-2010, 03:04 PM   #4
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Default

hmmmmm.. what makes you think its the throw out..? im not having missed shift often.. my clutch is a really sticky clutch tho.. but thats just how the clutch has been.
you think maybe the new 2.5l and added TQ is do some wear on my tranny? im not a race around town type.. i really baby this thing lol
Flyin_Hayn is offline   Reply With Quote
Old 09-07-2010, 04:23 PM   #5
sube-trex
Scooby Specialist
 
Member#: 97577
Join Date: Oct 2005
Chapter/Region: BAIC
Location: OR->WA->TX->OR->CA
Vehicle:
Bug In Your
Eye

Default

Quote:
Originally Posted by Flyin_Hayn View Post
hmmmmm.. what makes you think its the throw out..? im not having missed shift often.. my clutch is a really sticky clutch tho.. but thats just how the clutch has been.
you think maybe the new 2.5l and added TQ is do some wear on my tranny? im not a race around town type.. i really baby this thing lol
I don't think it's the T.B., the added torque is quite much for the stock transmission take what your current tune and add on 20% to account for drivetrain loss and ur looking at a little over 400ft lbs with ur current setup.
sube-trex is offline   Reply With Quote
Old 09-08-2010, 12:07 AM   #6
stibowen
Scooby Specialist
 
Member#: 234174
Join Date: Jan 2010
Chapter/Region: South East
Location: NC
Vehicle:
2006 STi
WRB

Default

Quote:
Originally Posted by Flyin_Hayn View Post
hmmmmm.. what makes you think its the throw out..? im not having missed shift often.. my clutch is a really sticky clutch tho.. but thats just how the clutch has been.
you think maybe the new 2.5l and added TQ is do some wear on my tranny? im not a race around town type.. i really baby this thing lol
Meh. Just a suggestion. Seen it before.
stibowen is offline   Reply With Quote
Old 09-08-2010, 01:09 AM   #7
Flyin_Hayn
Scooby Specialist
 
Member#: 175031
Join Date: Mar 2008
Chapter/Region: NWIC
Location: Sauce Town, OR
Vehicle:
2005 PSM STi
Stage2 303awhp / 331awtq

Default

^^ hmm well today i didnt notice the noise.. im heading to the gym and ill do some slow driving on my way home to pin point it.. it doesnt seem major at all and everythign runs like butter.. just "unusual"
Flyin_Hayn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sheer metal/metal grinding noise from tranny area digitaljigga Transmission (AT/MT) & Driveline 1 03-19-2007 11:58 AM
metal on metal grind noise? pads or ball joint? j-speedracer Brakes, Steering & Suspension 7 07-12-2005 03:57 PM
Help! metal on metal grinding noise andyC Legacy Forum 19 04-29-2004 09:47 AM


All times are GMT -4. The time now is 04:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.