Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-07-2010, 11:04 PM   #1
A1y50n
Scooby Newbie
 
Member#: 130194
Join Date: Oct 2006
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2007 Impreza 2.5i SW
Newport Blue Pearl

Default Installed Stock Intake, car stalls when depressing clutch.

So, after messing with the intake, checking for vacuum leaks, I decided to put on the stock intake to rid myself of this headache.

I made sure to reset the ecu but even with the stock intake, when I depress my clutch while slowing down, it will stall.
After I stop, the engine will idle once I start the car up again.
What gives?
* Registered users of the site do not see these ads.
A1y50n is offline   Reply With Quote
Old 09-08-2010, 12:33 AM   #2
kewlboxer2
Scooby Newbie
 
Member#: 161322
Join Date: Oct 2007
Chapter/Region: Tri-State
Location: Galeton, PA
Vehicle:
06 2.5i
Regal Blue

Default

Just let the car idle for at least 15 min. This will relearn idle.
kewlboxer2 is offline   Reply With Quote
Old 09-13-2010, 02:25 AM   #3
A1y50n
Scooby Newbie
 
Member#: 130194
Join Date: Oct 2006
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2007 Impreza 2.5i SW
Newport Blue Pearl

Default

Throttle plate was dirty.... I failed to clean it thoroughly.
It's good now.
A1y50n is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High pitch whistling/squeaky sound when depressing clutch halfway FreytheViking Newbies & FAQs 9 05-10-2012 01:16 PM
Scraping noise when depressing clutch pedal/letting off gas rage941 Transmission (AT/MT) & Driveline 2 07-02-2010 10:45 PM
05 2.5rs Stalls when push clutch in if cold & idle question Bamboorex Normally Aspirated Powertrain 9 05-07-2009 01:38 PM
Noise when depressing clutch JJL330 Transmission (AT/MT) & Driveline 2 01-04-2006 04:54 PM
Bump from the rear when depressing clutch - normal? newsman Transmission (AT/MT) & Driveline 2 12-11-2004 03:22 PM


All times are GMT -4. The time now is 06:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.