Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-08-2010, 03:41 AM   #1
Subi_Newbi
Scooby Newbie
 
Member#: 257059
Join Date: Sep 2010
Chapter/Region: International
Location: Tokyo
Vehicle:
2000 Legacy B4 RSK
White

Default Wierd noises in my B4...

Hey guys I have a 1999 Legacy B4 twin turbo 5speed and as I'm starting off in 1st and the clutch is almost fully released I get a strange vibration in the rear. After I'm driving for a few mins it goes away.

Also as I accelerate from a stop I can hear a faint clunking noise in the rear. Its not occurring at the same time every time. I haven't had time to get it on a lift but it sounds as if maybe it's the diff or axles?? I'm new to Subaru so I thought i would see if this was anything common before I go tearing stuff apart.
* Registered users of the site do not see these ads.
Subi_Newbi is offline   Reply With Quote
Old 09-09-2010, 03:28 AM   #2
Subi_Newbi
Scooby Newbie
 
Member#: 257059
Join Date: Sep 2010
Chapter/Region: International
Location: Tokyo
Vehicle:
2000 Legacy B4 RSK
White

Default

Nobody???
Subi_Newbi is offline   Reply With Quote
Old 09-10-2010, 09:40 PM   #3
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

check your rear suspension. alot of times, the exhaust or joints are just too loose especially when taking off. I would start there. Maybe have someone drive and sit in the back to pinpoint what side it's coming from. I know this is just basic advice but many times for subaru's, the problem was a easy fix.

all in all, check your tranny fluid level (plus) and your rear. Maybe it has never been changed. When i purchased my baja, the previous owner never checked the dipstick for the tranny (5 spd) and it made a vibrating noise. The tranny was bone dry and I made a cocktail of royal purple and mobile 1 synthetic oil and wahhlaa, noise went away. Don't be scared, just start troubleshooting and research your problem. I wouldn't rely on responses here because it takes too long. Good luck fellow subaru victim.
Baja_Gernaut is offline   Reply With Quote
Old 09-11-2010, 08:50 AM   #4
Subi_Newbi
Scooby Newbie
 
Member#: 257059
Join Date: Sep 2010
Chapter/Region: International
Location: Tokyo
Vehicle:
2000 Legacy B4 RSK
White

Default

Yea, if it's the exhaust or a hanger that would be sweet. I'm sure the fluids are good since it just had it's JCI inspection a few months ago but I'll double check.

I plan to get an exhaust anyway but all I can find at UpGarage is axle backs, I'd much rather have a cat back.
Subi_Newbi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wierd noise in the shifter, help me!!! Shho13 Normally Aspirated Powertrain 3 08-26-2008 05:11 PM
Wierd noise in tranny below 2.8k RPM with Kartboy tgrasshopper Transmission (AT/MT) & Driveline 1 05-14-2007 06:11 PM
Wierd Problem In my car Derk1127 Normally Aspirated with bolt-on Forced Induction Powertrain 3 05-12-2004 10:55 PM
clunking and quiet grinding noise in my WRX HonduhEater Transmission (AT/MT) & Driveline 0 10-01-2002 10:18 PM
I have engine noise in my speakers :( Keith Car Audio, Video & Security 11 04-17-2001 05:33 PM


All times are GMT -4. The time now is 10:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.