Welcome to the North American Subaru Impreza Owners Club Saturday April 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-17-2014, 04:51 AM   #1
nhawks
Scooby Newbie
 
Member#: 367296
Join Date: Sep 2013
Default 2002 wrx to 2000 rs post swap issues

Swapped my rs to a 02 wrx, merged the harness myself got the fuel pump controller all properly configured and all. But I startit up and it only runs on 2 occasionally 3 cylinders, the passenger 2 cylinders always run, but the drivers back cylinder sporadically works and I'm getting no response out of the front cylinder. Cam timing is correct, checked that multiple times, have spark, have fuel pressure in the rails and 12v supply to the injectors. But the #2 injector is not being grounded/triggered by the ecu. Checked continuity from the injecto ground wire to the ecu and it checks out, have good grounds for the ecu. Ecu isn't the problem, swapped in a buddies ecu with the same result, cam and crank sensors are all good. What could be causing this? I don't know what to try next besides changing cam/crank gears. Is there a way to test the trigger wheels ont the cam/crank.
* Registered users of the site do not see these ads.
nhawks is offline   Reply With Quote
Old 12-17-2014, 07:36 AM   #2
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

There is a whole section dedicated to swaps. My guess is something is up with your harness. Buy a $10 VAGCOM cable and download Romraider to help trouble shoot the issue. It will allow you to see trigger/switches.

http://forums.nasioc.com/forums/forumdisplay.php?f=87
quazimoto is offline   Reply With Quote
Old 12-17-2014, 08:48 AM   #3
nhawks
Scooby Newbie
 
Member#: 367296
Join Date: Sep 2013
Default

Been all through that, and the resources on rs25 followed brydons guide for the conversion, have a VAGCOM and Tactrix cable Romraider Ecuflash etc, but having a whole host of issues getting the openport to communicate properly.

Checked over the harness quite a few times but haven't found any issues, Makes since that the harness wouldn't really affect it since you really don't merge any wires that directly correlate between the ecu and motor.
nhawks is offline   Reply With Quote
Old 12-17-2014, 05:40 PM   #4
mikeyPSF
NASIOC Supporter
 
Member#: 236475
Join Date: Jan 2010
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
2002 WRX
Black

Default

nhawks, can you send me an email to support at tactrix dot com so that I can send you a beta version to try? We've made some recent tweaks that should improve things for your year.
mikeyPSF is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.