Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-10-2010, 05:08 PM   #1
Apocalipto
Scooby Newbie
 
Member#: 257116
Join Date: Sep 2010
Chapter/Region: E. Canada
Location: Ottawa,canada
Vehicle:
07 impreza
blue

Default electrical problem plz help!!

1st of all my car is an 07 impreza 2.5i
I decided to reinstall my sub woofer the other day and everything was going well untill some wires touched together while i was connecting the wires to the amp

Result: no more A/c fan, no more clock, no more radio and the air bag light turned on on my dash!!!

I changed all my fuses for new ones with no luck at all...
so im out of idea since i dont know much in car electrical!
Im hoping someone can help me here.
* Registered users of the site do not see these ads.
Apocalipto is offline   Reply With Quote
Old 09-10-2010, 06:34 PM   #2
earthcrisis
Scooby Newbie
 
Member#: 234350
Join Date: Jan 2010
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2012 WRX
SWP

Default

which fuse panel have checked, there is one in the cab and one under the hood. visually check all fuses.
earthcrisis is offline   Reply With Quote
Old 09-10-2010, 07:37 PM   #3
Apocalipto
Scooby Newbie
 
Member#: 257116
Join Date: Sep 2010
Chapter/Region: E. Canada
Location: Ottawa,canada
Vehicle:
07 impreza
blue

Default

ahh where is the one in the cab i changed all the ones under the hood!
Apocalipto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Subwoofer/Amp Problems!! Plz help! Infest Car Audio, Video & Security 11 11-29-2004 09:44 PM
98 impreza- wrx tranny install problems.plz help farrell Normally Aspirated Powertrain 2 11-29-2004 11:00 AM
98 impreza- wrx tranny install problems.plz help farrell Transmission (AT/MT) & Driveline 0 11-29-2004 10:36 AM
02-03 JDM headlitght problem, plz help!!! qwk_wrx Electrical & Lighting 7 11-11-2004 12:50 PM
2.2L into a 2.5L electrical problem plz help! farrell Subaru Conversions 8 08-09-2004 11:44 PM


All times are GMT -4. The time now is 11:10 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.