Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-16-2010, 09:44 AM   #1
stimania
Scooby Specialist
 
Member#: 233957
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Cumberland,MD
Vehicle:
2012 STI Hatch
SWP

Default Some sort of electrical problem.

I think my car is experiencing some sort of electrical problem. All of a sudden my car will spit and jerk like it's not getting fuel when I stomp the accelerator. And also,along with that the speedo needle is bouncing around all over the place. And I don't know if it has to do with the same issue but my factory 6 disc head unit will not play,eject,or load CDs. Is this as simple as a ground? Has anyone else experienced this or have any advice where to guide me. Thanks
* Registered users of the site do not see these ads.
stimania is offline   Reply With Quote
Old 09-16-2010, 12:48 PM   #2
Henry H
Scooby Newbie
 
Member#: 184330
Join Date: Jul 2008
Location: Southern California
Vehicle:
2008 Impreza 2.5i
Dark Grey Metallic

Default

Go get your battery checked out first (autozone offers a free service). Don't rule out the simple, easy stuff.
Henry H is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I should be inductive into some sort of hall of fame Asinine Off-Topic 13 01-12-2007 08:38 PM
Is there some sort of Email virus or networking problem today? semabe Off-Topic 18 08-03-2006 11:11 AM
some sort of fuel problem? usctom Factory 2.0L Turbo Powertrain 1 12-21-2003 04:54 PM
Some sort of electrical disturbance. webkris New England Impreza Club Forum -- NESIC 46 02-26-2002 02:17 PM
('93-'01) what ever happened to some sort of pittsburgh club?? theGrideimpreza4u Impreza Forum 0 06-02-2001 09:27 PM


All times are GMT -4. The time now is 09:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.