Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-24-2002, 04:39 PM   #1
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Question Ever see a turbo do this?

Anyone tell me what's missing here?

http://holly.colostate.edu/~rrios/turbo/DSC00328.JPG

Well, the compressor isn't in the best of shapes either. Notice one of the fins is missing a piece.

http://holly.colostate.edu/~rrios/turbo/DSC00329.JPG

-Ro

PS The turbine letting go had it's way with the o2 sensor

http://holly.colostate.edu/~rrios/turbo/DSC00333.JPG
* Registered users of the site do not see these ads.
Strepto is offline   Reply With Quote
Old 06-24-2002, 05:07 PM   #2
AnimalMother
Scooby Newbie
 
Member#: 11835
Join Date: Nov 2001
Location: Tucson, AZ
Vehicle:
2004 Honda Pilot
Dark Blue

Default

have you determined the cause for this failure? excessive heat?
AnimalMother is offline   Reply With Quote
Old 06-24-2002, 05:30 PM   #3
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Default

I have no idea. The turbo did have 120k miles on it. It was making weird noises about a week after I bought the car. Only things I can think of is that something came out of the combustion chamber (god I hope not), or the cartrage wasn't getting enough lubrication and the friction eventually became to much causing the turbine to sheer off. Maybe it was horribly out of balance and with time the wear took it's tool and the center shaft weakened enough to break. Who knows. I want to tear the thing apart since it's not really rebuildable (a new one would be cheaper) and maybe I'll find something out.

-Ro
Strepto is offline   Reply With Quote
Old 06-24-2002, 06:15 PM   #4
Tangmere
Scooby Specialist
 
Member#: 572
Join Date: Nov 1999
Location: Boulder, Colorado
Default

Ro,
Make sure you find out exactly what caused the failure to start with, otherwise you'll be using the new one as a diagnosis tool. Better still, run the damned thing down to TEC and have them tell you what caused the failure.

Mark
Tangmere is offline   Reply With Quote
Old 06-24-2002, 07:10 PM   #5
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Default

Mark, that's a really good idea
Strepto is offline   Reply With Quote
Old 06-25-2002, 12:55 AM   #6
Spectre23
Scooby Specialist
 
Member#: 311
Join Date: Sep 1999
Chapter/Region: RMIC
Location: Murray, Ut, USA
Vehicle:
2013 STi
CBS

Default

Correct me if I am wrong, but doesn't that look like a bad case of detonation?

But if it was making funny noises, it may have just had bad bushings in it.
Spectre23 is offline   Reply With Quote
Old 06-25-2002, 09:11 AM   #7
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Default

nope. You guys must be thinking the trubine melted, when in fact the shaft connecting the turbine and compressor broke. Since it was spinning pretty fast at the time some of the turbine fins imbedded themselves in the turbine housing (you can see some of them at the bottom of the picture). Because of the positioning of the o2 sensor in relation to the turbine, when the turbine had to go somewhere it ripped right through the o2 sensor (pic #3).

The best "guess" I'm getting from the more knowledgable guys over on CO DSM is that because the compressor fins were so bent and out of shape it threw off the balance of the turbo. That eventually lead to failure of the connecting shaft.

I'll be taking Mark's advice and shipping it down to TEC to see if they can determine why it did what it did. I don't want my new turbo doing the same thing (it's going in today btw ).
Strepto is offline   Reply With Quote
Old 06-25-2002, 11:53 AM   #8
phast
Scooby Specialist
 
Member#: 7957
Join Date: Jul 2001
Location: Colorado Springs, CO
Default

If you got anything less than a 20G as a replacement, well.. I'll be mad at you or something.
phast is offline   Reply With Quote
Old 06-25-2002, 01:28 PM   #9
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Default

yeah, because I only want to go in a straight line
Strepto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ever see a wheel do this? idioteque1025 General Community 56 04-23-2009 02:26 PM
I'd love to see a corvette do this! MidnightSti05 Mid Atlantic Impreza Club -- MAIC 13 10-17-2008 10:45 AM
Anyone ever see a spider like this? jetfan8178 Off-Topic 25 07-29-2006 06:59 PM
Do you ever see a cute gothy-emo type girl... WRXedUSA Off-Topic 42 06-02-2006 03:10 AM
Never, ever, ever, ever, ever do this... Cosworth Off-Topic 31 01-12-2005 08:50 PM


All times are GMT -4. The time now is 01:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.