Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-18-2010, 11:48 PM   #1
jakvett
Scooby Newbie
 
Member#: 218841
Join Date: Jul 2009
Vehicle:
06 2.5i

Default Speedometer Needle Twitchy

I recently changed my dash cluster lights. They are still regular incandescent bulbs, not LED's, but maybe it's relevant. Anyway, I also removed the needles when I was in there (not sure why now, and wish I hadn't). I managed to get the fuel, water temp, and tach needles right on, but my speedometer is twitchy. From a dead stop, when I accelerate slow, fast, or medium, the needle hesitates to move until it suddenly jumps up to 20. It does this in every driving situation, speeding up or slowing down. I have tried removing the needle and resetting it, but it didn't help. When I shut the car off, the needle eventually goes back down to 0, and the needle settles to be around the right speed when it finally catches up, it just doesn't react instantly. Any ideas on what's wrong, or more importantly, how to fix it?
* Registered users of the site do not see these ads.
jakvett is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer needle getting stuck at 40MPH RootUsr Electrical & Lighting 12 12-28-2011 11:18 PM
Faulty OB speedometer needle Teacher Outback Forum 1 01-15-2004 07:49 AM
3000 RPM and the speedometer needle BurntJamb Interior & Exterior Modification 0 04-23-2003 04:15 PM
('93-'01) What makes a speedometer needle "shakey" Dobes Impreza Forum 4 04-09-2001 12:15 PM
How sensitive is the speedometer needle?? wrxsti General Forum Archive 5 01-08-2001 12:52 PM


All times are GMT -4. The time now is 09:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.