Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-25-2002, 01:18 PM   #1
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Post Weird Rattle noise from Turbo on WRX ?

Ever since I installed a Turbo back exaust system on my WRX I get a weird rattle noise when the turbo kicks in. It only happens between 3000 - 4000 RPM right when the turbo starts to kick in. It almost sounds like something inside the turbo is rattling. It does it only when your driving and going though each gear. You can hear the Turbo start to kick in and make it's Hissss noise and then it makes a horrible rattle sound. It's not super loud, but it's just enough to bug you....and it just doesn't sound right. The Turbo still seems to works fine......doesn't feel like I lost any boost or anything. Just wondering if anyone has ever heard of this. And what steps I could take to fix this ?
Thanx, Jeff -
* Registered users of the site do not see these ads.
Impreza777 is offline   Reply With Quote
Old 06-25-2002, 01:22 PM   #2
cnk
Scooby Guru
 
Member#: 10757
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 BRZ Limited 6MT
DGM

Default

Could it be a loose heatshield?

Calvin
cnk is offline   Reply With Quote
Old 06-25-2002, 01:36 PM   #3
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Default

Nawww.........the Heat shield isn't loose. Nothing is loose under there. I've checked everything. If something was loose I would probably hear the rattle at random times. You can only hear this noise right when the Turbo kicks in......and it only happens between 3000-4000RPM.....when you get to higher RMP's it seems to disappear. I'm pretty sure It has something to do with the Turbo.......so who knows ?
Impreza777 is offline   Reply With Quote
Old 06-25-2002, 01:48 PM   #4
Concillian
Scooby Guru
 
Member#: 4414
Join Date: Feb 2001
Location: Dublin, CA
Vehicle:
2002 WRX Sedan
Midnight Black

Default

I have a rattle that IS the heatshield, but the heatshield is NOT loose. All bolts are definitely tight. It happened when the car was stock too.

I can put it in neutral and rev to about 3000 RPM or so and the heatshield on the turbo will start rattling.

Then if someone else presses (pretty hard) on the heatshield in the right location the rattling/buzzing will stop.

For me, when driving, it is most prevalent when I let off the gas at around 3000-3500 with a small amount of boost (very slight vacuum to 3 psi or so)

I have no idea how to get rid of it besides taking off the heatshields.

Maybe you should take off the heatshields for a quick drive just to verify that's not your problem.
Concillian is offline   Reply With Quote
Old 06-25-2002, 02:05 PM   #5
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Default

Yea..........I've done that test also. It's not the Heat Shield.
I've sat in the driveway and reved it up through 4000 RPM's.
I've have a friend push on stuff while I did that. There was no noise. It only makes the noise when the Turbo kicks in while you are driving. When your on the highway cruzing at 3000 RPM....nothing. When your cruzing at slow speeds at low RPM's....nothing. It only does it when the Turbo comes on... up through 4000 RPM. It's really weird.
Impreza777 is offline   Reply With Quote
Old 06-25-2002, 02:16 PM   #6
Concillian
Scooby Guru
 
Member#: 4414
Join Date: Feb 2001
Location: Dublin, CA
Vehicle:
2002 WRX Sedan
Midnight Black

Default

Uh, does it only happen at FULL boost?

Is it pre-detonation?
Concillian is offline   Reply With Quote
Old 06-25-2002, 03:13 PM   #7
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Default

No it disappears by full boost. It only makes the noise right when the Turbo is kicking in somewhere between 2500 - 3000RPM. And the noise stays up to about 3500 - 4000 RPM......and then it's gone. It's not loud........It's like a slight rattle instead of just a smooth Hisssss sound from the Turbo. Almost like whatever moves inside the Turbo is slightly rubbing against something. It doesn't seem like a big deal, but it just doesn't sound right.
Impreza777 is offline   Reply With Quote
Old 06-25-2002, 03:30 PM   #8
roybfr
Scooby Specialist
 
Member#: 14456
Join Date: Jan 2002
Chapter/Region: MWSOC
Location: WDM Iowa
Vehicle:
09 BMW 335i Sedan
69/72/01 Corvettes

Default

Are sure it is not the stock boost solenoid turning on and off. After installing my DP it became very noticable when boost was coming on up to about 5psi or so but then at full boost it would go away as full boost was reached. The sound was kind of metalic clanking.

Troy
roybfr is offline   Reply With Quote
Old 06-25-2002, 03:55 PM   #9
krave
Scooby Specialist
 
Member#: 13908
Join Date: Jan 2002
Location: Irving, TX
Vehicle:
2002 WRX Sedan
296 whp

Default

well i figure its one of the two...either your exhaust is vibrating under boost and rubbing on something. or, some sort of exhaust leak?
krave is offline   Reply With Quote
Old 06-25-2002, 04:16 PM   #10
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Default

Yea...........I was thinking it could have something to do with some kind of exhaust reverb or something ? I did get under there a few times to make sure that the whole exhaust wasn't moving or vibrating......seemed to be very solid........but ya never really know I guess.
Impreza777 is offline   Reply With Quote
Old 06-25-2002, 04:46 PM   #11
Wreckleford
Scooby Newbie
 
Member#: 887
Join Date: Feb 2000
Default

It may very well be detonation.
Wreckleford is offline   Reply With Quote
Old 06-25-2002, 05:04 PM   #12
KwanDDS
Scooby Newbie
 
Member#: 15709
Join Date: Feb 2002
Location: Houston, TX
Vehicle:
2002 WRX WAGON
SILVER

Post

I'm pretty much stock and I get a similar sound. Its probably just a sound inherent to the WRX engineering. I have a stock exhaust, so I doubt its an exhaust leak.
Hope this helps.
KwanDDS is offline   Reply With Quote
Old 06-25-2002, 05:21 PM   #13
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Default

Cool..........Thanx for all the input !
Jeff -
Impreza777 is offline   Reply With Quote
Old 06-25-2002, 05:52 PM   #14
elgorey
Scooby Specialist
 
Member#: 4374
Join Date: Feb 2001
Chapter/Region: MAIC
Location: VIRginia
Vehicle:
06 Titan,99,94 SM
06 nasa spec miata champ

Default

I have had this since I installed my DP. It bugged me at first but after doing a search, it looks like a common occurence and it is completely normal. Supposedly it is the boost control solenoid or wastegate fluttering
elgorey is offline   Reply With Quote
Old 06-25-2002, 07:36 PM   #15
BamBooI
Scooby Specialist
 
Member#: 10945
Join Date: Oct 2001
Chapter/Region: South East
Location: SC
Vehicle:
2006 Evolution IX

Default

I think the wastegate fluttering happens when you let off of the gas ie off of boost. What all mods do you have?
BamBooI is offline   Reply With Quote
Old 06-25-2002, 07:53 PM   #16
Impreza777
Scooby Newbie
 
Member#: 20453
Join Date: Jun 2002
Location: San Diego, CA
Vehicle:
2002 WRX
Silver

Default

Nawwww...........only makes the noise when you are on the Gas. I just have a Turbo back Exhaust....that's all.
Jeff -
Impreza777 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help diagnose: weird rattle/flutter from turbo? Or is this knock? AcquaCow Engine Management & Tuning 1 05-15-2010 11:30 AM
Weird noise from turbo SYBugeye Factory 2.0L Turbo Powertrain 5 08-02-2009 02:30 PM
Weird noise from Turbo area theSlothy1 Factory 2.5L Turbo Powertrain 22 11-05-2008 06:45 PM
Weird noise from turbo abgusaf Factory 2.0L Turbo Powertrain 9 10-03-2007 07:18 AM
tapping noise from turbo on boost cold DISCOPOPE Factory 2.5L Turbo Powertrain 3 11-15-2003 06:40 PM


All times are GMT -4. The time now is 12:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.