Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-26-2010, 02:28 PM   #1
TurboQueef
Scooby Newbie
 
Member#: 86700
Join Date: May 2005
Location: Otsego, MI
Vehicle:
2005 STI
Silver/Black,11.44@123.60

Default Out of Turbo? FP Red, ported heads, cams

Good day,

I am looking for information from actual user who can provide detail for an actual application ... not interested in "theory" without actual data.. (thank you)

Had Ron @ Axis/RAW refresh the build this spring... I had head porting and rods installed at this time. The engine has Kelford 276/272 cams and an FP Red (8cm housing)

I tune my STi myself with help from a few friends. I use DataLog Lab street dyno software as a baseline to tune against..

The engine runs great... no issues with the build but I am struggling to make the power I expected with the head porting... and am starting to wonder if the turbo is out of steam..

My HP target is: 420AWHP on pump.. and 540 on race fuel... I have not tuned with race fuel yet but I seem to be stuck at 380AWHP on pump..

I would like to hear feedback from anyone running an FP Red on a engine built similar to mine..

The specific feedback I am looking for:

** What is the high level of your build (head work, porting, turbo ((fp red))

** What AWHP/TQ have you been able to get out of it on pump and race fuel. Please define octane of fuel and boost level.

** Let me know if you have run it down the 1/4 mile.. if so, please detail the ET and MPH

Thanks a bunch

Jeff B
* Registered users of the site do not see these ads.
TurboQueef is offline   Reply With Quote
Old 09-26-2010, 02:37 PM   #2
renosubby
Scooby Specialist
 
Member#: 152576
Join Date: Jun 2007
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 STI 10.8@ 129
www.Mayhemtuning.com

Default

Quote:
Originally Posted by TurboQueef View Post
Good day,

I am looking for information from actual user who can provide detail for an actual application ... not interested in "theory" without actual data.. (thank you)

Had Ron @ Axis/RAW refresh the build this spring... I had head porting and rods installed at this time. The engine has Kelford 276/272 cams and an FP Red (8cm housing)

I tune my STi myself with help from a few friends. I use DataLog Lab street dyno software as a baseline to tune against..

The engine runs great... no issues with the build but I am struggling to make the power I expected with the head porting... and am starting to wonder if the turbo is out of steam..

My HP target is: 420AWHP on pump.. and 540 on race fuel... I have not tuned with race fuel yet but I seem to be stuck at 380AWHP on pump..

I would like to hear feedback from anyone running an FP Red on a engine built similar to mine..

The specific feedback I am looking for:

** What is the high level of your build (head work, porting, turbo ((fp red))

** What AWHP/TQ have you been able to get out of it on pump and race fuel. Please define octane of fuel and boost level.

** Let me know if you have run it down the 1/4 mile.. if so, please detail the ET and MPH

Thanks a bunch

Jeff B
No head work, forged internals. 394whp 370 wtq on 91 oct at 4500 ft elevation.
470 whp and 450 wtq on 110 oct
Ran 11.1 @127 in sacramento full weight with tool box and laptop, helmet, jacket, pool cues, jack
renosubby is offline   Reply With Quote
Old 09-27-2010, 05:32 PM   #3
nhsilversti
NASIOC Supporter
 
Member#: 50895
Join Date: Dec 2003
Chapter/Region: NESIC
Location: southern NH
Vehicle:
. www.48hrs.info
donation chairman

Default

forged internals, race porting, 44mm ewg, 93 oct, cams, 23psi and on a dyno dynamics dyno 38X hp/38X tq

motor was built for reliability on the track.....unfortunatly the bearings puked so it was just rebuilt again.
nhsilversti is offline   Reply With Quote
Old 09-27-2010, 06:51 PM   #4
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

what are you using for EM?Can you send me a log and a copy of a current map and what boost are you seeing?
john 1badSTI is offline   Reply With Quote
Old 09-27-2010, 10:53 PM   #5
TurboQueef
Scooby Newbie
 
Member#: 86700
Join Date: May 2005
Location: Otsego, MI
Vehicle:
2005 STI
Silver/Black,11.44@123.60

Default

Quote:
Originally Posted by john 1badSTI View Post
what are you using for EM?Can you send me a log and a copy of a current map and what boost are you seeing?
Thanks... just PM'ed you the data... running 24psi... only getting 375.301 on 93 octane...

jb
TurboQueef is offline   Reply With Quote
Old 09-27-2010, 11:26 PM   #6
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

i sent you a pm with some recommendations on your tune and where to make the changes in the map.
john 1badSTI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone got any measurments of the FP Red compressor wheel....? q_dubz Normally Aspirated with bolt-on Forced Induction Powertrain 0 09-23-2009 09:29 PM
My ghetto build, ported heads, cams, pistons; with pics juanmedina Built Motor Discussion 181 08-01-2009 07:35 PM
* Help identify this Turbo, FP red 20G?? PICS inside! Lam Newbies & FAQs 11 01-23-2009 03:35 PM
DP install - pulled one of the studs out of turbo?? bikergreen Factory 2.0L Turbo Powertrain 4 11-17-2008 11:33 AM
ported heads/cams/valvetrain? darioc Normally Aspirated Powertrain 11 10-20-2003 11:21 AM


All times are GMT -4. The time now is 08:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.