Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-29-2010, 10:33 AM   #1
moose00015
Scooby Specialist
 
Member#: 180924
Join Date: May 2008
Chapter/Region: MAIC
Location: West Chester, PA
Vehicle:
2007 Impreza WRX STi
2004 Forester XS Premium

Default 07 STi Fog Lights, Passenger Side Doesn't Work.

I'm having issues with my fog lights on my car. The passenger side one isn't working. It sometimes will come on for a brief amount of time and go off again. But it usually doesn't work at all. I've checked the fuse and bulb and both are ok. Any ideas what might cause this or what to look for?

Thanks!
* Registered users of the site do not see these ads.
moose00015 is offline   Reply With Quote
Old 09-29-2010, 06:53 PM   #2
FourOnTheFloor65
Scooby Specialist
 
Member#: 106225
Join Date: Jan 2006
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
02 WRX STied PSM
03 L, 05 GT Legacy Wagons

Default

I've seen bulbs, on several occasions, where they would work intermittently. The last one I had, the filament was broken on one side, but was resting on the contact where it was originally attached. I removed the bulb a couple of times and looked at it. It always looked fine. With that bulb, if I hit the headlight with my hand it would light up, and stay lit for a few minutes, then stop again. Finally I removed it, and shook it really hard and the filament permanently detached. After I put new bulbs in, I never had another issue with it.

The lesson is, even if the bulb looks good, it might not be. The same goes for fuses.
FourOnTheFloor65 is offline   Reply With Quote
Old 09-30-2010, 01:12 AM   #3
moose00015
Scooby Specialist
 
Member#: 180924
Join Date: May 2008
Chapter/Region: MAIC
Location: West Chester, PA
Vehicle:
2007 Impreza WRX STi
2004 Forester XS Premium

Default

I put a new bulb in. I forgot to mention that. I had bought a new one before I even looked just assuming it was the bulb. The new bulb didn't solve the problem. I'll try changing out the fuse even though it looked fine. Any other things to look at would be appreciated.
moose00015 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: (NJ) 07 STI Fog light covers cpunlamd Exterior/Styling 4 10-03-2007 01:20 AM
06-07 STI fog light cover question (searched) Mr. London Newbies & FAQs 2 07-08-2007 11:18 AM
WTB: Fog light- passenger side MY02 shift_rex Private 'Wanted' Classifieds 3 05-17-2007 01:46 PM
WTB: Aspen White 04/05 STI - Fog Light Covers, Side Skirts, Hood Scoop, Air Dams! NJ Bart! Private 'Wanted' Classifieds 2 12-06-2006 02:12 AM
FS Socal: BRAND NEW 2006/07 STI Fog Light Covers ComTekAuto Exterior/Styling 18 10-26-2006 05:28 PM


All times are GMT -4. The time now is 09:21 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.