Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-29-2010, 10:32 PM   #1
grant696
Scooby Newbie
 
Member#: 259105
Join Date: Sep 2010
Location: Michigan
Vehicle:
2007 N/A 2.5i
Newport Blue

Default HID question

I just recently bought my n/a 07 impreza 2.5i sedan and installed hid's in the stock headlights. I disconected the DRL's from behind the glovebox and also undeneath the hood. I still keep getting the cel and flashing cruise control light. I know that there are endless threads on this but I can't seem to find the exact answer that I need. Do I need a relay? Please respond back.

Thank you, -Pat
* Registered users of the site do not see these ads.
grant696 is offline   Reply With Quote
Old 09-29-2010, 11:19 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

You won't get a CEL from disconnecting the DRLs. Either you disconnected the wrong thing, or it's a coincidence that the light came on at the same time.
Go to Autozone and get the code read to see what it is telling you.
Mulder is offline   Reply With Quote
Old 09-29-2010, 11:27 PM   #3
grant696
Scooby Newbie
 
Member#: 259105
Join Date: Sep 2010
Location: Michigan
Vehicle:
2007 N/A 2.5i
Newport Blue

Default

Ok thank you. I actually tried to send you a private message but your inbox was full. The CEL came on before I disconnected them. It comes and goes.
grant696 is offline   Reply With Quote
Old 09-30-2010, 03:15 AM   #4
FourOnTheFloor65
Scooby Specialist
 
Member#: 106225
Join Date: Jan 2006
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
02 WRX STied PSM
03 L, 05 GT Legacy Wagons

Default

When putting HIDs on a car that didn't come with them, you absolutely need a relay harness. The stock wiring is not designed for the 10 or more amps drawn by the HIDs when they are starting up. STis with factory HIDs have 14 or 12 gauge wire going to the headlights. Your car has 18 or 20. It might work out OK for a while, but eventually something's going to melt, or worse catch on fire. Then again the crappy Chinese ballasts or bulbs could very well catch on fire at any moment. It's happened before.

The other things that you absolutely need when installing HIDs, are HID optics, which you do not have either.
FourOnTheFloor65 is offline   Reply With Quote
Old 09-30-2010, 08:07 AM   #5
grant696
Scooby Newbie
 
Member#: 259105
Join Date: Sep 2010
Location: Michigan
Vehicle:
2007 N/A 2.5i
Newport Blue

Default

Okay thank you Four, I greatly appreciate you responding. Also, what are HID optics?

Last edited by grant696; 09-30-2010 at 08:13 AM.
grant696 is offline   Reply With Quote
Old 09-30-2010, 09:49 AM   #6
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Quote:
Originally Posted by grant696 View Post
I just recently bought my n/a 07 impreza 2.5i sedan and installed hid's in the stock headlights. I disconected the DRL's from behind the glovebox and also undeneath the hood. I still keep getting the cel and flashing cruise control light. I know that there are endless threads on this but I can't seem to find the exact answer that I need. Do I need a relay? Please respond back.

Thank you, -Pat
For 2007, Subaru changed the way the DRL's were controlled. This means there no longer is a relay behind the RH side of the glove-box to disconnect to disable the DRL's.

If you disconnected the resistor that is under the hood, which is mounted to the passenger's side strut-tower, then leave it disconnected. But, whatever you unplugged from behind the glove-box, reconnect it (with the car off).
Big-E is offline   Reply With Quote
Old 09-30-2010, 11:46 AM   #7
grant696
Scooby Newbie
 
Member#: 259105
Join Date: Sep 2010
Location: Michigan
Vehicle:
2007 N/A 2.5i
Newport Blue

Default

Okay I will. Thanks for the input.
grant696 is offline   Reply With Quote
Old 09-30-2010, 05:27 PM   #8
FourOnTheFloor65
Scooby Specialist
 
Member#: 106225
Join Date: Jan 2006
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
02 WRX STied PSM
03 L, 05 GT Legacy Wagons

Default

Quote:
Originally Posted by grant696 View Post
Okay thank you Four, I greatly appreciate you responding. Also, what are HID optics?
Optics are simply devices that control light. With headlights these would be either reflectors, or in your case, projectors. HID and halogen projectors are very different. You cannot just mix match light sources in a given optic. Light is emitted from an HID capsule totally differently than it is from a halogen bulb. Just because the rebased HID capsules that you bought physically fit in the back of the projector, doesn't mean they are appropriate, safe, legal, or even an upgrade over the stock halogens.

Read these...

http://forums.nasioc.com/forums/show...ight=handsdown

http://www.danielsternlighting.com/t...dvantages.html

http://www.danielsternlighting.com/t...nversions.html

It is probably good to read them in that order. Hopefully after that you will reconsider the HID kit, and put your halogens back in.
FourOnTheFloor65 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HID and NON HID question samg00dy06STI Interior & Exterior Modification 2 04-17-2009 07:33 PM
STi's in Niagara Falls, NY or Michigan ? HID vs non-HID question/content... SportyBry STi Forum Archive 3 07-26-2003 04:37 PM
HID question? AudioFan Interior & Exterior Modification 3 02-08-2002 08:32 AM
HID question and advice leungl Bay Area Impreza Club Forum -- BAIC 1 01-06-2002 01:43 PM
('93-'01) HID question Billy Impreza Forum 2 07-16-2001 03:11 AM


All times are GMT -4. The time now is 04:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.