Welcome to the North American Subaru Impreza Owners Club Sunday February 7, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-01-2010, 01:09 AM   #1
rob17san
Scooby Newbie
 
Member#: 259519
Join Date: Oct 2010
Default Ticking at idle...but not while driving or after

I have the 1995 Impreza L Coupe with the 1.8L, 160K. The car ticks after idling for awhile, but goes away when driving and stays away at stop lights. Only excessive idling initates the tick. Its on the top end for sure. Is it a valve adjustment issue? Or what else could it be? There is plenty of oil, and it gets changed often.

THANK YOU!
* Registered users of the site do not see these ads.
rob17san is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ECU and WBO2 AFRs match at cruise, but not at idle RP31 Engine Management & Tuning 7 04-13-2007 07:20 PM
Running rich at idle but only while fans are on..?? SubieStylez Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 11-01-2006 09:56 PM
Car died at 4000rpm will not make power or idle - need advice gimmewar Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 38 05-14-2006 07:04 AM
Engine ticking at idle? help blazeEJ20 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 02-02-2006 04:45 PM
Another Smoking at Idle but on a Sti? SupersayianNeo Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 13 11-01-2005 06:53 PM

All times are GMT -4. The time now is 09:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.