Welcome to the North American Subaru Impreza Owners Club Saturday September 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-05-2010, 05:39 PM   #1
gleesamo
Scooby Newbie
 
Member#: 143346
Join Date: Mar 2007
Chapter/Region: NWIC
Location: spokane, wa
Vehicle:
03 wrx 285 whp
white

Default injector issues

Alright guys, help me out. I am having a problem and needs help. My car has been running like crap for a while now and found out cyl # 3 is at 75lbs so replacing the shortblock.

My issue now is the injector on cyl 1. Cyl 1 is running WAY lean, when I pulled the spark plug it was white white. So figured faulty injector. My buddy came over from seattle to help me trouble shoot noticed my injector on 1 was making a loud ticking noise, louder then normal. Sooooo, I bought some pinks from fellow nasioc member and still have the same loud ticking noise from injector on cyl 1!?!?!

Where do I go from here? Should I pull off my intake and make sure the fuel lines are clean? Do injectors make a louder ticking noise if they are dry firing? Any info is appriciated!

mods:16g turbo, pinks, full exhaust, front mount, utec, up/down pipe.
* Registered users of the site do not see these ads.
gleesamo is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-05-2010, 07:25 PM   #2
gleesamo
Scooby Newbie
 
Member#: 143346
Join Date: Mar 2007
Chapter/Region: NWIC
Location: spokane, wa
Vehicle:
03 wrx 285 whp
white

Default

b u m p
gleesamo is offline   Reply With Quote
Old 10-05-2010, 10:35 PM   #3
gleesamo
Scooby Newbie
 
Member#: 143346
Join Date: Mar 2007
Chapter/Region: NWIC
Location: spokane, wa
Vehicle:
03 wrx 285 whp
white

Default

bee you em pee
gleesamo is offline   Reply With Quote
Old 10-06-2010, 10:35 AM   #4
gleesamo
Scooby Newbie
 
Member#: 143346
Join Date: Mar 2007
Chapter/Region: NWIC
Location: spokane, wa
Vehicle:
03 wrx 285 whp
white

Default

anybody?
gleesamo is offline   Reply With Quote
Old 10-20-2010, 12:19 PM   #5
DeatschWerks
Former Vendor
 
Member#: 87358
Join Date: May 2005
Chapter/Region: TXIC
Location: Oklahoma City
Default

Have you tried moving injectors around to see if the problem follows the injector or stays on cylinder 1?

Are you sure you are getting fuel to cylinder 1? Are you getting fuel to cylinder 3?
DeatschWerks is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Injector issue DreamEvil Engine Management & Tuning 1 01-03-2010 02:59 PM
Modified Blue Injectors - Issue BlackEyeBugEye Open Source Reflashes 17 07-30-2008 10:37 PM
02 wrx hesitation/ poss fueling/injector issue? 95lwrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 04-19-2008 08:56 PM
Injector issues. Adictwrx Mid Atlantic Impreza Club -- MAIC 4 03-05-2008 08:51 PM
Sti Injector issue please help WRC WRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 03-01-2003 12:45 PM


All times are GMT -4. The time now is 04:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.