Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-08-2010, 04:58 PM   #1
Tbird Man
Scooby Newbie
 
Member#: 71991
Join Date: Oct 2004
Vehicle:
1999 Legacy GT Ltd.
White

Default 1999 2.5 4-cylinder missfire

I just bought a 1999 legacy GT Limited (208K) for $2,600, and got a CEL on the way home. advance says it is a misfire in all four cylinders. I got home and started poking around and found the intake box was not firmly attached to the engine, could this cause my problem? I feel i got a good deal even with any issues it has short of the engine blowing up.
* Registered users of the site do not see these ads.
Tbird Man is offline   Reply With Quote
Old 10-08-2010, 05:09 PM   #2
sachilles
Scooby Specialist
 
Member#: 115107
Join Date: May 2006
Chapter/Region: NESIC
Location: Waitsfield VT
Vehicle:
02 wrx wagon
61 Morris Mini

Default

Probably not the issue, but anything is possible. Was it running crappy, or just throw the light with no other symptoms?
sachilles is offline   Reply With Quote
Old 10-08-2010, 05:33 PM   #3
Tbird Man
Scooby Newbie
 
Member#: 71991
Join Date: Oct 2004
Vehicle:
1999 Legacy GT Ltd.
White

Default

it seems to run ok, maybe a slight miss feeling now and then, but nothing obvious. the CEL starts flashing every now and then.
Tbird Man is offline   Reply With Quote
Old 10-08-2010, 09:19 PM   #4
sol_tegra
Scooby Newbie
 
Member#: 259406
Join Date: Sep 2010
Location: truckee,ca
Vehicle:
02 WRB WRX

Default

pull you spark plugs n look for carbon tracking....
sol_tegra is offline   Reply With Quote
Old 10-08-2010, 11:16 PM   #5
Tbird Man
Scooby Newbie
 
Member#: 71991
Join Date: Oct 2004
Vehicle:
1999 Legacy GT Ltd.
White

Default

I bought plugs and wires today to put on it. bought an air filter too before i realized it has a K&N. I am also going to put some lucas in the fuel.
Tbird Man is offline   Reply With Quote
Old 10-09-2010, 09:39 AM   #6
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

If it has an MAF sensor clean the MAF sensor and get a regular air filter. a loose or leaking intke can cause a misfire, and usully on all cylinder if it does. this is because the quantity of air measured is different than the actual amount entering the cylinders (because of the leak), so the ratio of fuel to air will be off. if its off enough, misfires due to extremely lean or rich mixtures may occur. any codes for "sys lean bank 1" or anything like that?
RaceFaceXC is offline   Reply With Quote
Old 10-09-2010, 12:25 PM   #7
Tbird Man
Scooby Newbie
 
Member#: 71991
Join Date: Oct 2004
Vehicle:
1999 Legacy GT Ltd.
White

Default

ok, so the last guy who had it was an idiot. he put a silicone boot between the TB and the intake, he tried to clamp the boot to the rubber part of the intake and obviously that is where my leak was. removed boot as well as replacing plugs/wires, runs better but still off. when i stab the throttle it hesitates and i hear a gulping sound from the intake, Could this be injectors or fuel system? or perhaps it needs to recalibrate?
Tbird Man is offline   Reply With Quote
Old 10-09-2010, 02:32 PM   #8
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

i dont know how the 95 ECU works, but on the current systems a large fuel trim would be skewed from the leak and it would need to be driven enough to re-adjust to normal. Or resetting the ECU would hopefully start it from a default calibration which should be close to what it needs to be. Dont know how to reset that ECU for sure but disconnecting either battery terminal for a few minutes may work.
RaceFaceXC is offline   Reply With Quote
Old 10-09-2010, 02:59 PM   #9
Tbird Man
Scooby Newbie
 
Member#: 71991
Join Date: Oct 2004
Vehicle:
1999 Legacy GT Ltd.
White

Default

this is actually a '99 LGT, my '95 runs fine.
Tbird Man is offline   Reply With Quote
Old 10-09-2010, 05:32 PM   #10
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Can't hurt to reset the ECU now that you've replaced the plugs and wires and fixed the intake.
Patrick Olsen is offline   Reply With Quote
Old 10-10-2010, 12:08 PM   #11
Tbird Man
Scooby Newbie
 
Member#: 71991
Join Date: Oct 2004
Vehicle:
1999 Legacy GT Ltd.
White

Default

Reset the ECU, runs 1000% better now, thanks for all the help.
Tbird Man is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 1999 2.5 RS coupe 5 speed! Rally Blue! PA! vettez062002 Private Vehicle 'For Sale' Classifieds 8 11-27-2009 09:03 AM
all 4 cylinders missfiring, but car seems to be running ok csimp3 Factory 2.0L Turbo Powertrain 7 01-04-2009 11:08 PM
Swap 1999 2.5 RS engine for 2001 2.5 RS engine c0mrade Subaru Conversions 5 06-15-2006 09:19 PM
2.5 L Cylinder heads 4 sale 1997 fastonthefly Private 'For Sale' Classifieds 0 03-01-2006 10:23 PM
stock 2.5 RS cylinder #3 & 4 misfires sorakiu Normally Aspirated Powertrain 12 06-13-2003 05:49 PM


All times are GMT -4. The time now is 03:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.