Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-16-2010, 12:59 PM   #1
empoweredwendy
Scooby Newbie
 
Member#: 224926
Join Date: Sep 2009
Default Scratches & Chips on block...still use-able?

Ok, tore heads off 99 Impreza Outback 2.2 that son bought with supposed only mis-fire in 2 cyl. The kid busted off the compression gauge bottom in there, got part out. Any ideas on that? I was looking at the block and these chips alarm me; they are mostly on 1 & 3. Other side looked better but there was a lot more carbon and gunk on those pistons. My son thinks I know nothing, maybe I don't but seems to me it would interrupt a proper seal especially when you can't over torque. Whatta ya'all think? Can I use my 2.5 motor I have been saving for a Subie that needs an engine at a cheap price... totaled my 03 Legacy wagon. 2.5 SOHC with 69K on it. Can we swap it. Don't need to do wiring harness right? HELP!!!
Also, I am pretty sure when it was totaled, the timing belt was torn but still on till I removed it. Don't think anyone turned the engine over after it was off, but with kids and hubby, can't be positive. How do we make sure the engine is still good since it has now sat covered in my garage for almost 2 years.
http://s369.photobucket.com/albums/oo132/empoweredwendy/
* Registered users of the site do not see these ads.
empoweredwendy is offline   Reply With Quote
Old 10-16-2010, 01:01 PM   #2
lavid2002
Scooby Specialist
 
Member#: 226864
Join Date: Oct 2009
Location: southern NJ
Vehicle:
2005 PSM WRX
18.5lb. 93 oct, DP, UP

Default

Are you sure those are nicks + chips? When I took my heads off I had stuff that looked like that but I bet its just from having some flaws in the casting process. Im not sure though. I dont know it well enough. I think you can deck a block worst case scenario but a lot of garbage comes along with it.

Why dont you clean up the piston heads, cylinder walls, and block and take some pictures then?
Some looking flat across the block would be helpful I would imagine.
lavid2002 is offline   Reply With Quote
Old 10-16-2010, 01:51 PM   #3
empoweredwendy
Scooby Newbie
 
Member#: 224926
Join Date: Sep 2009
Default













empoweredwendy is offline   Reply With Quote
Old 10-16-2010, 07:34 PM   #4
69subaru360
Scooby Guru
 
Member#: 159682
Join Date: Sep 2007
Chapter/Region: NESIC
Location: Maine
Vehicle:
1995 WRX
1998 2.5 RS

Default

Everything looks normal.
69subaru360 is offline   Reply With Quote
Old 10-16-2010, 08:45 PM   #5
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

pssshhhh I've run worse :P
sidewayz is online now   Reply With Quote
Old 10-16-2010, 10:57 PM   #6
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Looks fine to me. Have all the surfaces resurfaced and it'll look good as new.
alcoolaid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Will i still be able to use the vf39 turbo after spun bearing? mr.phil.roxass Newbies & FAQs 5 11-02-2009 01:45 PM
Will you still be able to use crusie control after getting a TBE/EM SubyWRXSti AccessPort 5 10-08-2006 11:56 PM
PDX Protune on 04WRX AccessPort --> able to be used on an '05WRX? doylfish AccessPort 3 06-17-2006 02:47 PM
can i spray paint my helmet and still be able to use it in auto x? Duo Motorsports 6 03-05-2004 02:44 AM
Question on paint. NOT scratches and chips. Evaider Car Care & Detailing 9 01-22-2002 03:52 PM


All times are GMT -4. The time now is 09:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.