Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-17-2010, 02:05 PM   #1
freddiemac24
Scooby Newbie
 
Member#: 83706
Join Date: Mar 2005
Default 2.5 hybrid sounds terrible?

I just got my o4 wrx back from the shop. They installed a 2.5 shortblock, and im currently running stage 2 on my access port. The shop says the reason its running so bad is because it needs a tune. It almost sounds as bad as it did when i took it in there with a spun bearing. does this sound right or should i take it back to the shop and tell them to check over it again?
* Registered users of the site do not see these ads.
freddiemac24 is offline   Reply With Quote
Old 10-17-2010, 04:12 PM   #2
gleesamo
Scooby Newbie
 
Member#: 143346
Join Date: Mar 2007
Chapter/Region: NWIC
Location: spokane, wa
Vehicle:
03 wrx 285 whp
white

Default

post a vid of what it sounds like
gleesamo is offline   Reply With Quote
Old 10-17-2010, 07:47 PM   #3
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

What exactly sounds bad?
sidewayz is offline   Reply With Quote
Old 10-17-2010, 08:24 PM   #4
Boost!
Scooby Newbie
 
Member#: 201148
Join Date: Jan 2009
Chapter/Region: MWSOC
Location: Indianapolis, Indiana
Vehicle:
2006 Impreza WRX STI
OBP

Default

x2 on posting up a quality video.
Boost! is offline   Reply With Quote
Old 10-17-2010, 11:23 PM   #5
hot-j
Scooby Newbie
 
Member#: 260982
Join Date: Oct 2010
Default

It should NOT sound like it did when it had a spun bearing. Timing might be off.
hot-j is offline   Reply With Quote
Old 10-18-2010, 05:25 AM   #6
Halls
Scooby Newbie
 
Member#: 241214
Join Date: Mar 2010
Chapter/Region: NWIC
Location: portland
Vehicle:
2002 wrx
wrb

Default

gtfo,the shop didn't bother to pro tune and just gave you back the car. I wouldn't even risk driving it anymoreuntil you get it properly tuned.
Halls is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Do WRX 2.5 hybrids sound different than 2.0? superg Built Motor Discussion 17 06-30-2007 04:13 PM
Any 2.0/2.5 Hybrids using SZ49 or FP Green joeyd02 Subaru Conversions 2 01-02-2006 05:15 AM
2.0/2.5 hybrids sube-trex Factory 2.0L Turbo Powertrain 0 11-08-2005 01:31 PM
Day 5, almost 200 miles on 2.5 Hybrid, all is going well :) Davenow Subaru Conversions 17 06-26-2005 08:59 PM


All times are GMT -4. The time now is 10:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.