Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-18-2010, 09:26 PM   #1
GEE-OTTO
Scooby Specialist
 
Member#: 201277
Join Date: Jan 2009
Chapter/Region: MAIC
Location: Arlington VA
Vehicle:
2009 Legacy GT
OBP

Default p0420 only with more than 1/4 tank. HELP

I have a odd issue with my 2008 LEgacy 2.5i. As of late (last 1000 miles) it throws the P0420 CEL when I fill up and stay on until i get down to 1/4 tank then it goes off. As soon as I fill up the light comes back one. Now besides a bad rear o2 and not other codes to suggest anything else, what do you think would cause this? I am going to order a new rear o2 from Rock Auto and patch it in and I hope that helps b/c no other codes are present to point to another cause of the issue.

Any help would be great or suggestions
* Registered users of the site do not see these ads.
GEE-OTTO is offline   Reply With Quote
Old 10-18-2010, 11:35 PM   #2
williaty
Scooby Guru
 
Member#: 71092
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: Delaware County, Ohio
Vehicle:
2005 2.5RS Wagon
Regal Blue Pearl

Default

Wiring problems. Go talk to the dealership.
williaty is offline   Reply With Quote
Old 10-19-2010, 02:29 AM   #3
chRS
Scooby Newbie
 
Member#: 228073
Join Date: Oct 2009
Default

it should be covered under factory warranty since p0420 is an emission related problem. bring it to the dealer.
chRS is offline   Reply With Quote
Old 10-19-2010, 09:08 AM   #4
GEE-OTTO
Scooby Specialist
 
Member#: 201277
Join Date: Jan 2009
Chapter/Region: MAIC
Location: Arlington VA
Vehicle:
2009 Legacy GT
OBP

Default

Well I would but my car is out of warranty ( yes it's an 08 w/ 67.5k miles) so if the stealer is going to charge me for a new sensor I'd rather do it myself
GEE-OTTO is offline   Reply With Quote
Old 10-20-2010, 08:26 AM   #5
GEE-OTTO
Scooby Specialist
 
Member#: 201277
Join Date: Jan 2009
Chapter/Region: MAIC
Location: Arlington VA
Vehicle:
2009 Legacy GT
OBP

Default

The light comes on and goes off under a quarter tank and over three quarters of a tank. This makes perfect sense because the the ECU only monitors Catalytic converter effciency or defficiency between 3/4 and 1/4 tank of fuel. This expalins why I get light when full or low!!

My converter is actually bad but the ECU doesn't give a damn but only 1/2 the time (3/4-1/4 = 1/2)
GEE-OTTO is offline   Reply With Quote
Old 10-20-2010, 11:46 AM   #6
motohippy
Scooby Newbie
 
Member#: 225882
Join Date: Oct 2009
Location: Central NJ
Vehicle:
2000 OBS
'88 BMW K75S

Default

I may be wrong here, but it looks like if your converter goes bad you've got federally mandated warranty on it til 80K.
http://www.epa.gov/oms/consumer/warr95fs.txt
motohippy is offline   Reply With Quote
Old 10-20-2010, 12:08 PM   #7
RaineMan
Scooby Specialist
 
Member#: 256727
Join Date: Sep 2010
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2007 2.5I Wagon
Silver

Default

Quote:
Originally Posted by GEE-OTTO View Post
Well I would but my car is out of warranty ( yes it's an 08 w/ 67.5k miles) so if the stealer is going to charge me for a new sensor I'd rather do it myself
Call the dealer and check on warranty status. In 2008 some Subarus were certified as PZEV, which carries an extended warranty on emissions components in certain states.
RaineMan is offline   Reply With Quote
Old 10-20-2010, 03:52 PM   #8
GEE-OTTO
Scooby Specialist
 
Member#: 201277
Join Date: Jan 2009
Chapter/Region: MAIC
Location: Arlington VA
Vehicle:
2009 Legacy GT
OBP

Default

Hey so I went to the dealer and as luck would have it the P0420 light went off and more oddly they said it wasn't stored in the ecu however I did notice my ecu was reset as it stumbles at idle hard fir the first few miles after a reset. Could the tech have rest the ecu then tried to read the trouble codes ? Don't they stay in memoryafter the light goes off and a reset? ( purge all built up electricity ) they claim there is no code and they will need to read the code before they honor a warranty repair or I have to pay $$$ for the diagnostic charge

And the p0420 hasn't came back yet which is how I know they rest it bc I do the same thing and it takes about 2 weeks to showup again.
GEE-OTTO is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
More FBKC when under 1/4 tank of gas? aberg12012 Engine Management & Tuning 5 05-11-2010 12:16 PM
Used '08 WRX only $1K more than Used '06 WRX? Why? snvin General Community 28 11-06-2008 03:05 PM
Nickquest, a list of all the otters with more than 10 warning points -=C=- Off-Topic 140 09-23-2005 07:02 PM
Acura is going to have AWD with more than Subaru! 2002WRXSTi Off-Topic 29 12-10-2004 11:44 PM
Car won't let me run more than 18.4 psi? rasheeb Engine Management & Tuning 15 11-09-2003 12:40 PM


All times are GMT -4. The time now is 06:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.