Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-29-2011, 01:08 AM   #101
SmokescreenWRKS
Scooby Newbie
 
Member#: 276040
Join Date: Mar 2011
Location: Maryland
Vehicle:
2011 WRX Hatch
Rally Blue

Default

Quote:
Originally Posted by xluben View Post
I got my car in October 2010. About a month later the clutch started clicking. Brought the car in to the dealer in November 2010. They diagnosed it as a bad clutch master cylinder. The master cylinder was replaced. The car was click free for probably 6 months. Sometime during this 6 months I installed the brake master cylinder brace.

I got mine around the time you got yours! Hah! and I heard the cliking at around November also!

Try the antiseize on the spring. Get it all over the mating interfaces of the spring (anything that touches the spring) Good luck.

And if anyone has pictures of that cracked weld please post. Thanks in advnaced.
* Registered users of the site do not see these ads.
SmokescreenWRKS is offline   Reply With Quote
Old 08-01-2011, 10:55 AM   #102
mothrgoosr
Scooby Newbie
 
Member#: 289374
Join Date: Jul 2011
Vehicle:
2011 WRX

Default Same issue

I have a 2011 wrx sedan with 900 miles and just started hearing a single click noise in the first few inches of travel. Im going to try and crawl underneath the dash tonight and see if I can tell where it is coming from...Anyone determine a final answer for what is causing this? I have seen people say MC, cracked welds (ouch), a safety switch noise, or even just a temporary issue that goes away. It is weird that something like this would present itself before the break in period is over.
mothrgoosr is offline   Reply With Quote
Old 08-01-2011, 03:10 PM   #103
mothrgoosr
Scooby Newbie
 
Member#: 289374
Join Date: Jul 2011
Vehicle:
2011 WRX

Default

I checked under the dash and it is definitely the clutch switch for me. I could repeat it it by pushing the clutch in with my hand and then manually actuating the switch...seems like it is just a bit rough in its travel and when the plunger comes all the way out it makes a slight click sound. Not a big deal for me... If someone knew of a safe lube for that plunger I'm sure it would go away...
mothrgoosr is offline   Reply With Quote
Old 08-01-2011, 06:36 PM   #104
09rexwagon
Scooby Specialist
 
Member#: 216135
Join Date: Jul 2009
Vehicle:
2011 Civic SI
STX #66, 06 S2000 STR 180

Default

Quote:
Originally Posted by mothrgoosr View Post
I checked under the dash and it is definitely the clutch switch for me. I could repeat it it by pushing the clutch in with my hand and then manually actuating the switch...seems like it is just a bit rough in its travel and when the plunger comes all the way out it makes a slight click sound. Not a big deal for me... If someone knew of a safe lube for that plunger I'm sure it would go away...
My clutch switch got replaced 3 times and the noise always came back. Dielectric grease would work if you took it apart. The dealer would never let me keep the switch so I could fix it though.
09rexwagon is offline   Reply With Quote
Old 08-10-2011, 10:34 AM   #105
2bfi
Scooby Newbie
 
Member#: 265981
Join Date: Dec 2010
Vehicle:
2011 STi Sedan
Dark Gray

Default

Quote:
Originally Posted by mothrgoosr View Post
I checked under the dash and it is definitely the clutch switch for me. I could repeat it it by pushing the clutch in with my hand and then manually actuating the switch...seems like it is just a bit rough in its travel and when the plunger comes all the way out it makes a slight click sound. Not a big deal for me... If someone knew of a safe lube for that plunger I'm sure it would go away...
My clutch switch is also causing the clicking. Sometimes it just stops. I wonder if it's just lubrication.
2bfi is offline   Reply With Quote
Old 09-07-2011, 03:14 PM   #106
adrianwrx11
Scooby Newbie
 
Member#: 293740
Join Date: Sep 2011
Location: new york
Vehicle:
2011 subaru wrx
white

Default

Quote:
Originally Posted by David920 View Post
Just started feeling/hearing a click when the clutch is pressed. Its not always there. I had my dealer check it out and they say its normal (though I never noticed it in the first 500 miles). Its about 700 miles now. Anyone else hear/feel this click? It feels as if a component is flicking off another.

honestly i dont think any clicking or noise comeing from the clutch should be considered as normal .. and just to add to this i have 2011 white wrx with 13k miles on it and already had my clutch replaced by the Subaru dealer . and for free warranty took care of it . but that's just because i went to the dealer multiple of times b4 the clutch burned out and failed a complain stating that my clutch felt really stiff and numb, i can almost compare it too as if you were pressing some kind of jello ... well the dealer checked and confirmed that car and clutch were working according to factory specifications ..while my buddy got same exact car but in blue and his clutch always felt nice and soft and responsive ... well i drove it like that till it burned out took it to the dealer ... they had to call someone up from "soa" and they they fixed it but i wasn't happy for long because the clutch after the fix felt how it sepousse to be only for maybe 3-4 days then went back to feeling stiff and numb... funny thing is when i left the car untouched for 2 days then started it the clutch felt as brand new for about 30 min then gradually started getting stiff and numb ... today 9-7-11 i took it in to the dealer with the complain of stiffness and numbness they said theyll call me back Thursday- Friday this week... also did anyone ales experience similar problem as me.. ?
adrianwrx11 is offline   Reply With Quote
Old 10-17-2011, 12:37 PM   #107
ejhayes76
Scooby Newbie
 
Member#: 267923
Join Date: Dec 2010
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2011 Impreza 2.5i

Default

Quote:
Originally Posted by ejhayes76 View Post
about 2.5 weeks later and I am hearing a clicking sound from the clutch pedal again. However, I am not sure it is the MC or just the clutch switch. I can get the brake pedal to make a similar sound sometimes too. It sounds like a relay or switch right now. It is not the loud multiple popping noise I was getting before.

I will continue to update. If the loud noise comes back, that will be a bummer. Even the softer clicking is abnormal to me, but this car makes a lot of electrical relay and switch noises
It has been about 6 months since this was fixed. The clicking switch is back and has been since a few weeks after the master cylinder replacement last spring.

I notice it happens with the clutch pedal all of the time, unless the pedal is pushed down slowly. It will happen with the brake pedal too, if that pedal is pushed quickly (like you would push a clutch pedal down). I usually push the brake more slowly than the clutch, so usually the brake pedal is quiet.

I think it is annoying, but I don't think there is a solution. I think its a bad switch design for the cruise control.
ejhayes76 is offline   Reply With Quote
Old 10-21-2011, 12:11 AM   #108
pvn
Scooby Newbie
 
Member#: 298511
Join Date: Oct 2011
Location: San Francisco Bay Area
Default

NOOOO. I can not believe this! I am so sad.

I drove Honda Accord which in Europe is the same as US Acura TSX. I had the same clicking/creaking/squeaking/ clutch pedal/MC. I have wasted a months reading the whole Internet and trying almost every possible fix. The noise came back soon or later. After that i just gave up and decided I could not live with this annoying noise and I keep driving it knowing I will sell the car soon. Apart from that the car was rock soild!!! But just this noise destroys my whole joy of driving the car.


During the time I had my Accord I found in the Internet that TSX is not the only model which is affected by this problem, not even the only brand! I found the same complains from Acura, Toyota and Nissan owners. And NOW right before I am going to by WRX I am facing this thread. I CAN NOT BELIEVE THIS. I am assuming that this "clicking/creaking/squeaking/ clutch pedal/MC" problem is a Japanese thing.

Now I do not know what to do. I was definitely convinced that I will buy 2012 WRX in the next two weeks. Now I am lost. There is no other car I like in this price-tag. So saaaaaaaaaaaaaaaadddddddddddd. But I definitely do not want to hear and feel on my feet this clicking and popping "thing" in my life!

Please tell me something promising.

Sorry for my bad English.

Last edited by pvn; 10-21-2011 at 12:19 AM.
pvn is offline   Reply With Quote
Old 10-22-2011, 10:32 PM   #109
1cleenwrx
Scooby Specialist
 
Member#: 170542
Join Date: Jan 2008
Chapter/Region: MAIC
Location: HAMPTON,VA
Vehicle:
08 AGILEbuilt-STI
93Soarer/01RSTI/06SPEC-B

Default

heys guys, just weld the brace in there. fixes it all.
1cleenwrx is offline   Reply With Quote
Old 10-23-2011, 02:48 AM   #110
pvn
Scooby Newbie
 
Member#: 298511
Join Date: Oct 2011
Location: San Francisco Bay Area
Default

I still wonder whether to order a 2012 WRX. Would be possible to arrange an inspection of the problematic area (pedal assembly and firewall) and re-welding if necessary before I buy? Would this be fixed from the factory in 2012 WRX? What do you think?

Thank you!
pvn is offline   Reply With Quote
Old 10-24-2011, 01:12 AM   #111
ejhayes76
Scooby Newbie
 
Member#: 267923
Join Date: Dec 2010
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2011 Impreza 2.5i

Default

@1cleenwrx, what and where are you welding? I think the sound is a switch, but if you had the clicking and welding fixed it, please send instructions.

I am more inclined to try and figure out how to remove the cruise switch for the brake and clutch, as I think that's what it is clicking. I never use cruise anyway.

@pvn. My pedal didn't start the click noise until about 3000 miles, so you won't likely know when its brand new.
ejhayes76 is offline   Reply With Quote
Old 10-24-2011, 02:03 AM   #112
pvn
Scooby Newbie
 
Member#: 298511
Join Date: Oct 2011
Location: San Francisco Bay Area
Default

Quote:
Originally Posted by ejhayes76 View Post
@pvn. My pedal didn't start the click noise until about 3000 miles, so you won't likely know when its brand new.
Too bad. I think I will not buy WRX then. I just do not want to go trough the whole nightmare AGAIN. And I do not want every time I press the clutch pedal to fear and to expect to hear/feel something familiar.

The click from the switch is completely different thing. Do not mix it up with the creaking! The clicking switch is harmless and does not make me crazy. I can deal with this noise but the creaking is annoying as hell. And not only the noise but you can actually feel it on your foot.

BTW you can easily eliminate the clicking switch by putting some tape on it making it pressed all the time even when the pedal is pressed. But this way you can only switch off the cruise control from the steering wheel button. It is a little dangerous in a extreme situations but still is a solution. You can try this just for a test - to test whether the switch indeed is making the click or it is something else. I have done this on my (not mine already) Accord.


I am still sad. I love this WRX sedan! Does anyone know if this problem is resolved permanently in the 2012 version? How long would take to someone to investigate the new 2012 model and make a statement whether the design of the clutch pedal assembly and firewall has been changed or not? This would be VEEEERRRYYYYY helpful. If someone tell me this is fixed by Subaru from the factory I am putting some shoes and go right to the dealer to order a WRX. If not and if someone is willing to fix it for me I would be happy to pay reasonably. All: feel free to PM me if you think you can help.

Thank you!

Last edited by pvn; 10-24-2011 at 02:33 AM.
pvn is offline   Reply With Quote
Old 10-29-2011, 11:07 PM   #113
bicycle_wreck
Scooby Newbie
 
Member#: 226331
Join Date: Oct 2009
Chapter/Region: South East
Location: Knoxville, TN
Vehicle:
2012 WRX Hatch
Dirty Smurf

Default

Quote:
Originally Posted by SmokescreenWRKS View Post
It sems that as the MC wears it puts slightly more pressure on the clutch assembly probably not enought to notice but enought to break the welds on the link from clutch to the firewall. This ultimately misalignes the spring assist assembly causing this clicking sound.

It seems when everyone who's replaced the MC seems to end up having the cliking sound come back.

Putting antiseize on the spring bushing and center alignment seems to eliminate the sound. But the weld could still be cracked. Does anyone have pictures of this clutch link to the firewall?

Been 6mo now and no clicking on my end.
Pics of broken welds here: http://www.3gwrx.com/forum/index.php/topic,15651.0.html
bicycle_wreck is offline   Reply With Quote
Old 10-30-2011, 09:34 PM   #114
bannana_612
Scooby Newbie
 
Member#: 299501
Join Date: Oct 2011
Default shift into 2nd?

Hey new guy kinda off topic but I have a 2011 wrx hatch with about 800miles i seem to have issues shifting from 1st to 2nd without it feeling kind of rough is that just the way this clutch is? My last car was an 09 cobalt ss 5spd and it was a breeze to shift just wondering if its something I need to get a feel for? Thanks guys
bannana_612 is offline   Reply With Quote
Old 10-31-2011, 11:49 AM   #115
ejhayes76
Scooby Newbie
 
Member#: 267923
Join Date: Dec 2010
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2011 Impreza 2.5i

Default

Quote:
Originally Posted by bannana_612 View Post
Hey new guy kinda off topic but I have a 2011 wrx hatch with about 800miles i seem to have issues shifting from 1st to 2nd without it feeling kind of rough is that just the way this clutch is? My last car was an 09 cobalt ss 5spd and it was a breeze to shift just wondering if its something I need to get a feel for? Thanks guys
Off-topic, suggest you start a new thread or search for an existing thread on shifting.
ejhayes76 is offline   Reply With Quote
Old 10-31-2011, 07:29 PM   #116
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Just rolled over 15k and noticed a clutch pedal issue. My clutch sometimes clicks but it doesn't really bother me--however, on the way home tonight it started "grinding" with a minor squeak on its last 20% of travel or so. This is INCREDIBLY annoying as I often clutch all the way to the floor if I'm coasting to a stop in traffic (<5mph, out of first gear etc.).

Anyone experienced this grinding/squeaking? Or just the clicking.
foolycooly is offline   Reply With Quote
Old 10-31-2011, 08:41 PM   #117
Airplay355
Scooby Specialist
 
Member#: 213825
Join Date: Jun 2009
Chapter/Region: NESIC
Location: Southern Maine
Vehicle:
2011 WRX
SWP

Default

Mine was clicking in the beginning but now at ~14k miles it's long gone and silent.
Airplay355 is offline   Reply With Quote
Old 11-02-2011, 09:29 PM   #118
ejhayes76
Scooby Newbie
 
Member#: 267923
Join Date: Dec 2010
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2011 Impreza 2.5i

Default

Quote:
Originally Posted by Airplay355 View Post
Mine was clicking in the beginning but now at ~14k miles it's long gone and silent.
I've heard a few reports like this.

I"m at 9K miles now. I won't bother taking it back to the dealer again since I expect it to come back. I Hope it wears in and goes away.

If I get motivated, I may try anti-seize, but I"m not sure where to apply it. I may also try to tape ove the cruise switch and/or remove it. I never use cruise, ever.
ejhayes76 is offline   Reply With Quote
Old 11-04-2011, 10:56 AM   #119
Bruins1982
Scooby Newbie
 
Member#: 240365
Join Date: Mar 2010
Chapter/Region: NESIC
Location: MA
Vehicle:
2011 WRX Premium
Sedan WRB

Default

Quote:
Originally Posted by ejhayes76 View Post
I've heard a few reports like this.

I"m at 9K miles now. I won't bother taking it back to the dealer again since I expect it to come back. I Hope it wears in and goes away.

If I get motivated, I may try anti-seize, but I"m not sure where to apply it. I may also try to tape ove the cruise switch and/or remove it. I never use cruise, ever.
I had the dealer lubricate mine. The click went away for about a week, came back, and now it's gone again. Seems to pop up at random.
Bruins1982 is offline   Reply With Quote
Old 11-30-2011, 11:46 AM   #120
iwanbo
Scooby Specialist
 
Member#: 81951
Join Date: Feb 2005
Chapter/Region: NESIC
Location: CT
Vehicle:
2011 WRX Hatch
WRB

Default

I'm around 13k miles on my 2011 and I still get the clicking here and there. It seems to only happen when the car sits for long periods of time (e.g. starting it in the morning to go to work and leaving work). It'll click a handful of times and then stop.

I'd like to have the dealer check it out, but by the time I get the dealership I know the clicking will be gone. Is there a TSB or anything out for this, or is it just dealership fixing it on a case by case basis?
iwanbo is offline   Reply With Quote
Old 12-02-2011, 09:56 PM   #121
bgj1010
Scooby Newbie
 
Member#: 286090
Join Date: Jun 2011
Chapter/Region: NESIC
Location: Worcester, MA
Vehicle:
2011 WRX Limited 5dr
Lightning Red Pearl

Default

So this thread is mainly about the clicking from the cruise relay, which is definitely normal. Switches click. It's what they do. My hearing may not be the best, but I can barely hear mine, although I definitely do. If you could hear that over the engine, radio and normal road noise, you must have bionic ears.
My problem is in regards to the actual stuttering/squealing that if I'm not mistaken, 3 people posted about in this thread. My 2011 WRX Limited has around 8K on her, and just last week this happened to me. It went away and came back twice, and has subsided, thankfully, and hopefully someone can shed light on this. The first time it happened, it was just bumper to bumper traffic headed home from work. No clutch riding or anything, nice and smooth. My friend mentioned perhaps a "glazed clutch" so I intentionally rode the clutch going slow in 2nd and it went away. The second time it happened, I dropped it down from 4th and nailed it, but it was a perfect shift, so I can't see why this would've happened??
The stutter feeling happens at about 1/2 to 3/4 of the way out, releasing slowly. Less stutter when quicker, but I don't "pop" my clutch like that, rather smooth and steady. Once, in the 3 occurrences, it made a very strange, squealing sound. It went away almost immediately. As one of the previous posters' stated, in neutral it was smooth as normal, then when in gear the stutter occurred. Any more of these instances by anyone else? Any resolutions to those who previously posted? Thx...
bgj1010 is offline   Reply With Quote
Old 12-03-2011, 04:15 AM   #122
pmccut
Scooby Newbie
 
Member#: 300048
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Palo Alto, CA
Vehicle:
2012 WRX
WRB

Default

Quote:
Originally Posted by pvn View Post
Too bad. I think I will not buy WRX then. I just do not want to go trough the whole nightmare AGAIN. And I do not want every time I press the clutch pedal to fear and to expect to hear/feel something familiar.

The click from the switch is completely different thing. Do not mix it up with the creaking! The clicking switch is harmless and does not make me crazy. I can deal with this noise but the creaking is annoying as hell. And not only the noise but you can actually feel it on your foot.

BTW you can easily eliminate the clicking switch by putting some tape on it making it pressed all the time even when the pedal is pressed. But this way you can only switch off the cruise control from the steering wheel button. It is a little dangerous in a extreme situations but still is a solution. You can try this just for a test - to test whether the switch indeed is making the click or it is something else. I have done this on my (not mine already) Accord.


I am still sad. I love this WRX sedan! Does anyone know if this problem is resolved permanently in the 2012 version? How long would take to someone to investigate the new 2012 model and make a statement whether the design of the clutch pedal assembly and firewall has been changed or not? This would be VEEEERRRYYYYY helpful. If someone tell me this is fixed by Subaru from the factory I am putting some shoes and go right to the dealer to order a WRX. If not and if someone is willing to fix it for me I would be happy to pay reasonably. All: feel free to PM me if you think you can help.

Thank you!
I believe I have the same issue in my '12. <500 miles, seems to do it mostly late at night when it's colder.
pmccut is offline   Reply With Quote
Old 12-03-2011, 03:07 PM   #123
bgj1010
Scooby Newbie
 
Member#: 286090
Join Date: Jun 2011
Chapter/Region: NESIC
Location: Worcester, MA
Vehicle:
2011 WRX Limited 5dr
Lightning Red Pearl

Default

Look under the dash as you push the clutch in with your hand. You will see the spring-assist mechanism, and hear it creak. Mine hasn't creaked loud enough to hear, but when I was down there trying to see if I could identify my problem, I saw the spring and heard a barely audible, faint creaking. It obviously shouldn't make any noise at all, especially on a brand new car with les than 500K , but ithat should be easily resolved with some lube, whether it be white lith in an aerosol can or from a grease gun, slathered into the mechanism with a paintbrush or something similar. Work it in good, with the clutch all the way in and out. Save a trip to the dealer, whether it's under warranty or not, for something you could probably resolve yourself in less than 5 min... I fixed my "crazy blinkers" myself (yes, both driver AND passenger), in less than 10 min each, whereas some people afraid to unscrew a bolt took it to the dealer and wasted time they'll never get back :P

I love my car
bgj1010 is offline   Reply With Quote
Old 01-15-2012, 04:27 PM   #124
RobSnyderSCR
Scooby Newbie
 
Member#: 286610
Join Date: Jun 2011
Location: Northern California
Vehicle:
2008 Subaru WRX

Default

I had this same problem with clicking. I solved mine by spraying seafoam spray on the spring in the clutch pedal assembly. I also sprayed the rod by the gas pedal that goes through the firewall. I still have squeaking issues but the click is gone!!

Last edited by RobSnyderSCR; 01-15-2012 at 11:16 PM.
RobSnyderSCR is offline   Reply With Quote
Old 01-23-2012, 06:42 PM   #125
barold
Scooby Newbie
 
Member#: 243476
Join Date: Apr 2010
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
'11 5-door WRX
WRB

Unhappy Video of Clicking

The clicking just started on my way home today and I wanted to post this video up to show people that it is not the cruise control switch. The last two clicks in the video show this fact best.


I'm not sure what to do at this point considering most of the fixes only sound temporary.
barold is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch pedal clicking noise GeLLo_Boi Newbies & FAQs 6 03-01-2008 08:37 PM
Clutch making clicking / ticking type noise t3ch9 Transmission (AT/MT) & Driveline 2 05-25-2006 02:25 PM
Clutch making a clicking noise popnfresh Transmission (AT/MT) & Driveline 0 06-10-2005 01:28 PM
Weird clicking noise when I put in first and let go of clutch m u f a s i s Transmission (AT/MT) & Driveline 22 02-20-2004 01:06 PM
Click noise when releasing clutch? NicGordon Transmission (AT/MT) & Driveline 0 10-24-2002 12:07 AM


All times are GMT -4. The time now is 01:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.