Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-11-2013, 03:02 PM   #2676
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Quote:
Originally Posted by bettner12 View Post
I KNOW! i want them!!!

tom, what part of slippery rock are you in? i could swing up sometime and lend a hand sometime

My house boarders the field with the water tower at the top of Center Street. Hell, you could even come up just to drink my beer.
* Registered users of the site do not see these ads.
dexterous is offline   Reply With Quote
Old 05-11-2013, 03:03 PM   #2677
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

IT RUNS AGAIN!!!

dexterous is offline   Reply With Quote
Old 05-11-2013, 03:04 PM   #2678
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Working on the car right now so I dont want to spend a ton of time posting BUT, I finally got the car running today. I put the last bolt in, primed the oil, primed the fuel and hit the key. It started up right away, idled flawlessly and otherwise seems perfect.
dexterous is offline   Reply With Quote
Old 05-11-2013, 04:05 PM   #2679
bboylocob
Scooby Specialist
 
Member#: 151809
Join Date: Jun 2007
Chapter/Region: South East
Location: New Orleans
Vehicle:
2007 WRX
Black

Default

Sweet!!!! Great news!!!!!
bboylocob is online now   Reply With Quote
Old 05-11-2013, 06:09 PM   #2680
TwinscrollGT35R
Scooby Specialist
 
Member#: 256810
Join Date: Sep 2010
Chapter/Region: International
Default

Sweet...
TwinscrollGT35R is offline   Reply With Quote
Old 05-11-2013, 07:37 PM   #2681
Layvon
NASIOC Supporter
 
Member#: 195711
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cadillac MI
Vehicle:
STi 04/05/06/07
JBP / OBP for now

Default

What is the cooler in location of stock tmic? Fuel or oil?
Layvon is online now   Reply With Quote
Old 05-11-2013, 09:16 PM   #2682
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

oil i think.

if you have any post some pics of the compressor elbow going to the fmic piping.
stretchedk7 is offline   Reply With Quote
Old 05-11-2013, 09:26 PM   #2683
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Quote:
Originally Posted by Layvon View Post
What is the cooler in location of stock tmic? Fuel or oil?
Thats my Setrab oil cooler. I run -10 hoses form a Mocal filter adapter. Its top notch stuff and I see ZERO pressure drop.
dexterous is offline   Reply With Quote
Old 05-11-2013, 09:50 PM   #2684
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Quote:
Originally Posted by stretchedk7 View Post
oil i think.

if you have any post some pics of the compressor elbow going to the fmic piping.
I didn't have any but I am in the garage so here you go. I have a big camera and its a very tight spot so this is the best I could do without taking the car apart again.










dexterous is offline   Reply With Quote
Old 05-12-2013, 12:35 PM   #2685
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

sweeet. so looks to me like you didnt weld an elbow on compressor but used a 90 degree coupler?

jw, in the past ive had to weld an elbow because of space
stretchedk7 is offline   Reply With Quote
Old 05-12-2013, 12:53 PM   #2686
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Quote:
Originally Posted by stretchedk7 View Post
sweeet. so looks to me like you didnt weld an elbow on compressor but used a 90 degree coupler?

jw, in the past ive had to weld an elbow because of space
You're correct. Space wasn't an issue at all but I think I would like to convert it to a solid, welded bend next winter. I have not put any effort into things like that as my only goal for the past two years has been to get the car tuned. Thus far, I haven't been all that successful due to some pretty bad luck. I could have had it tuned at any point last year BUT I was very concerned that I was going to experience another block failure. Now that I am running a fully closed deck block with reinforcement material that runs all the way down the outside of the cylinder wall I think its time to give it a go.
dexterous is offline   Reply With Quote
Old 05-12-2013, 01:04 PM   #2687
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

sweeet sounds good. do it big
stretchedk7 is offline   Reply With Quote
Old 05-12-2013, 07:24 PM   #2688
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Well, I spoke too soon. I went to go for a drive, pulled out onto the main street and heard a horrible noise (sounded like a boost leak or something). Turned around, and went back to my house to discover that my turbo's compression was hitting the side of the housing. The turbo is out and I cant find anything else wrong with the car.

I hope this is because something happened to it while it was in storage this winter and not some kind of foreign object damage. The compressor is toast but the turbine looks perfect.

Last edited by dexterous; 05-12-2013 at 07:43 PM.
dexterous is offline   Reply With Quote
Old 05-12-2013, 08:13 PM   #2689
isis
Scooby Specialist
 
Member#: 73283
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
05 CTS-V
03 Z1000

Default

**** dude...
isis is offline   Reply With Quote
Old 05-12-2013, 08:41 PM   #2690
ringlander
Scooby Newbie
 
Member#: 336100
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: nj
Vehicle:
2011 sti

Default

So sorry to hear that. I hope it stops at the turbo. Did you take any pictures?
ringlander is offline   Reply With Quote
Old 05-12-2013, 08:44 PM   #2691
Fir3Fighter
Scooby Newbie
 
Member#: 316780
Join Date: Apr 2012
Chapter/Region: MAIC
Location: Parkersburg, WV
Vehicle:
2003 Impreza WRX
Silver

Default

I hate ****ty luck..
Fir3Fighter is offline   Reply With Quote
Old 05-12-2013, 08:45 PM   #2692
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

You can't catch a break Tom. Does it look like something went through the turbo or was it just a rub?
kellygnsd is offline   Reply With Quote
Old 05-12-2013, 09:35 PM   #2693
bboylocob
Scooby Specialist
 
Member#: 151809
Join Date: Jun 2007
Chapter/Region: South East
Location: New Orleans
Vehicle:
2007 WRX
Black

Default

Dang bro that sucks!!!! Its all good we know u will get it fixed and running asap. Keep Ur head up
bboylocob is online now   Reply With Quote
Old 05-12-2013, 09:37 PM   #2694
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

jeeeez man......dont know what to say
stretchedk7 is offline   Reply With Quote
Old 05-12-2013, 09:52 PM   #2695
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Dayamn dude your luck's got to change for the better! Very sorry to hear this!

Last edited by manitou; 05-12-2013 at 10:20 PM.
manitou is offline   Reply With Quote
Old 05-12-2013, 10:24 PM   #2696
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Quote:
Originally Posted by kellygnsd View Post
You can't catch a break Tom. Does it look like something went through the turbo or was it just a rub?
I took the entire turbo apart and couldn't find any explanation. There's a lot of runout on the compressor and you can clearly see where its rubbing the housing. The turbine is perfect or at least as perfect as I can tell by looking at it. It also makes a pretty bad noise when I rotate the blades by hand. I see no evidence that the compressor ingested anything but I wouldn't have expected to see that either given that theirs a filter right on the end of the turbo. Its all packed up again and heading to comp in the morning. USPS says that it will be there on Wednesday so hopefully this is only a two week delay.
Tom
dexterous is offline   Reply With Quote
Old 05-12-2013, 10:33 PM   #2697
Layvon
NASIOC Supporter
 
Member#: 195711
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cadillac MI
Vehicle:
STi 04/05/06/07
JBP / OBP for now

Default

I don't know much about how the chra system works but could some gummed up oil from sitting be the culprit? If it solidified maybe it got a little misaligned and thwacked stuff.. or ball bearings got boogered up?

We can all speculate but i guess we'll find out soon enough
Layvon is online now   Reply With Quote
Old 05-12-2013, 10:46 PM   #2698
shilohb
Scooby Specialist
 
Member#: 214121
Join Date: Jun 2009
Chapter/Region: TXIC
Location: Sherman Texas
Vehicle:
2005 604whp/543wtq
fp3586 twinscroll

Default

Man your luck! I hope you leave your house wearing a helmet and full body suit!
shilohb is offline   Reply With Quote
Old 05-13-2013, 10:35 PM   #2699
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Quote:
Originally Posted by Layvon View Post
I don't know much about how the chra system works but could some gummed up oil from sitting be the culprit? If it solidified maybe it got a little misaligned and thwacked stuff.. or ball bearings got boogered up?

We can all speculate but i guess we'll find out soon enough
Well, I run a filter on the turbo so I am not sure how that could happen. I checked the filter as well as the restrictor and both looked good. The turbo had oil flowing through it for sure, I primed the ever living crap out of the engine before I fired it up for the first time.
dexterous is offline   Reply With Quote
Old 05-13-2013, 10:38 PM   #2700
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

I called COMP and talked to them today. I also I shipped the turbo via USPS and according to the tracking info, it should be there by Wednesday. They said that they could possibly ship it back to me as early as Monday which will reduce my down time significantly.
dexterous is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VF37 Twin Scroll Turbo and New Tomei Twin Scroll headers/Up pipe arco SCIC Private Classifieds 11 10-22-2010 01:09 AM
Picture of my new Ultimate Racing twin scroll kit blowbyu24 Member's Car Gallery 682 08-24-2010 08:12 AM
VF37 Twin Scroll Turbo and New Tomei Twin Scroll headers/Up pipe arco Engine/Power/Exhaust 9 10-02-2009 01:04 PM
FS VA: JDM manifold, Twin Scroll kit, JDM Genome and more quadzilla Engine/Power/Exhaust 38 09-18-2008 10:22 PM
Pros and cons of twin-scroll turbo! Carisma Factory 2.0L Turbo Powertrain 59 07-04-2005 05:06 PM


All times are GMT -4. The time now is 09:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.