Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-23-2012, 08:17 AM   #326
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Man I wish I could've had a 1.42 on that second pass. Heck, even a 1.50.
* Registered users of the site do not see these ads.
JTPerryR1 is offline   Reply With Quote
Old 10-23-2012, 01:39 PM   #327
Crystal_Imprezav
Scooby Specialist
 
Member#: 84105
Join Date: Mar 2005
Chapter/Region: SCIC
Location: I'm a Newbie
Vehicle:
2005 Super Slow STi
CGM

Default

I'm sure you have said it before but what suspension do you have on now? What are you launching at now? Fuel cut or ignition cut?
Crystal_Imprezav is offline   Reply With Quote
Old 10-23-2012, 05:43 PM   #328
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Stock struts with Tein H-Tech springs. I think they're just way to soft. Ignition cut at 5800. Only building 12 psi on the 2 step
JTPerryR1 is offline   Reply With Quote
Old 10-23-2012, 06:04 PM   #329
project_skyline
Scooby Specialist
 
Member#: 153880
Join Date: Jul 2007
Chapter/Region: RMIC
Location: Western Slope, Colorado
Vehicle:
03 Evo VIII
2011 STI

Default

Those springs are junk and a half especially if your a full weight car or close to it launching that hard.

Even stock struts with something a bit stiffer would be better.

What psi are you running on those, from the video it looks like a bit much?
project_skyline is offline   Reply With Quote
Old 10-23-2012, 06:12 PM   #330
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

I agree with you. Just havent figured out what suspension to buy yet. I want something thats gonna work and keep working with more power. Had 14 psi in the tires, was gonna go lower, but 4th gear @ 141 felt a little iffy
JTPerryR1 is offline   Reply With Quote
Old 10-24-2012, 10:54 AM   #331
Crystal_Imprezav
Scooby Specialist
 
Member#: 84105
Join Date: Mar 2005
Chapter/Region: SCIC
Location: I'm a Newbie
Vehicle:
2005 Super Slow STi
CGM

Default

What do you have the DCCD set to? Have you tried running a few more psi's on the front tires?

The back half of the track always feels iffy . I remember the first time I went fast, the car felt like it was floating at the end and I ended up letting off early lol.
Crystal_Imprezav is offline   Reply With Quote
Old 10-24-2012, 11:12 AM   #332
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Dccd all the way to the back. Always worked the best for me. Haven't tried more air in front. I had the 60 fts consistent last year. Always low 1.5s best of a 1.45.
JTPerryR1 is offline   Reply With Quote
Old 10-24-2012, 11:27 AM   #333
Crystal_Imprezav
Scooby Specialist
 
Member#: 84105
Join Date: Mar 2005
Chapter/Region: SCIC
Location: I'm a Newbie
Vehicle:
2005 Super Slow STi
CGM

Default

Try putting some more air in the front tires. May 16 or 18psi front and 14psi rear. Then put the DCCD in Lock (full forward) and give that a shot.
Crystal_Imprezav is offline   Reply With Quote
Old 10-24-2012, 11:29 AM   #334
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Do you run yours in lock all the time ? You're not the first to say that
JTPerryR1 is offline   Reply With Quote
Old 10-24-2012, 02:44 PM   #335
Crystal_Imprezav
Scooby Specialist
 
Member#: 84105
Join Date: Mar 2005
Chapter/Region: SCIC
Location: I'm a Newbie
Vehicle:
2005 Super Slow STi
CGM

Default

I run mine in auto with no issues but I know of a lot of guys who do. Most end up with DCCD pro's because it apparently helps so much on launch and then the DCCD pro is programed to switch back to open (full rear) after hitting second or thrid gear.
Crystal_Imprezav is offline   Reply With Quote
Old 03-07-2013, 07:41 PM   #336
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Its been a long winter, we were kinda bored so we went to play on the dyno a little. 35 psi on C16






Street Mode

JTPerryR1 is offline   Reply With Quote
Old 03-07-2013, 07:42 PM   #337
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

We have a bunch of dyno videos, I'll post one when I get it.
JTPerryR1 is offline   Reply With Quote
Old 03-08-2013, 08:09 AM   #338
low-n-slow
Scooby Specialist
 
Member#: 313818
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: North West OH
Vehicle:
2002 wrx hybrid
WRB

Default

Oh my....

low-n-slow is offline   Reply With Quote
Old 03-08-2013, 08:13 AM   #339
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

Yeah that dyno is . Car looks niiiice
stretchedk7 is offline   Reply With Quote
Old 03-08-2013, 08:46 AM   #340
fonsworth
Scooby Newbie
 
Member#: 260681
Join Date: Oct 2010
Chapter/Region: NESIC
Location: Somerset
Vehicle:
07 sti
10.90 @ 127

Default

not the greatest quality but its something, gona be a good year this year

fonsworth is offline   Reply With Quote
Old 03-08-2013, 09:11 AM   #341
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

nice dyno. car looks and sounds great. Is that a cut out open in video??
stretchedk7 is offline   Reply With Quote
Old 03-08-2013, 10:24 AM   #342
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Quote:
Originally Posted by stretchedk7 View Post
nice dyno. car looks and sounds great. Is that a cut out open in video??

Thanks man. No cutout, full exhaust. Tomei Titanium.
JTPerryR1 is offline   Reply With Quote
Old 03-08-2013, 11:33 AM   #343
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

Sounds sexy. Thought it mighta had cut out. Look super nice to. Doesn't look like a sleeper though lol. Lots of low tens ok YouTube! Good for you man. Nice driving .
stretchedk7 is offline   Reply With Quote
Old 03-08-2013, 12:49 PM   #344
AJW Performance
NASIOC Vendor
 
Member#: 219896
Join Date: Aug 2009
Chapter/Region: NESIC
Location: Bow, NH
Default

Looks great Jay! Hope alls well.
-Tim
AJW Performance is online now   Reply With Quote
Old 03-08-2013, 01:08 PM   #345
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Thanks man ! I'm gonna try to hit the track April 6th , I'm dying to race.But in the mean time, we've been tearin up the streets.

Quote:
Originally Posted by stretchedk7 View Post
Sounds sexy. Thought it mighta had cut out. Look super nice to. Doesn't look like a sleeper though lol. Lots of low tens ok YouTube! Good for you man. Nice driving .
JTPerryR1 is offline   Reply With Quote
Old 03-08-2013, 01:10 PM   #346
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Quote:
Originally Posted by AJW Performance View Post
Looks great Jay! Hope alls well.
-Tim
Thanks Tim ! All is well, and I hope its the same for you up there. We need to talk about that suspension soon, I have less than a month to get that going.
JTPerryR1 is offline   Reply With Quote
Old 03-08-2013, 01:13 PM   #347
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

yeah i gotta tighten up my fast shifting skills. the 1/2 is killing me. going to be worse now when i air out the 67mm turbo!!
stretchedk7 is offline   Reply With Quote
Old 03-08-2013, 01:22 PM   #348
JTPerryR1
Scooby Specialist
 
Member#: 163361
Join Date: Nov 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
05 STI
10.000 @ 142

Default

Im curious to see how that BorgWarner is gonna do. I need to decide on a turbo for my other car .

Quote:
Originally Posted by stretchedk7 View Post
yeah i gotta tighten up my fast shifting skills. the 1/2 is killing me. going to be worse now when i air out the 67mm turbo!!
JTPerryR1 is offline   Reply With Quote
Old 03-08-2013, 01:34 PM   #349
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

yeah im curious to!! moore performance is fabbing up the ts header and up pipe. running hood dumped exhaust. supposedly they are almost done with it . cant wait
stretchedk7 is offline   Reply With Quote
Old 03-08-2013, 08:32 PM   #350
BlazeRex
Scooby Specialist
 
Member#: 268354
Join Date: Dec 2010
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
02 WRX 05 LGT
Slow Automatics

Default

Do you use by the book loading on that mustang or a custom number? (weight and hp@50)

EDIT just saw the post above, looks like you use 3575 and 15.7 respectively
BlazeRex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My 04 GT35R STi in the 10's on 91 octane! Scuba Steve Proven Power Bragging 107 12-07-2007 05:37 PM
For those who care..SRT-4s are now in the 10's. mhoward1 Off-Topic 13 02-14-2006 11:12 AM
First PR WRX in the 10's!!!! randyspeed Proven Power Bragging 64 01-07-2006 09:38 PM
I bets ya this thing runs in the 10's... zuczek Canada Region Forum 13 04-19-2005 10:51 PM
Anyone in the 10's or close? Easy Street WRX Proven Power Bragging 23 10-21-2002 11:27 PM


All times are GMT -4. The time now is 10:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.