Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-29-2002, 03:08 AM   #1
guitboymc
Scooby Newbie
 
Member#: 20430
Join Date: Jun 2002
Location: San Francisco, CA
Vehicle:
2002 WRX
Midnight Black Pearl

Question Engine Noise - Please Help

Sometimes when I let off the gas to push in the clutch and shift, I hear a strange rattling noise coming out of the bottom front right of my '02 WRX. I have an HKS SSQV BOV and an AEM Cold Air Intake. If the turbo spools up a whole lot, after heavy accelaration, I do not hear the noise (rather the BOV emits a loud air blast) - it only happens if I push the clutch in about 30% and then release to shift. It seems as if the BOV is blocking the air and pushing it back out the intake. Is this possible? If not, what could be the problem?

Thanks in advance....from a scooby-newbie.
* Registered users of the site do not see these ads.
guitboymc is offline   Reply With Quote
Old 06-29-2002, 07:47 AM   #2
jsmonet
Scooby Specialist
 
Member#: 14190
Join Date: Jan 2002
Location: so. cali
Vehicle:
2005 STi
white

Default

first off, prepare to be flamed all to hell by the bypass valve nazis. good luck.

second, i want to know what that sound is as well. i have mine off for now, until i can figure out just what is happening and how to fix it.
jsmonet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange noise comming from engine bay...Please help UndertoW101 Warranty Issues & SOA Problems 13 11-21-2005 11:53 AM
Problem with engine/ground/RF noise. Please help. gharari Car Audio, Video & Security 16 05-15-2005 09:52 AM
Loose engine mounts?? Weird Noises, Please Help AK*WRX*2004 Transmission (AT/MT) & Driveline 3 03-06-2005 09:20 PM
Experienced help with some engine noise please Brandon Clifton Normally Aspirated Powertrain 0 12-11-2004 04:02 PM
engine noise please help. turbome Factory 2.0L Turbo Powertrain 4 10-17-2001 10:17 PM


All times are GMT -4. The time now is 10:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.