Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-30-2010, 10:38 PM   #1
I<3APS
Scooby Newbie
 
Member#: 262525
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Bum F*** Egypt, Wisconsin
Vehicle:
'03 WRX BabyZilla
Gunmetalish?

Default 2003 WRX HELP! Knock sensor!

I have a 2003 wrx with about 50k on the motor and I am throwing code p0328 knock sensor high input. Replaced the knock sensor because thats all I read on the forums was everyone saying replacing it fixed it. It didn't make the code go away. I did the age old test with a multimeter on ac current and tapping the block with a hammer but no dice.... didnt register anything. Now I dont know if that test doesnt work because WRX knock sensors are tuned for just ping which is like 6000-7000hz which I obviously can't replicate with a hammer buttt idk... I am stumped. The car doesnt really hesitate, the code just wont turn off and I don't hear knock whatsoever. Anyone have any ideas how else to test it or what else to do? Aftermarket knock light? I need this car tuned and they wont tune it without hte knock sensor!
* Registered users of the site do not see these ads.
I<3APS is offline   Reply With Quote
Old 10-31-2010, 06:33 AM   #2
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

the orientation of factory knock is important.
did you follow the instructions?
angle?
torque?
jaxscuby is offline   Reply With Quote
Old 10-31-2010, 06:34 AM   #3
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

the orientation of factory knock is important.
did you follow the instructions?
angle?
torque?
jaxscuby is offline   Reply With Quote
Old 10-31-2010, 02:21 PM   #4
I<3APS
Scooby Newbie
 
Member#: 262525
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Bum F*** Egypt, Wisconsin
Vehicle:
'03 WRX BabyZilla
Gunmetalish?

Default

Yeah I can't remember what the torque was something undre 20ft lbs I torqued it too like 17 or something. And the pig tail gets tucked into the corner towards the tranny bellhousing. I've done it too many times to screw it up... lol Sooo yeah I'm not sure where else to check though other than starting the car up and purposely making the motor detonate to cause knock to test the sensor... but its hard to get the multimeter prong under the intercooler while the car is started.
I<3APS is offline   Reply With Quote
Old 10-31-2010, 03:22 PM   #5
rouckey21
Scooby Newbie
 
Member#: 148207
Join Date: May 2007
Chapter/Region: Tri-State
Location: Palmer, PA
Vehicle:
02 WRX
PPG box'd

Default

did u try clearing the code out and driving around for a while... you say that everything seems to be fine now that you replaced it. just clear the code and drive around for a bit and see if it comes back. if it doesn't than you have no issue if it does than its something else
rouckey21 is offline   Reply With Quote
Old 10-31-2010, 04:34 PM   #6
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Uncle Scotty is offline   Reply With Quote
Old 11-01-2010, 02:06 AM   #7
I<3APS
Scooby Newbie
 
Member#: 262525
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Bum F*** Egypt, Wisconsin
Vehicle:
'03 WRX BabyZilla
Gunmetalish?

Default

As soon as I clear the code with my code scanner it comes right back on. It will flash off for like 2 seconds then come right back even when the car isnt started up and just in the "on" position it wont go away. It shows 2 codes a "pending" one and then the actual code and they both wont go away. But thanks for that troubleshooting guid ill try it out!
I<3APS is offline   Reply With Quote
Old 11-01-2010, 02:15 AM   #8
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by I<3APS View Post
As soon as I clear the code with my code scanner it comes right back on. It will flash off for like 2 seconds then come right back even when the car isnt started up and just in the "on" position it wont go away. It shows 2 codes a "pending" one and then the actual code and they both wont go away. But thanks for that troubleshooting guid ill try it out!
did you see the link I posted, above????
Uncle Scotty is offline   Reply With Quote
Old 11-02-2010, 01:21 AM   #9
I<3APS
Scooby Newbie
 
Member#: 262525
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Bum F*** Egypt, Wisconsin
Vehicle:
'03 WRX BabyZilla
Gunmetalish?

Default

Yeah thanks for that I'll try it out on my day off tomorrow.
I<3APS is offline   Reply With Quote
Old 07-27-2013, 01:51 PM   #10
vms150
Scooby Specialist
 
Member#: 172917
Join Date: Feb 2008
Chapter/Region: NESIC
Location: Southeastern, Massachusetts
Vehicle:
2004 WRX
WRB

Default

I know I am reviving an old thread, but it's right in line with my question. It's is said that the orientation is very important. Is it possible to clock the sensor incorrectly, causing an issue and does anyone have information on the exact position it needs to be in?
vms150 is offline   Reply With Quote
Old 08-10-2013, 01:53 PM   #11
MonsterRSTI
Scooby Newbie
 
Member#: 351200
Join Date: Mar 2013
Default

I have simular issue
MonsterRSTI is online now   Reply With Quote
Old 08-11-2013, 02:00 AM   #12
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by vms150 View Post
I know I am reviving an old thread, but it's right in line with my question. It's is said that the orientation is very important. Is it possible to clock the sensor incorrectly, causing an issue and does anyone have information on the exact position it needs to be in?
yeah...it is real easy to put it in the wrong orientation

id post the page outta the fsm but im at work and dont have it handy
Uncle Scotty is offline   Reply With Quote
Old 08-11-2013, 02:44 PM   #13
Ej20_dgaf
Scooby Newbie
 
Member#: 364985
Join Date: Aug 2013
Default

Anyone know how to set the knock sensor on an apexi safc 2
Ej20_dgaf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WRX Knock Sensor Check *HELP!!!* CarbonCJC Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 09-28-2010 11:29 PM
2003 WRX Help! Breather Cover brd360sk8 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 09-10-2010 10:12 PM
FS: 2003 WRX TGV/TPS Sensors lettucemanatee Engine/Power/Exhaust 1 03-29-2010 08:36 AM
Wtb: 2003 wrx front o2 sensor Never_Satisfied1 Private 'Wanted' Classifieds 1 08-19-2009 12:01 AM
2003 WRX Tap/Knocking noise from engine? help peterislazy Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 07-31-2008 10:38 AM


All times are GMT -4. The time now is 08:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.