Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-03-2010, 11:35 AM   #1
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default 2011 WRX/STi SPT Boost Gage Issue

Well, if anyone has 2011 WRX /STi with factory installed SPT Boost Gage please read this.
I have a 2011WRX for 2months and the SPT boost gage back light started to go on and off since 2 weeks ago. I brought it to the dealership first time and they found there is voltage going in but no current. When the dealer wanted to order a new boost gage circuit board, Subaru has informed them that there is potential electrical circuit interaction between the 2011 harness with SPTís. There is no fix until further noticed. The tech has pulled the bulb out so the gage light is not blinking on and off.
[FONT='Calibri','sans-serif']Just wanted to let you guys know if you are having same problem.[/font]
* Registered users of the site do not see these ads.
2011WRX is offline   Reply With Quote
Old 11-03-2010, 02:37 PM   #2
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

I think this may be the reason that they discontinued the boost gauge. You can't order it as an option anymore.
jonklein611 is offline   Reply With Quote
Old 11-03-2010, 05:29 PM   #3
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

My car was ordered in July and took delivery in August. Sound like they discontinue this option not longer ago.
2011WRX is offline   Reply With Quote
Old 11-03-2010, 06:05 PM   #4
DiscoGsus
Scooby Specialist
 
Member#: 47646
Join Date: Nov 2003
Chapter/Region: MAIC
Location: NoVa
Vehicle:
0211 RallyWagon
DGM Sedan

Default

Quote:
Originally Posted by jonklein611 View Post
I think this may be the reason that they discontinued the boost gauge. You can't order it as an option anymore.
True. I heard this as well
DiscoGsus is offline   Reply With Quote
Old 11-05-2010, 04:33 AM   #5
sunset
Scooby Newbie
 
Member#: 52036
Join Date: Jan 2004
Location: Lake Forest, CA
Vehicle:
2011 STI Hatchback

Default

I just (today) bought a 2011 STI Hatchback and I got the boost gauge option. The dealer told me the gauges are not on hold any longer.
sunset is offline   Reply With Quote
Old 11-23-2010, 08:45 PM   #6
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Well, I just called the dealer and they told me no fix yet.
Hope yours will be no problem.

Not only the light problem but the needle also making some noise.
2011WRX is offline   Reply With Quote
Old 01-06-2011, 02:55 PM   #7
Greenberger
Scooby Newbie
 
Member#: 265267
Join Date: Nov 2010
Default

I purchased my 2011 STI in November, a less then 2 weeks later i had this same problem start.
So i have been talking to SOA for about a month now, and just received an update.

"It appears that this turbo boost gauge (for MY 2008-2010)was erroneously installed at port. There is no replacement SPT turbo boost gauge available at this time for your 2011 Impreza WRX STI."

And....

"....not likely that we will be able to offer a 2011 SPT turbo boost gauge at all."
Greenberger is offline   Reply With Quote
Old 01-06-2011, 08:59 PM   #8
salvoun
Scooby Newbie
 
Member#: 261393
Join Date: Oct 2010
Chapter/Region: NESIC
Location: Boston Metro - MA
Vehicle:
2011 WRB STI - Hatch
Navi, SS, SPT exhaust

Default

I ordered my 2011 STI a couple of weeks ago from Manchester Subaru. I was told that the boost gauge is still available and will be installed at the dealer rather than at the port of entry.
salvoun is offline   Reply With Quote
Old 01-06-2011, 09:32 PM   #9
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Good luck for anyone ordering it.

talk to SOA many times, the engineer ask me to remove the gage...stupid, dash already drilled hole

Also the gage needle is jumpy and make some noise...never had this on aftermarket gage
2011WRX is offline   Reply With Quote
Old 01-06-2011, 09:38 PM   #10
salvoun
Scooby Newbie
 
Member#: 261393
Join Date: Oct 2010
Chapter/Region: NESIC
Location: Boston Metro - MA
Vehicle:
2011 WRB STI - Hatch
Navi, SS, SPT exhaust

Default

I will be checking with the dealer tomorrow. Thanks for the heads-up.
salvoun is offline   Reply With Quote
Old 01-06-2011, 11:24 PM   #11
rxfuel
Scooby Newbie
 
Member#: 261704
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2013 Evolution
Black Pearl

Default

The dealers I talked with said it has been discontinued due to issues in the 2011 and they redesigned a new one for release in March 2011
rxfuel is offline   Reply With Quote
Old 01-20-2011, 10:38 PM   #12
SwordVan
Scooby Newbie
 
Member#: 260540
Join Date: Oct 2010
Chapter/Region: TXIC
Vehicle:
2011 STI 5-Door
WRB

Default

Quote:
Originally Posted by rxfuel View Post
The dealers I talked with said it has been discontinued due to issues in the 2011 and they redesigned a new one for release in March 2011
Mine just started flickering tonight in my 2011 STI. Any word on the new one in March and if SOA will do a full replacement when they come in? Nothing cheapens up a dash like a ****ty looking aftermarket gauge.
SwordVan is offline   Reply With Quote
Old 01-21-2011, 01:40 AM   #13
rxfuel
Scooby Newbie
 
Member#: 261704
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2013 Evolution
Black Pearl

Default

Quote:
Originally Posted by SwordVan View Post
Mine just started flickering tonight in my 2011 STI. Any word on the new one in March and if SOA will do a full replacement when they come in? Nothing cheapens up a dash like a ****ty looking aftermarket gauge.
No idea, I heard this from my dealer back in November when I was in for an oil change and was interested in ordering an spt gauge and they told me they were no longer available until March. I imagine they will cover a replacement under warranty though.
rxfuel is offline   Reply With Quote
Old 03-29-2011, 09:45 PM   #14
Ellery
Scooby Newbie
 
Member#: 267484
Join Date: Dec 2010
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
2011 Impreza WRX STI
Plasma Blue Pearl

Default 2011 SPT Boost Gage

Hmm well March has come and gone and still no Boost gage. I finally got my other 3 options installed after dicking around with an a-hole of a sale guy. Lucky the sales manager and the rest of the dealership still understands what customer service means.

So I'm contemplating just cancelling the boost gage and ask for a refund. For those who had one is it worth it? I know it should be better than an after market one.

So how many folks are still waiting for this or heard of any updates since my parts guys doesn't seem to have a clue.
Ellery is offline   Reply With Quote
Old 03-30-2011, 08:56 PM   #15
Hdshaw
Scooby Newbie
 
Member#: 219172
Join Date: Aug 2009
Chapter/Region: MWSOC
Location: Arlington Heights, IL
Vehicle:
2009 WRX sedan
white

Default

I wanted to buy this gauge for my 2009 WRX. Has anyone heard of the same issue in my model year? I have been looking but have come up with nothing.
Hdshaw is offline   Reply With Quote
Old 04-16-2011, 08:20 AM   #16
honestabe
Scooby Specialist
 
Member#: 261730
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX hatch
WRB

Default

bump, any news about the 2011 spt gauge?
honestabe is offline   Reply With Quote
Old 04-16-2011, 12:50 PM   #17
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Have been calling SOA everyday, they said by end of the month their will have the fix for 2011. It's been 8month and kinda BS waiting for the fix forever.
The reason I go with OEM is due to the warranty. My HKS boost gage on my Evo is rock steady, doesn't have the needle jiggle like the SPT.
But of course SPT match the color and interior layout
2011WRX is offline   Reply With Quote
Old 04-23-2011, 09:25 PM   #18
11DGMWReX
Scooby Newbie
 
Member#: 275518
Join Date: Mar 2011
Location: LI, NY
Vehicle:
2011 Wrx sedan
DGM

Default

I was told by my buddy who is a tech at my local dealer and he was told that the gauge will be available in may... The brochures say march but he was told may so I am waiting..
11DGMWReX is offline   Reply With Quote
Old 05-21-2011, 04:16 PM   #19
b154wheel
Scooby Newbie
 
Member#: 206874
Join Date: Mar 2009
Chapter/Region: NESIC
Location: Salem, NH
Vehicle:
2010 Impreza WRX
Black

Default

I've been having the same issues on my 2010. Now it's May. Any news heard?

I'm on my second LED bulb and both worked for a couple of months, and then would start flickering. I tried just using a regular bulb but found it was very dim. After testing the connector, I've found that the connector has full voltage (13.3v with car running) but no amps (155mA). Looks like that circuit is designed for an LED bulb. So I've been thinking of just cutting the wires and splicing it into some power and ground so I have full voltage and current and then just stick a regular bulb inside the gauge.

I'm also curious if with the gauge sitting on top of the dash in the direct sun if it is messing with the LED circuit board.
b154wheel is offline   Reply With Quote
Old 05-26-2011, 01:00 PM   #20
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Well, new parts arrived at dealer last week and I scheduled to have the update parts installed next week.
Hope it fixed the issue!
2011WRX is offline   Reply With Quote
Old 05-26-2011, 01:29 PM   #21
rxfuel
Scooby Newbie
 
Member#: 261704
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2013 Evolution
Black Pearl

Default

Quote:
Originally Posted by 2011WRX View Post
Well, new parts arrived at dealer last week and I scheduled to have the update parts installed next week.
Hope it fixed the issue!
is it just updated parts? or a whole new gauge?
rxfuel is offline   Reply With Quote
Old 05-28-2011, 02:38 PM   #22
b154wheel
Scooby Newbie
 
Member#: 206874
Join Date: Mar 2009
Chapter/Region: NESIC
Location: Salem, NH
Vehicle:
2010 Impreza WRX
Black

Default

Any news on the fix? Is it fixed?

I just fixed mine. I dumpped the LED light and modified the harness to provide full amperage so I can install a regular bulb. Looks good. I'll see how long this lasts.
b154wheel is offline   Reply With Quote
Old 06-02-2011, 10:50 PM   #23
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

Finally got my car back and they installed a new gage and the circuit board...Basically whole gage replaced.
Hope no more problem
2011WRX is offline   Reply With Quote
Old 06-27-2011, 02:04 PM   #24
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

FYI

based on car101.com

6/9/2011 turbo boost gauge is now available for WRX, STI 2008-2011. Red lit. Factory installed MSRP on a new car $335. Part price $230. Part #H501SFG500
jonklein611 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 wrx/sti paint issues??? 3rdsubaru Warranty Issues & SOA Problems 63 10-20-2012 02:38 PM
2011 Wrx vs. 2011 Wrx STI impressher General Community 202 03-09-2011 02:10 PM
2011 WRX SPT Boost Gage Problem 2011WRX Electrical & Lighting 4 11-09-2010 01:51 PM
2011 WRX and SPT performance parts GodWhomIsMike News & Rumors 0 09-22-2010 07:11 PM
Fs: (pa) 07 Sti Spt Boost Gauge sean18337 Interior/Dressup/Audio & Security 1 01-23-2008 05:00 PM


All times are GMT -4. The time now is 06:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.