Welcome to the North American Subaru Impreza Owners Club Sunday December 4, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-18-2015, 02:19 AM   #1
rocketsled
Scooby Newbie
 
Member#: 35223
Join Date: Apr 2003
Chapter/Region: SWIC
Location: Seligman, MO
Vehicle:
2002 WRX Wagon
WR Blue

Default What year o2 sensors

2002 WRX Wagon 5spd tranny with 02 ecu BUT running an '06 255 out of baja gt with stage four mods. Doing some long overdue maintenance ie. upgrade turbo to 1.5xt-r(vf34 has 120k on it!!!), k&n typhoon intake (was stock box with green filter), txs racepipe (was txs hi-flo cat), grimmspeed uppipe (was sti catless).
I want to have fresh o2 sensors when I get a protune for new parts. Probably dumb question, and I am surprised I was having such a difficult time finding the answer, but I can't decide what year sensors I should order. Currently running the 2002 sensors that came with the 2.0liter 205 and seem ok but I notice the '06 part numbers and design are different. Should I go with the '06 sensors because I am now running more displacement or stay with the '02 sensors because I am still running the '02 ecu. Guessing the latter but some more opinions would help me sleep. Thanks!!
* Registered users of the site do not see these ads.
rocketsled is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-19-2015, 10:07 PM   #2
rocketsled
Scooby Newbie
 
Member#: 35223
Join Date: Apr 2003
Chapter/Region: SWIC
Location: Seligman, MO
Vehicle:
2002 WRX Wagon
WR Blue

Default

....went with 2002 oem...sleeping fine...
rocketsled is offline   Reply With Quote
Old 10-20-2015, 09:56 PM   #3
DHRDAN
Scooby Specialist
 
Member#: 204358
Join Date: Feb 2009
Chapter/Region: SCIC
Location: Santa Paula, CA.
Vehicle:
01 2.5RS W/ EJ257
Black

Default

You should be running a wide band o2 sensor with some type of ECU management that is tunable.


Sensors always follow the engine, because that's that the Engine Management uses.



To be honest many of subaru's engines share similar sensors, so that's why it's running decent.



You're asking for trouble though. Engine> use same use Engine sensors> use engine management to tune> profit.





YOu're going about everything backward.
DHRDAN is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.