Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-11-2010, 02:23 AM   #1
Kamm99rs
Scooby Newbie
 
Member#: 253793
Join Date: Aug 2010
Chapter/Region: SCIC
Location: Orange County
Vehicle:
2005 Legacy 2.5i
black

Default Swapped 99 RS CEL Code (Gas Tank Pressure Control Solenoid)

So I did an 05 STI swap in my 99 RS last week. Everything went smoothly and it run's flawless! I only had two cel codes that came on. One was for a low MAF sensor signal, the other was for a fuel tank pressure control solenoid (from what I remember).

I fixed the MAF sensor signal, and I've heard that the STI tank has a tank pressure sensor that the RS tank does not have. The ecu is wired for the sensor, all I need to do is basically find the correct part and wire it in. It's not necessary and I've been told that it can just go anywhere basically, I just want to get rid of the cel light so I can get it Barred (I'm in CA).

So I came up with the following part number for it: 14774aa601

It's cheaper for me to just buy the sensor than flash the code out so I just wanted to see if anyone knew if that part number I came up with was the correct one. It's necessary for ALL STI/RS swaps so it's either you swap the tank and have the sensor already installed, flash the code from the ECU, do what I'm going to do, or just ignore it so I figured someone would know.
* Registered users of the site do not see these ads.
Kamm99rs is offline   Reply With Quote
Old 11-19-2010, 04:12 PM   #2
httrdd
Scooby Newbie
 
Member#: 224180
Join Date: Sep 2009
Default

What about putting a resistor on the sensor wire?
httrdd is offline   Reply With Quote
Old 11-21-2010, 05:42 PM   #3
speedyHAM
Scooby Specialist
 
Member#: 48377
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: "They eat fish soaked in lye"
Vehicle:
1996 Gutted, built
XP class Impreza L

Default

A resistor doesn't work because the ECU is looking for a changing signal depending on the input.

That part isn't necessary for all RS/STI swaps as some RS's (2000 and 2001) already had that sensor installed form the factory.
speedyHAM is offline   Reply With Quote
Old 11-25-2010, 05:15 AM   #4
Kamm99rs
Scooby Newbie
 
Member#: 253793
Join Date: Aug 2010
Chapter/Region: SCIC
Location: Orange County
Vehicle:
2005 Legacy 2.5i
black

Default

Sorry, I was referring to my model. But for future searchers, that's the part if you have a gas tank pressure sender solenoid cel code
Kamm99rs is offline   Reply With Quote
Old 12-11-2010, 11:20 PM   #5
scoobylong
Scooby Newbie
 
Member#: 127087
Join Date: Sep 2006
Chapter/Region: South East
Location: Palm Beach Gardens, Fl.
Vehicle:
1999 2.5 RS(swapped)
WRB

Default

I'm having the same problem with my 03 wrx swap on my 99rs, but my car's not even running right (sputters at certain rpms). I gotta get a new one for the rs I guess.
scoobylong is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL code P0457: Evaporative Emission Control System Leak Detected (fuel cap) aznfoos Factory 2.0L Turbo Powertrain 17 06-18-2014 09:40 AM
Fuel tank pressure control solenoid sebatsi Private 'Wanted' Classifieds 0 09-23-2009 08:22 PM
Got CEL code 440, Emission System Control Evan J. Kelly Normally Aspirated Powertrain 14 11-27-2008 11:58 AM
CEL and Gas tank problem.. Redemption Service & Maintenance 2 12-27-2007 03:36 PM
P1400 Fuel tank pressure control solenoid valve circuit low input after utec install bozz Engine Management & Tuning 7 07-28-2004 11:47 PM


All times are GMT -4. The time now is 05:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.