Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-01-2002, 06:37 PM   #1
Cujo31
Scooby Newbie
 
Member#: 19843
Join Date: Jun 2002
Chapter/Region: MWSOC
Location: St. Louis
Vehicle:
2000 2.5 RS Sedan
Silverthorn Mettalic

Default Annoying noise when pushing clutch pedal.. where to lube?

Maybe hopefully one of you guys have had this.

when I push the clutch pedal in even when the car is off, as it nears the floor, there's a annoying slight vibrating 'rubbery' type of noise

i got under there to check it out while i pushed the pedal with my hand, and it seems to be coming from where the linkage goes throught the firewall..

I'm thinking i need some grease somewheres, but I'm not exactly sure where...

any ideas?


I'll take it to the dealer if I have to, as i do have a warranty and what not... but if its a quick fix I'd like to get rid of the annoyance asap

thanks!
* Registered users of the site do not see these ads.
Cujo31 is offline   Reply With Quote
Old 07-01-2002, 07:06 PM   #2
Julian
Scooby Specialist
 
Member#: 1182
Join Date: Mar 2000
Location: Ventura, CA
Vehicle:
MY00 RS
BRP

Default

Clutch creak. It's been talked about before, but I haven't seen the subject pop up recently. Supposedly you just grease the clutch slave cylinder piston (you'll have to have someone push the clutch in for you). I forget now.

But I have the sound you're talking about. I can also feel it when depressing the clutch pedal fully. Haven't taken it to Subaru yet. I may before the warranty is up. Is the slave cylinder covered under the powertrain warranty?
Julian is offline   Reply With Quote
Old 07-01-2002, 07:18 PM   #3
Mops
Scooby Newbie
 
Member#: 16845
Join Date: Mar 2002
Location: Auckland, NZ
Vehicle:
1994 Legacy RS
Navy Blue

Default

I had similar thing in my 94 Legacy RS (jap version)
+ the other problem... clutch pedal was sticking down everytime i reved the engine to abouve 4k rpm (it came out about half way - the clutch was engaged so i could normally drive, but it was really annoying). It didnt make any strange sound tho. Anyways, my friend who is a diesel mechanic looked into it and we replaced slave clutch cylinder - and that fixed it.. but not entirely - still sometimes (very rare) clutch comes up only half way through - mostly when i rev it very high on 1st gear. Probably thats due my not-in-good-condition clutch pressure plate.

Anyways... it's just my fev lines on the topic.
Mops is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"honking" noise when pushing in clutch califesaver Transmission (AT/MT) & Driveline 7 07-14-2009 03:57 AM
Clutch pedal stays to the floor when car's hot RyansJDMgc8 Transmission (AT/MT) & Driveline 41 09-28-2005 04:52 PM
Strange noise when pushing in clutch? Help! crazee195 Transmission (AT/MT) & Driveline 6 07-18-2005 11:14 PM
"Pshhhhhh" noise when pushing in clutch? Ging Service & Maintenance 11 11-02-2004 07:07 PM
Tranny noise at startup when cold, clutch pedal out... Cosworth Transmission (AT/MT) & Driveline 4 01-09-2002 02:20 PM


All times are GMT -4. The time now is 08:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.