Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2010, 10:25 PM   #1
nicko360
Scooby Newbie
 
Member#: 249036
Join Date: Jun 2010
Chapter/Region: NWIC
Location: Bellingham WA
Vehicle:
2002 rhd s2000
spa yellow

Default need a new computer help?

just picked up a 98 legacy gt sedan w the 2.5 engine

the car idles low and check engine is on, previous owner told me he took it to a mechanic and swears up and down that they all told him it needs an ECU. my question is, will an automatic ecu work (car is a 5 speed) I cant seem to find a 5 speed ecu online for a 98. also will a 97 or 99 ecu work? thanks
* Registered users of the site do not see these ads.
nicko360 is offline   Reply With Quote
Old 11-20-2010, 02:17 AM   #2
Jonathan
Scooby Guru
 
Member#: 4021
Join Date: Feb 2001
Chapter/Region: NESIC
Location: Natick, MA USA
Vehicle:
1999 Legacy GT Ltd
Quick Silver Metallic

Default

Yes, you can use an ECU from an automatic in a manual (or the other way around) with out issues.

My understanding is the fuel tank on the 99's has different emission issues so it may or may not work. You might want to swap in the newer fuel tank and evaperative emission controls from the 1999 model along with the newer '99 ECU.

You can also use an ECU from a '98 Impreza RS, although the '99+ Impreza used the MAP sensor instead of the MAF sensor so those are out.

Do to all the changes in the '99 2.2 motor, their ECU will not work in any pre 2000 EJ25 powered cars. You could use an ECU from an earlier 2.2 motor, although the electronically controlled speed limiter would kick in at ~ 112 MPH.

Last edited by Jonathan; 11-20-2010 at 02:23 AM.
Jonathan is offline   Reply With Quote
Old 11-20-2010, 03:20 AM   #3
kirbykirb
Scooby Newbie
 
Member#: 183596
Join Date: Jul 2008
Chapter/Region: South East
Location: USA
Vehicle:
2005 WRX/9-2x
Obsedian Black Pearl

Default

I have an ECU available if you need to test it out. :P
kirbykirb is offline   Reply With Quote
Old 11-20-2010, 03:59 AM   #4
Huffer
Scooby Specialist
 
Member#: 36735
Join Date: May 2003
Chapter/Region: MWSOC
Location: Wellington,NZ / Willoughby,OH
Vehicle:
99 GF8 Impreza 2.0
2= 1998 BD + BK Legacy GT

Default

Quote:
Originally Posted by nicko360 View Post
the car idles low and check engine is on,
How low is the idle, and what is the CEL code for?

If the car runs and drives fine otherwise, my guess is that the PO was too lazy to fix the real issue. ECUs don't fail often, and a low idle isn't usually an ECU problem.
Huffer is offline   Reply With Quote
Old 11-20-2010, 05:56 PM   #5
nicko360
Scooby Newbie
 
Member#: 249036
Join Date: Jun 2010
Chapter/Region: NWIC
Location: Bellingham WA
Vehicle:
2002 rhd s2000
spa yellow

Default

Quote:
Originally Posted by Huffer View Post
How low is the idle, and what is the CEL code for?

If the car runs and drives fine otherwise, my guess is that the PO was too lazy to fix the real issue. ECUs don't fail often, and a low idle isn't usually an ECU problem.
check engine is on, car sometimes at idle drops to 500 and acts like its going to die, ive always worked on hondas and never really ran into the problem of a bad ecu, but i was wondering if maybe it was a subaru think

also the car sounds like it has a bad wheel bearing and the abs engages at low speeds, the seller told me somehting was wrong with the hub and it would be best to just replace the whole thing
nicko360 is offline   Reply With Quote
Old 11-20-2010, 06:04 PM   #6
nicko360
Scooby Newbie
 
Member#: 249036
Join Date: Jun 2010
Chapter/Region: NWIC
Location: Bellingham WA
Vehicle:
2002 rhd s2000
spa yellow

Default

so my other question is, will any hub assembly off a 96-99 work the same or does it need to be exclusivley off a gt>
nicko360 is offline   Reply With Quote
Old 11-21-2010, 08:45 AM   #7
Huffer
Scooby Specialist
 
Member#: 36735
Join Date: May 2003
Chapter/Region: MWSOC
Location: Wellington,NZ / Willoughby,OH
Vehicle:
99 GF8 Impreza 2.0
2= 1998 BD + BK Legacy GT

Default

What is the CEL code?
500 isn't bad, the tach starts at 500.
Sounds like you need to clean the idle air control valve. In the winter these cars have a fluctuating idle if the ambient air temp is quite cold.

If it sounds like a bad wheel bearing, and the ABS continues to engage, then it could be a broken ABS sensor ring.
Huffer is offline   Reply With Quote
Old 11-21-2010, 02:34 PM   #8
nicko360
Scooby Newbie
 
Member#: 249036
Join Date: Jun 2010
Chapter/Region: NWIC
Location: Bellingham WA
Vehicle:
2002 rhd s2000
spa yellow

Default

Quote:
Originally Posted by Huffer View Post
What is the CEL code?
500 isn't bad, the tach starts at 500.
Sounds like you need to clean the idle air control valve. In the winter these cars have a fluctuating idle if the ambient air temp is quite cold.

If it sounds like a bad wheel bearing, and the ABS continues to engage, then it could be a broken ABS sensor ring.

some times the idle drops though and it dies at stopsigns, im going to have the CEL checked today. and when it idles between 500-1000 it sputters like its goin to die
nicko360 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need a lil computer help, blue screen of death. Hondaslayer Off-Topic 15 01-31-2006 07:30 PM
Need a little computer help linux>windows Off-Topic 34 12-30-2004 02:58 PM
Need a new computer KapaFool Alaskan Impreza Club Forum -- AKIC 46 10-28-2004 01:11 AM
I need a new computer, help me choose please BrysImpreza New England Impreza Club Forum -- NESIC 24 09-05-2003 11:03 PM
Gauging Interest - do you need a new computer? maaw Bay Area Impreza Club Forum -- BAIC 4 07-12-2003 01:51 AM


All times are GMT -4. The time now is 09:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.