Welcome to the North American Subaru Impreza Owners Club Monday July 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-02-2002, 10:54 AM   #1
Sparks
Scooby Specialist
 
Member#: 16495
Join Date: Mar 2002
Chapter/Region: South East
Location: Jacksonville
Vehicle:
2013 BRZ
Sterling Silver Metallic

Default Help with CEL P0457 EVAP

Well I changed my inlet pipe (Samco) over the weekend and now the CEL won't clear.

I stopped by AutoZone to see what the code was and they said P0457. I did some checking and searching and can find nothing about that code but I did find P0456 - Evaporative emission control system malfunction (pretty close to what AutoZone said).

I checked all my vac lines to make sure they're hooked up.

Anyone had this code or can offer any trouble shooting help?

Thanks-in-advance,

Shaun
* Registered users of the site do not see these ads.
Sparks is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-02-2002, 11:23 AM   #2
kenshiro
Scooby Specialist
 
Member#: 15917
Join Date: Mar 2002
Vehicle:
2002 teh FastAR rex
Black like my soul

Default

Tighten your gas cap dude.

P0457 Evaporative emission control system leak detected (fuel filler cap loose/off)

http://66.24.68.150/wrx/2002troublecodes.txt
kenshiro is offline   Reply With Quote
Old 07-02-2002, 11:42 AM   #3
Sparks
Scooby Specialist
 
Member#: 16495
Join Date: Mar 2002
Chapter/Region: South East
Location: Jacksonville
Vehicle:
2013 BRZ
Sterling Silver Metallic

Default

THAT is a nice link to have. I spent all morning looking for that exact reference.

I'm off to re-seat my gas cap.
Sparks is offline   Reply With Quote
Old 07-03-2002, 09:54 PM   #4
Sparks
Scooby Specialist
 
Member#: 16495
Join Date: Mar 2002
Chapter/Region: South East
Location: Jacksonville
Vehicle:
2013 BRZ
Sterling Silver Metallic

Default

Filled up the tank and made sure the gas cap is on.

The CEL has came back.

What should I look for?
Sparks is offline   Reply With Quote
Old 07-03-2002, 10:48 PM   #5
bingo
Scooby Newbie
 
Member#: 13665
Join Date: Dec 2001
Location: Montreal, Canada
Vehicle:
2004 sti
rally blue

Default

Is it back? or never went off. If it never went off you can either re-set (remove battery ground and pump brake pedal) or leave it alone and it will go off after a while.

If it went away and then came back, I am stumped.
bingo is offline   Reply With Quote
Old 07-04-2002, 09:29 AM   #6
Sparks
Scooby Specialist
 
Member#: 16495
Join Date: Mar 2002
Chapter/Region: South East
Location: Jacksonville
Vehicle:
2013 BRZ
Sterling Silver Metallic

Default

The code keeps coming back after clearing it.

Anyone have service manual info on the EVAP system.

I'm wondering what components are in the loop (PCV, head vents, gas cap, ect..)
Sparks is offline   Reply With Quote
Old 07-04-2002, 09:45 AM   #7
Cocoa Beach Bum
Scooby Specialist
 
Member#: 17355
Join Date: Apr 2002
Default

It's possible, according to this memo, that this trouble code is spurious and the problem is within the ECU.
Cocoa Beach Bum is offline   Reply With Quote
Old 07-15-2002, 09:00 AM   #8
kenshiro
Scooby Specialist
 
Member#: 15917
Join Date: Mar 2002
Vehicle:
2002 teh FastAR rex
Black like my soul

Default

Take it to the dealer.
kenshiro is offline   Reply With Quote
Old 07-15-2002, 10:35 AM   #9
Sparks
Scooby Specialist
 
Member#: 16495
Join Date: Mar 2002
Chapter/Region: South East
Location: Jacksonville
Vehicle:
2013 BRZ
Sterling Silver Metallic

Default

I fixed it.

Found a vac line off under the intake. Right next to the inlet pipe, small blue connector.
Sparks is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
****need Help With Cel Codes-please Help************** stito Subaru Conversions 4 07-29-2007 04:55 AM
Need help with Cel code. WRX Joe Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 08-16-2002 10:40 PM
need help with CEL slammedWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 08-06-2002 12:16 AM
Help with CEL! WRXavier Service & Maintenance 3 06-26-2002 08:24 PM
Need help with CELs BluJay Tri-State Area Forum 3 11-03-2001 08:31 PM


All times are GMT -4. The time now is 01:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.