Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-01-2010, 06:08 PM   #1
GusGus91
Scooby Specialist
 
Member#: 201312
Join Date: Jan 2009
Chapter/Region: SWIC
Location: Reno, NV
Default 08-10 sti owners question!

So i have an 08 sti, completely stock. So I noticed today when I'm in sport sharp and I floor it, at about 4500rpms the car kinda feels like it gives out for a split second, then it keeps pulling like nothing happened.. Any ideas? Ifyou need more info just ask. I was thinking maybe there's too Much restriction in the exhaust? I don't really know. That's why I'm here asking you guys. Thank you in advance
* Registered users of the site do not see these ads.
GusGus91 is offline   Reply With Quote
Old 12-01-2010, 06:14 PM   #2
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

It's probably the crappy stock tune, are you planning on upgrading anything in the future?

Mike
GrimmSpeed is offline   Reply With Quote
Old 12-01-2010, 06:19 PM   #3
GusGus91
Scooby Specialist
 
Member#: 201312
Join Date: Jan 2009
Chapter/Region: SWIC
Location: Reno, NV
Default

I was just planning on doing a Catback until my warranty is up in 2012.. Lol it's my DD so I wasn't gonna go crazy.
GusGus91 is offline   Reply With Quote
Old 12-01-2010, 06:24 PM   #4
TheBaran06
Scooby Newbie
 
Member#: 198216
Join Date: Dec 2008
Chapter/Region: MWSOC
Location: Lake St. Louis, MO
Vehicle:
2008 Infiniti G37S
2004 GSX-R600

Default

Could be the turbo. Is this your first Turbo car? Because a lot of times with the way the boost is you have to slightly ease on the gas before railing it. There's going to be a split second where the motor has to react to the fact that its wide open throttle. Let it sit at 4k rpm for a couple minutes driving and then floor it, does it still hesitate?
TheBaran06 is offline   Reply With Quote
Old 12-01-2010, 06:42 PM   #5
GusGus91
Scooby Specialist
 
Member#: 201312
Join Date: Jan 2009
Chapter/Region: SWIC
Location: Reno, NV
Default

No not my first turbod car. I have a 06 WRX with a hta green.. Well it's already boosting. Just feels like it does it in the middle of boost, cuts out real quick, then keeps pulling
GusGus91 is offline   Reply With Quote
Old 12-01-2010, 06:49 PM   #6
GusGus91
Scooby Specialist
 
Member#: 201312
Join Date: Jan 2009
Chapter/Region: SWIC
Location: Reno, NV
Default

If I let it sit at 4k for a couple seconds before I step on it it doesn't seem to do it. But I've only tried that in second

EDIT: still does it in 4th
GusGus91 is offline   Reply With Quote
Old 12-01-2010, 11:00 PM   #7
TheYoungblood91
Scooby Newbie
 
Member#: 243862
Join Date: Apr 2010
Location: Santa Cruz, CA
Vehicle:
2003 wrx 30r'd
white

Default

Try One Step Colder plugs. Also make sure that subaru put the new map on there from the Recall. SOA made a new map for the 08's..
TheYoungblood91 is offline   Reply With Quote
Old 12-02-2010, 03:28 AM   #8
Screwbal
Scooby Newbie
 
Member#: 196946
Join Date: Dec 2008
Chapter/Region: NWIC
Location: Kent, WA
Vehicle:
2007 Wrx limited WRB
07 FXT WRB,'14 limitedBRZ

Default

If u register the car on subaru.com u might be able to see if it was already flashed from SOA. I picked up my newer STI this weekend and registered it online and saw the service history saying the dealership did it when the car had 58 miles.
Screwbal is offline   Reply With Quote
Old 12-02-2010, 03:34 PM   #9
GusGus91
Scooby Specialist
 
Member#: 201312
Join Date: Jan 2009
Chapter/Region: SWIC
Location: Reno, NV
Default

Okay, I will register it. thank you.
GusGus91 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB 08-10 sti springs, 08-10 aftermarket/custom exhaust subiehatch09 Private 'Wanted' Classifieds 2 08-11-2010 11:27 AM
WTB : Spoiler from 09-10 WRX hatch or 08-10 STI iDrove Private 'Wanted' Classifieds 1 06-23-2010 12:08 PM
WTB 08-10 sti springs or 09-10 wrx springs TwinRider MWSOC Private Classifieds 0 05-14-2010 07:31 PM
any 08-10 WRX owners with a Perrin exhaust? Westside PDX Sideways North West Impreza Club Forum -- NWIC 9 01-27-2010 03:26 PM
WTT : 08 STi BBS. Your 08 - 10 STi 5 spokers + cash paikman MAIC Private Classifieds 2 09-22-2009 05:18 PM


All times are GMT -4. The time now is 01:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.